Diablo® III

"Login" Button Grayed Out?

85 Draenei Paladin
2215
As the title suggests the "Login" button after D3 loads is grayed out, so i cannot login.

I got the annual pass, checked battle.net and diablo 3 is "active".

When i installed i clicked "already active" and that was the last i heard of it.

I thought after 11pm UK (12am CEST) the button would turn red and allow me to play but to no avail.

I re-installed, still nothing. But looking on youtube i see the button is red for others, even before launch, but they weren't able to login.

That means its something else and i cannot figure out what it is, or find any other threads about it.

If anyone can help, please do so. I would really like to play the game i payed for lol.

I also wasn't asked for a product key, nor did i receive one, if that helps.
Reply Quote
Customer Service
Hello,

Please try the following:

Windows XP:

Press the Windows Key + R
Type CMD in the box and press OK

Windows Vista / 7:

Go to the Start Menu and search for 'command prompt'
Right click on the command prompt program and choose 'run as admin'

Then type the following in the command prompt window:
netsh winsock reset

Preess Enter, then power off your router for a few minutes and restart your computer.

Please then try the game after this.
Reply Quote
85 Draenei Paladin
2215
You absolute hero, worked.

Thanks for the quick reply!
Reply Quote
Got the same problem on my macbook pro(late 2008). Please help
Reply Quote
i have same proplem
Reply Quote
exact same problem.. mac pro.. don't know what to do and really frustrated
Reply Quote
There's no Winsock on the Mac, so that won't help you, but you could try to Flush your DNS. Provided you have Leopard (10.5.x), Snow Leopard (10.6.x), or Lion (10.7.x), you can perform the following command:

For all versions of OSX, the simplest way to flush your DNS cache is to start “Terminal” which you can find in “Applications” > “Utilities” > “Terminal”. Once you’ve done that type (or copy + paste) into the Terminal:

dscacheutil -flushcache
Reply Quote
i am having the same problem, but it is for the US midnight release. ideas?
Reply Quote
forgot to mention that it is on a mac and that i already tried the above
Reply Quote
Its 2:28 in Texas and I can't press the login button battle.net account name in and password just grayed out loginn button please help.
Reply Quote
And I'm on a mac
Reply Quote
Same whats going on? I live in Texas also!
Edited by Drtywrks#1574 on 15/05/2012 08:36 BST
Reply Quote
I've stayed up to check this out and I can't login been waiting since 12:30am
Reply Quote
This sucks..
Reply Quote
Win7 and solution posted didn't work for me. :(
Reply Quote
Same issue, put in all my log in information and login button is still greyed out, HELP!

Edit: have tried the command prompt reset and powered down comp and router to no difference

Edit2: So tried typing in my email for battlenet not my battle tag and the button turned red, but still get a message that the servers are to busy. Hope this helps
Edited by Ent#1344 on 15/05/2012 08:46 BST
Reply Quote
Same thing here. Login button greyed and tried the above fix for win7 and no worky
Reply Quote

Edit2: So tried typing in my email for battlenet not my battle tag and the button turned red, but still get a message that the servers are to busy. Hope this helps


Thanks, thought it wanted my battletag, so thats one issue down lol.
Reply Quote
I'm having this issue as well. I tried the winsocket reset but to no avail.

Im using windows 7.
Reply Quote
I tried the winsock reset and I am still having this issue as well.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]