Diablo® III

Constant freeze and black screen....

(Locked)

Tried all suggested fixes and the game still crashes my pc. I hope blizzard addresses this soon
Game plays fine Quests 1-4#..As soon as i get into the Fields of miserary BAM! Freezes up and have to hard boot my computer. My computer is far past specs. I bought this game 2 days ago and its a lot of fun but i am completely dissapointed! Please fix soon a lot of people spent money on this game and cant even play it
my problem lasts 21 days and blizzard Are you kidding me? Now in addition to boot I have to reset it and then reset again but with a button, otherwise I have the same thing with Diablo, and all of the Diablo, and on the main site only about real money at an auction or some hopeless shirts, why do not you write that fu**ed up the optimization of the card?

and like another guy from Blizzard to write me something about overheating:

any other recent game works for me full detail and IT can work through the weekend, you understand?

P.S my next barbarian died for lack of optimization, hardcore record at lvl 42, then blackscreen's BY PATCH from the beginning of JUNE for now.
Edited by BrutalDemon#2164 on 21/06/2012 11:55 BST
i've been witnessing the same problem, fail to play any single minute without crashing/freezing.
start playing diablo 3 since 2 days ago, and now still on lvl 4
tried my best with all of recommended solutions, but all fails :(
bump and really need the help from Blizzard or someone :(
Same problem for me :
Windows 7 ultimate x64
intel core i3 2120
radeon HD 6850

Freeze a few seconds --> black screen --> come back in game (no reboot for me)

But it's very annoying ...

Does someone have any fix or solution?
2 Undead Warrior
0
Posts: 3
Same for me, every minute! Nvidia GTX 280
Have you tried running in fullscreen window mode? It stopped crashing entirely for me.
Posts: 22
SAME! Blizzard - this problem was from begining LOTS and LOTS of players have this isue and you have not solved it?! Please do something!! Investigate and give us answer! Tired of this black screen already X(

btw card 9800 GTX+ - drivers up to date!
Edited by Kewle#1252 on 24/06/2012 17:47 BST
i managed to fix mine. i installed windows 8 :/
Posts: 51
I have same problem , Freeeeeeeeeeeez , Plz help us blizzard
Hi Guys,

i've fixed the FMOD Error today by updating my Realtek High Definition Audio Driver from 2.66 to 2.70. But the freeze problem stil remain, i've found the exact spot where i get the freeze up, it's at the Drowned Temple at Act 1. When i enter the cave, everything goes fine, but when i'm at the middle of the bridge i get the freeze up, blackscreen with the ambient sound on the background. The second freeze up is at the Fields of Misery, most of the time it's random. And the third freeze up is at the large bridge before entering the last dungeon.

So after all these freezeups, i'm a little tired about playing Act 1, i can't complete certain quests, only with some help of my friends (waiting in town, and when they have complete the quest rejoin the party by clicking on the banner).

Here are my specs:

ATI Radeon HD 5700 Series

2012.06.24 19:54:17.310031500 Diablo III Release (No Assertions) running under Windows 7-64 SP1 (Version 6.1.7601)
2012.06.24 19:54:17.310152500 <BUILD>1.0.3.10057 (48345-690636)</BUILD>
2012.06.24 19:54:17.310258000 Cheats: DISABLED
2012.06.24 19:54:17.310386000 CPU Vendor: AuthenticAMD
2012.06.24 19:54:17.310480500 CPU Details: AMD Phenom(tm) II X4 955 Processor
2012.06.24 19:54:17.310569500 CPU Processors: 1
2012.06.24 19:54:17.310654000 CPU Cores: 4
2012.06.24 19:54:17.310737500 CPU Threads: 4
2012.06.24 19:54:17.310823000 4095.24 MB of total physical memory
2012.06.24 19:54:17.310913000 OS Language: ......
2012.06.24 19:54:17.310993500 Application Path: D:\Games\Diablo III\
2012.06.24 19:54:17.312669500 --- OS memory stats -----
2012.06.24 19:54:17.312801500 Virtual size: 113.43 Mb
2012.06.24 19:54:17.312886000 Total free: 3966.37 Mb
2012.06.24 19:54:17.312965000 Largest free block: 2047.75 Mb
2012.06.24 19:54:17.313043500 --- OS memory stats end-----
2012.06.24 19:54:17.313117500 ----------------------------------------------

And the last D3Debug.txt lines between two crashes in the Drowned Temple:

2012.06.24 19:55:38.495135000 -----------------------------------------------------------------
2012.06.24 19:55:38.495269000 Server Version Information:
2012.06.24 19:55:38.495353500 -----------------------------------------------------------------
2012.06.24 19:55:38.495430500 Server BuildVersion: 1.0.3.10182
2012.06.24 19:55:38.495514000 Server SNOPackHash: 0x40306D97 (client hash = 0x40306D97)
2012.06.24 19:55:38.495597500 Server ProtocolHash: 0xFDD6012B (client hash = 0xFDD6012B)
2012.06.24 19:55:38.495673500 -----------------------------------------------------------------
2012.06.24 19:55:39.255773000 Initializing client world trdun_Cave_Nephalem_03...
2012.06.24 19:55:40.96364000 Initializing client world trOUT_Town...
2012.06.24 19:55:49.898242500 de activate app 0 iconic 0
2012.06.24 19:55:50.159704500 TestCoopLevel - D3DERR_DEVICELOST
2012.06.24 19:57:12.443287000 de activate app 1 iconic 1
2012.06.24 19:57:12.576636000 ACTIVATE APP 1 iconic 0
2012.06.24 19:57:12.580788000 TestCoopLevel - D3DERR_DEVICENOTRESET
2012.06.24 19:57:12.604495000 Reset() Attempt started - soft reset!
2012.06.24 19:57:12.864484500 Est. Available Texture Memory = 2790 MB
2012.06.24 19:57:12.864636000 DeviceReset() succeeded!
2012.06.24 19:57:12.865450000 Setting depth texture, fmt = 36
2012.06.24 19:57:12.865665500 PostFXGfxInit() success
2012.06.24 19:57:12.866401500 SubObjectGfxInit() 1
2012.06.24 19:57:13.388575000 TestCoopLevel - S_OK
2012.06.24 19:57:36.6481000 de activate app 0 iconic 0
2012.06.24 19:57:36.105366500 TestCoopLevel - D3DERR_DEVICELOST
2012.06.24 19:58:12.405895000 de activate app 1 iconic 1
2012.06.24 19:58:12.539315500 ACTIVATE APP 1 iconic 0
2012.06.24 19:58:12.543480000 TestCoopLevel - D3DERR_DEVICENOTRESET
2012.06.24 19:58:12.552322500 Reset() Attempt started - soft reset!
2012.06.24 19:58:12.745600500 Est. Available Texture Memory = 2790 MB
2012.06.24 19:58:12.745751000 DeviceReset() succeeded!
2012.06.24 19:58:12.746446000 Setting depth texture, fmt = 36
2012.06.24 19:58:12.746664500 PostFXGfxInit() success
2012.06.24 19:58:12.747211500 SubObjectGfxInit() 1
2012.06.24 19:58:13.255543000 TestCoopLevel - S_OK
2012.06.24 19:58:32.277397000 de activate app 0 iconic 0
2012.06.24 19:58:32.364577500 TestCoopLevel - D3DERR_DEVICELOST
2012.06.24 19:58:57.764391000 de activate app 1 iconic 1
2012.06.24 19:58:57.897150500 ACTIVATE APP 1 iconic 0
2012.06.24 19:58:57.901530000 TestCoopLevel - D3DERR_DEVICENOTRESET
2012.06.24 19:58:57.916406000 Reset() Attempt started - soft reset!
2012.06.24 19:58:58.144148000 Est. Available Texture Memory = 2790 MB
2012.06.24 19:58:58.144328500 DeviceReset() succeeded!
2012.06.24 19:58:58.145202500 Setting depth texture, fmt = 36
2012.06.24 19:58:58.145408500 PostFXGfxInit() success
2012.06.24 19:58:58.145911500 SubObjectGfxInit() 1
2012.06.24 19:58:58.637597500 TestCoopLevel - S_OK
2012.06.24 20:00:00.916797500 de activate app 0 iconic 0
2012.06.24 20:00:01.12830500 TestCoopLevel - D3DERR_DEVICELOST
2012.06.24 20:00:21.751643000 de activate app 1 iconic 1
2012.06.24 20:00:21.885288500 ACTIVATE APP 1 iconic 0
2012.06.24 20:00:21.889698000 TestCoopLevel - D3DERR_DEVICENOTRESET
2012.06.24 20:00:21.906580500 Reset() Attempt started - soft reset!
2012.06.24 20:00:22.110502000 Est. Available Texture Memory = 2790 MB
2012.06.24 20:00:22.110709000 DeviceReset() succeeded!
2012.06.24 20:00:22.111578000 Setting depth texture, fmt = 36
2012.06.24 20:00:22.111830000 PostFXGfxInit() success
2012.06.24 20:00:22.112420000 SubObjectGfxInit() 1
2012.06.24 20:00:22.602289500 TestCoopLevel - S_OK

Are there more people with the same Act 1 freeze ups?
I get the freeze then 30 seconds later it resumes with a disconnected from server box.

NVIDIA: GTS 250 (Im seeing alot of these in the comments.... fml)
7 Human Mage
0
Posts: 3
This is the solution and its charm working for me!!!
I have GFX280 and no single black screen or freeze since.

1. Go to http://www.evga.com/support/download/
2. Register and download Precision X
3. Click the "fan curve" button and enable "software automatic fan control"
You are done.

Hope its working for you all too
You can thank me after :)
You mean GTX280? i have one, i check this and tell me, what i Precision X?
Same here, coupled with an occasional system reboot. Submitted a ticket a few days ago, but got no answer yet. Radeon HD 8750 OC, drivers up to date, temperatures and voltage are all fine.
I have 3 comps all run D3 fine but it seems older nvidia cards and 19 inch monitors just shut off the OS and or the monitors go into sleep mode and the comps still running. This has nothing to do with cards or PSU or CPU's but only happens in diablo 3 which seems like a major game engine design flaw. remember Blizz now is about money and not customer base so all this was well known but they still had it launched anyway. Blizz north was dismantled ages ago because they were about creating games people like and not bringing in instant cash. Blizz has lost all integrity and trust with its fan base and now run with greedy SOB's. You could easily tell people you were to lazy and this is what the game needs but that would hurt sales. I got two fingers flyin straight up for blizz now.
I've had this problem since getting a new card - Hd 7850 Gigabyte OC (upgraded from 5850)
had freezing and as everyone has stated black screen / monitor turn off after 1 - 3 minutes of play etc etc.

The way I fixed mine was to underclock my card it is currently running:
GPU clock: 850Mhz
Memory Clock: 1000Mhz
(I just changed the settings in the catalyst centre - (AMD overdrive tab)
I'm running 12.6 version of catalyst.

my in game settings are 150fps for foreground and 10 for background and all my graphical settings are set to their highest. I have Vsync on and anti aliasing on.
full screen and 1920x1080. through HDMI.

This fixed mine - I know there are a lot of Nvida users on here too and I'm sorry I don't have info for you. I will keep an eye on this thread for as long as I can to try and answer any questions people post. - hopefully this helps some of you.

Regards,
Temorah.
i got the same problem, already change all setting to low, and set fps to 50.
not help at all, the blank screen still there.

my graphic card is nvidia gforce gtx550 ti
I have tried all of the above
including repasteing my thermal paste on the video card
cutting back my framerate 54 56
have the lastest drivers

BLANK BLANK BLANK 3 seconds sometimes ,
sometimes to desktop

sit awhile go to game ow and R.I.P. dead

this sux so much ! almost unplayable !
This thread is locked.

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]