Diablo® III

nvidea geforce 9400, will this low fps ever get fixed?

first of all, i will start by saying that i love diablo, and when its playable, diablo 3 is already one of my favorite games. however, ever since i started act 2, my fps is hovering at about 8-13, which makes the game unplayable. i have read up on this and found out that everyone else that has the same graphic card is having the same problem. i really hope this gets fixed, because if it doesnt soon, i will be asking for a full refund. i am also dissapointed that blizzard told me that my 24 inch imac with the 10.7.4 update would run the game smoothly, and it has done the opposite. so, do you guys think it will ever be fixed, or am i kinda screwed for life on this one?
Reply Quote

The problem might be your video card was released when dirt was new.

That's to say: it's flipping old. Blizz link above lists your card on the low perf chart.

Your fps issues aren't Blizzard's fault; they're yours. You can get a great video card for around 120$ that will run the game perfectly. You already spent 60, what's another 120?
Reply Quote
i cant get a video card, it is apart of the computer and saudered into the computer, therefore i couldnt even spend the 120$ if i wanted to
Reply Quote
110 Human Paladin
Posts: 39
Its low end quite old budget card, it can play the game but that doesnt mean it has to play it well. Blizzard has nothing to do with it. Did you try setting everything to low in graphics options?
Reply Quote
Posts: 13
Look for FPS configs, they might increase it to 20ish atleast if you're lucky.

Else buy a new computer without that !@#$ty "locked GPU/CPU" etc.
Reply Quote
What's to fix there? I'll tell you in a plain text: GeForce 9400 is a piece of crap. It was an entry level budget GPU back 4 years ago when it launched.

That thing is not meant for modern gaming.

Fun fact, it actually cost LESS than Diablo 3 back then.
Edited by Zelas#2388 on 18/05/2012 08:14 BST
Reply Quote
Don't listen to people here,they don't know what they are talking about.What you need to do is go into your Diablo 3 config file,found in Documents in your D3 folder.

Find these lines:
DisableTrilinearFiltering "1"
HardwareClass "1"

Make sure the values both have ones.I was having trouble with perforamance until I changed these settings,and now D3 runs great on my 2008 laptop and it only chugs a bit during huge crazy battles,which thankfully isn't too often.
Reply Quote
>buy a mac
>play games on it
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Explain (256 characters max)