Diablo® III

Launcher stuck at "Launching"

(Locked)

85 Night Elf Druid
3275
Posts: 16
Yoyoyoy good people!
My launcher is currently stuck at "Launching".
When i open up my launcher it starts out by being stuck at "Updating tools 0%".
When i kill the Agent.exe it moves on to "Initializing" and after 3-4 seconds to "Game is up to date" (by now i have a new Agent.exe popping up).
When i press "PLAY" i immediatly get stuck at "Launching" (tried killing the Agent.exe before pressing play aswell).

tried disabling peer-to-peer.
Tried running as admin.
tried waiting for an hour to see if it's actually launching.
was able to play diablo 3 last night with no such problems.

Any possible solutions for this? anyone else with this problem?
I am having the same issue except I have not been able to get beyond this point since launch.
100 Worgen Rogue
13215
Posts: 30
hiya mates thnks for the info killing the agent exe made the game launch hope u find ur answers soon :)
Same here. The launcher freeze and nothing happens.

I have tried turning of my firewall
Run as admin
Restart computer

I have no idea what is going on. Worked fine yesterday.
Customer Service
Posts: 26,131
Hello,

Can you please check your security software? If you have some installed, please check it for updates from the manufacturer's website.

You can also test this by temporarily uninstalling your security software, and seeing if the issue persists.
I am running it with no other programmes working in background, no security software whatsoever, and it just won't progress. To me it seems like it is downloading same files all over again. It just says "Updating files". I have followed every single instruction on your FAQ for installing and patching thread and the issue hasn't been resolved yet.
SOLUTION: I can not say it will work for you guys but go to your diablo 3 folder, then go into the updates folder and delete the update that is in there.
Then start the launcher again and it will say the game is up to date, then click play and you are good to go.
Worked for me :)
First it gets stuck at 'Updating Tools 0%'. Then when I kill agent.exe, the launcher will proceed to Initializing and then Updating Files. Then 'Game is up to date'. When I click Play, I get stuck at Launching.

I close the launcher. Kill agent.exe and try again. Same thing will happen.
SOLUTION: I can not say it will work for you guys but go to your diablo 3 folder, then go into the updates folder and delete the update that is in there.
Then start the launcher again and it will say the game is up to date, then click play and you are good to go.
Worked for me :)


Someone else suggested it and I have tried it but it didn't work for me unfortunately.
SOLUTION: I can not say it will work for you guys but go to your diablo 3 folder, then go into the updates folder and delete the update that is in there.
Then start the launcher again and it will say the game is up to date, then click play and you are good to go.
Worked for me :)


Someone else suggested it and I have tried it but it didn't work for me unfortunately.


Now it doesnt work for me anymore neither :( damnit
Oke i got it to work now, again i can not promise it will work for everybody.
What i did was i started the launcher, let it update to game up to date.
Then i went to my windows firewall and turned it off, waited about 20 seconds and clicked play, it started instantly.
Okay I got it to work by letting the update finish. Leaving the launcher on and starting a second launcher. The second launcher said the game was updated and I could start the game.
Edited by Minamoto#2863 on 16/05/2012 12:13 BST
Still not working for me.
same problem here , where is the solution ? update and cache remving is not helping :S
I'm also having the same problem, stuck at "launching". Prior to the release, I had no problem getting into the game. Since the release, I got into the game exactly TWO times, once shortly after the release at midnight (took two hours or so to finally log in, though...) and once at about 22.00 yesterday. The second time it took me about 2 or 3 hours of trying the different solutions suggested here on the forums and elsewhere, everything from disabling antivius software to deleting the battle.net folder, killing the agent.exe and reinstalling the game. At some point, the game just started and I don't see anything in particular that finally made it start.
So far, I can eliminate my internet connection and (probably) the OS (I'm running Win 7 64bit Home) as the source of the problem (two friends came over yesterday and they had no problem starting the game on their machines and the usual trouble with login, one had Win XP SP3, one Win 7 64bit Home).
Same problem here. Stuck at launching. It was working fine yesterday and a few hours after the servers went live, with anti virus software running so I know its not that. All my firewall settings allow any and all blizzard downloads/updates so its not that either. However, my world of warcraft launcher always got stuck at launching as well so I had to go into the file folder and open it from inside the folder to bypass the launcher. Unfortunately, this does not work for D3 =(
Hey guys i figured it out. Things i did to make it work:

1) Change update folder to Update_2
2) Change compatibility mode of Diablo3.exe to Windows XP Service Pack 3
3) Run as administrator

Once you get the game to update and it gets stuck at "launching" run a second launcher but make sure you launch "Diablo 3 launcher.exe". That will get you into the game.

Im not sure which of the above has helped in doing this but I think the key is to open 2 launchers. One is the standard d3.exe and after open the Diablo 3 launcher.exe
Yeah, I think that's how I got it to work one time, but trying that again brought me back to being stuck at "launching".
However, I have (at last, after more than 2 days...) found a permanent solution for me:
I reinstalled D3 (again, for the 3rd or so time), only this time I put it on my Windows system hard drive (an SSD, previously I always installed it on my second hard drive, a regular HDD).
Now, all my troubles are gone and the game always starts up without any problems !!!
Maybe it has something to to with the battle.net folder that is always created on the Windows partition and the game has some problem with having to access two different hard drives when the games is installed on a seperate drive...

UPDATE:
Well, just out of curiousity I reinstalled the game (yet again...) back onto my second hard drive and it's still working without problems. I have no clue why this hasn't worked the 3 or so times I already reinstalled the game before but now everything seems fine...
So the solution to at least some people's problems may just be one more reinstallation away... ;-)
Edited by H3llfire13#2822 on 17/05/2012 18:16 BST
Problem Solved

I had the same problem. Launcher would just say "Launching," and nothing would happen etc. Same stuff people are saying above. I uninstalled the game last night and re-installed it, works great no issues. Launcher starts right up. I had preloaded the game 2 weeks before it came out and I'm guessing they have an updated client available as of last night. If you were like me and preloaded the game way in advance then just uninstall and re-install with the new updated client.
1.) Go to command Prompt
2.) Right click and hit Run as Admin
3.) Type this in "Netsh winsock Reset"
4.) Restart PC
Then
Go to your Diablo III folder, create a new folder, name it backup, move the folder labeled Updates to this backup folder. Start client.
Worked for me.

Also, if you get stuck at launching, you can open task manager, and end the "agent" process. this should fix hangups at launching and even downloading. do this while the launcher is open and stuck
This thread is locked.

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]