Diablo® III

Massive fps drops since patch?

86 Human Paladin
0
Hello,

After the patch today i noticed that i seem to be having fluctuations in my FPS , it already starts in act I without any mobs on the screen , its not "lag" as in that it is choppy all the time (you know graphic settings to high) , its more like you walk a couple of sec , then it stutters for a minor second and then its fine again , this can happen once a couple of minutes or a couple of times in a row.

It tends to happen just as im attacking mob,however it can also happen when just walking about.

My system itself (i know its not the best ;p but i had no issues whatsoever before patch , exept that my fullscreen-windowed mode didnt want to minimize or sometimes locked up on the foreground [no application would show in front of diablo 3 unless i moved it to monitor #2]) :

<SPECS>
Intel e7300
Ati HD4600 1gb version - stock - Latest ati drivers aswell.
Windows 7 x64 ulti , 4gb of mem.
Dual monitor setup
Playing Fullscreen-Windowed.
6TB of hdd space. Multiple HDD's
Diablo 3 settings didnt change and used to work fine , but ill list em
1920x1080 16:9, mfps 150 , max b.fps 60 , tex high , shadow med, physics high , clutter medium and no AA or low-fx selected.

Running atm :

ESET NOD32 security
Diablo 3
Perfmon & taskmon

Analyse thingy from myself (or how i see it) :

Diablo 3 takes around 800-900MB committed memory , around 40% of my CPU aswell , my system resources show that there is still around 1.5gb memory free to commit, Both dont increase at all during heavy combat etc (processor jumps to perhaps 50% but nothing serious).

I checked fragmentation on my 15000 rpm raptor hdd that has my diablo and warcraft installation , all seems to be well (read / write speeds of 80-90mb/s. for all types of data 2/4/8/12/64 etc) I check wow and can play with 60-90 fps no issues. I also checked in perfmon and taskmon how much my drive was being utilized (the hdd) and that was less then 20% of its capacity , also checked for faults on it with spinrite and that passed the test with flying color.

could it be that the new patch changed something that causes me to have these hickup's ?
considering its purely this game since the patch.

Any advice dear blue's?

p.s i did notice my 100mbit line is saying i have a latency of 252 ms in diablo and a 19ms in wow. (home/world) , dont think that should affect it thou.

EDIT : since im not the only one it seems , if you experience this issue , please state what kind of videocard you have so they will be able to fix it quickly :D

EDIT 2 : since there are more people joining this thread and i can see some being made, requested a sticky so we can keep everything in 1 thread.
Edited by Aion#2383 on 07/06/2012 21:12 BST
Reply Quote
Same problem :/
Reply Quote
I have same problem, though with macbook pro... my computer was doing very fine at the gameplay, after the patch im getting small lagspikes/freezes every 2sec which is making the game nearly unplayable...

Dont know what to !@#$ing do
Reply Quote
Same problem :(

Pc
no fps problem before patch
GeForce GT 540M
Edited by grovsum#2778 on 07/06/2012 21:10 BST
Reply Quote
I noticed some slight fps mess also....AMDx250/4gb/HD4770 here, worked like a charm before the patch.
Reply Quote
86 Human Paladin
0
bump
Reply Quote
85 Human Paladin
6140
Same problem for me, random fps drops whit the new patch, its almost unplayable at this point. No problems before the patch, have hd 6970.
Reply Quote
Ive got the same problem 3.3 to 4.4fps after most recent patch was 68- 76fps before patch, running a fx6200, and a msi 550ti cyclone 8 gigs 1600Mhz ram. Odd thing is even at the login its around 3.3 with 3-6% cpu usage and 99% gpu usage pre patch it was typically 20% cpu usage and 80-95% gpu usage in a battle, my guessing is theres some sort of leak in the code pertaining to the gpu causing some sort of loop, or memory leak that taxes it to the max. Sometimes it will run at a normal frame rate but but my charachters kind of stutters and theres a lot of tearing in the animations at times. Very frustrating after how long it was in development.
Reply Quote
same problem with me
my graphic card is radeon HD 6770m 1gb
Reply Quote
85 Worgen Warlock
2680
Same issue here since patch, GeForce 9600 GTX XXX.

Even running the game off a SSD.
Edited by Lupi#2325 on 14/06/2012 12:06 BST
Reply Quote
Same was fine before but since some windows update... not Diablo... I started to get the same thing you guys have. I just updated it last night (been more then a week since last update windows update) and now FPS drop without explanations.

Rad HD 6520G
Reply Quote
same problem for me

I have a mac

my performance was GREATLY improved in the patch before last with the mac improvements, but now it's worse again

=(
Reply Quote
Samme problem here. Just bumping the thread so maybe Blizzard will se that this is a issue for alot of players. Have mailed them but haven't got an answer yet.

Well Krater is out and soon torchlight 2 so maybe it is time to switch game. Too bad, I really enjoyed D3.
Reply Quote
85 Orc Death Knight
5855
Same... can't play thhe game as it is now.. before the patch it was flawless... WAY TO GO BLIZZARD!!
Reply Quote
Same problem when i play only solo click esc and wait to have normal fps its anynoing and waste lots of time i want to blizzard repair it is not my fault or my pc i first test diablo 3 on starter key from friend and game work well than i go buy diablo 3 and there i get it ?? i i know after patch iwill play with 5 fps i will didn't bought it.
Reply Quote
Great game before patch; COMPLETELY UNPLAYABLE NOW.

Even after lowering all the settings to bare minimum, as soon as more than 3/4 enemies appear on screen it just breaks down completely.
Reply Quote
Same problem, tried moving the MPQs to a flash USB drive - didn't help. Minor fps-drops before the patch, unplayable since the latest patch.

Blizzard, what the hell?
Reply Quote
Same here. Since a few days the game is totally unplayable! What happened? Is there a fix for this?
Reply Quote
I'm having the same problem, game ran perfectly and now when I enter it's fine for a few minutes and then the frame rate just drops through the floor. It's totally unplayable for me now.
Reply Quote
90 Undead Priest
10615
Same here..
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]