Diablo® III

Performance/Stuttering Workaround

(Locked)

Customer Service
Posts: 26,131
We are testing a workaround for some of the performance and stuttering effects that some players may have experienced, this involves disabling Windows Drive Indexing, a tool that speeds up Windows searches.

1. Click Start
2. Click Computer*
3. Right Click your Windows drive (usually C:\) and select Properties
4. Select the General tab
5. Uncheck Allow files on this drive to have contents indexed...**
6. Click Apply
7. A new popup will appear, select Apply changes to drive C:\ only
8. Click Ok, and then Ok again
9. Load up Diablo III and see if your performance has improved

* = My Computer on Windows XP
** = Allow Indexing Service to index... on Windows XP

If you still experience stuttering after this, try disabling indexing for subfolders and files too (found at step 7). Once you've turned indexing off for everything, the option will change to one that lets you re-enable it if need be.

Please note that deactivating indexing is possible for any partition or hard drive on your system.

Please be aware that this may not assist in all cases, and the investigation into this issue is ongoing. Please also remember to check other steps in our Performance FAQ:
http://eu.battle.net/support/en/article/diablo-iii-video-performance-issues
Edited by Lurdlespor on 01/07/2012 15:38 BST
I understand Lurdlespor why you (or the support/tech team behind you) might think this will aid some ppl, and it very might well aid a VERY small nr of ppl indeed, but that is certainly not the culprit of the stuttering problem this game has. And this will actually NOT assist in 90% of the cases at all.
In addition you say that this needs to be done on the C:\ drive, but many people also install their game on another drive so they might want to do that drive too.

The stuttering problem is related to a bad programming routine concerning loading assets / caching data / buffering and so on, so that is what needs to be changed.

In my case I have disabled Windows Search service long before I ever started playing this game, which disables windows indexing on the whole system as I've always done that so this tip does nothing for me at all. Stuttering problem is IN the game code, not in Windows!!!

I really don't want to insult you guys but this should really not be such a big problem to solve for such a (normally) competent team of programmers...

Even a 5400RPM Hdd should be sufficiently fast enough to load data for this game without any kind of stutter at all, let alone a 7200RPM or more Hdd, game code change is what is needed! All my other games, of which many are MUCH more demanding then BF3, load fast and smooth on a 7200RPM Hdd.

I'm even under the impression that your rendering engine is not doing what it should be doing either as it's only using 350Mb of Vram tbh with everything on high (no AA and no smoothed shadows), although this has nothing to do with the loading data stuttering, this might have something to do with the FPS drops people have and graphical stuttering which happens when nothing is loading, in areas where nothing is happening, and on top of that areas which are even quite bland in graphical details, which is also existant in the game.

In other words, you need to solve 2 different stuttering problems in the game, not in Windows! Seeing as this problem should be quite easy to reproduce...
Edited by RedruM#2612 on 01/07/2012 18:20 BST
I am trying this, but I have a strange feeling when I need to change the way my windows is working to be able to play a game.
A little warning to everyone that decides to turn the indexing off for the whole drive including all subfolders and files: my windows has been working on this for a couple minutes already, since it seems like each file must be worked on seperately to be changed.

edit:
it took my computer almost 30 minutes to "un-index" my windows drive, which has 75GB data on it. I do NOT recommend doing this at a time that you rather want to play D3 or do anything else that uses your system power. I got lucky that the diablo servers are having problems anyways at this time, so I couldn't have been playing/browsing the AH anyways if I didn't change my windows to have a small chance for this game to run smoother.

edit2:
this didn't help at all, thank you for wasting my time and making me mess with my windows configuration, just because you are unable to code the game right. -.-
Edited by Moosplauze#2969 on 03/07/2012 08:52 BST
85 Troll Priest
8690
Posts: 60
Hey Lurdlespor, thanks for the info. ofc, you know from my thread that I'm running a 10k raptor drive for windows and games so it won't help me at all, but I'm sure others who are following my thread and enjoying all the feedback will appreciate this woorkaround.

oh... what's that? you haven't posted the link on my tech support thread? You haven't even looked in on it since you posted?

Oh, well I'm sure it's a simple oversight and not intended just to leave me hanging on so I posted this link on there for you...

However, popping in occasionally to check on feedback / updates / new reports of those problems would be nice... here's the link http://eu.battle.net/d3/en/forum/topic/4797099976
does not change a thing.
Posts: 12
What about Mac OS X users? Some of us encounter the same stutter issues since the patch.
Tried it didn't work. Game dropped so hard on a spot it litteraly froze my game for 5+sec...
Seriously need to go and fix those issues Blizzard because HC is unplayable as it was. But with these issues increasing it's just even worse. Especially since you refuse to ress any chars due to bug/game/server fault.

Edit: For those who played it and remember Torchlight has the same problem with explosive arrow and some other skills/effects. I remember this "fix" passing through there as well. While it did improve some speed it wasn't a fix. It's all in the game and it's effects and programming, there is nothing we can do from our side to fix it.
Edited by Daves2hd#2833 on 02/07/2012 02:16 BST
Posts: 38
I have seen great results (on several computers) by changing certain values in the "D3pref.txt" found in my doc.
Changes:
DisableTri.Filt. = 1 (default = 0)
HardwareClass = 1 (default = [depends on your computer ~ 3 - 4])

I cannot see any visual changes such as decreased quality,
but the game is smoother.
I have done some other changes as well to my setup, but the fix described above, was all i changes for a friend, and that both improved stuttering and performance overall.

Why is it so, that i have to change these values, and my computer setup is way more than capable of running the game?

My computer:
i7 920
24 Gb RAM
MSI 5850
128 Gb SSD
Win7 x64

Thx in advance for all replies.
Posts: 31
This doesn`t work. But do you really think all users have to change their windows configuration to run a game??

Please blizzard do your work and dont try to pass the problem to the users.
Edited by Konstantin#2340 on 02/07/2012 10:12 BST
Trying this now. Not really noticing any difference but thx for the tip :-)
90 Gnome Warlock
0
Posts: 35
I use a Mac and I get this problem occasionally, but so far it hasn't made the game unplayable. This fix does ignore us Mac users. Lucky I have a fast machine (including fast HD, graphics card etc) or I would notice this more.

(All settings to full on a 27" 2560 x 1440 screen :P )
Edited by RockyWaist#2895 on 02/07/2012 12:56 BST
Does nothing at all, i know this as i've had indexing off since the day i installed windows 7 and get stutter all the time on new assests loading.
did not help. problem is the game !
Let me add something to this.

I used to play the game in windowed mode (full screen). I also used to play on Windows 8 Consumer Preview and Release Preview.

The thing about the preview releases of windows is that they are debug builds. They don't do near real time stuff really good. But the situation with Windows 7 RTM is radically different. So, get off the Windows 8 preview builds if you're using them.

Secondly, run the game in full screen exclusive mode. Not windowed. Turn on v-sync (I suffer from tearing if it's not on but v-sync is one of those things I tend to fiddle a lot with).

Power options, make sure you're using a high performance power plan. There are some energy saving features that might mess with your rig, if you switch to a high performance plan those will be disabled.

Make sure you're running the latest drivers of course. nVidia recently updated their drivers with a couple of major improvements to all their generation 4xx series cards and later.

I used to have framing issues, although really subtle, but not any more.
Edited by Jijo#2533 on 04/07/2012 07:51 BST
no change at all
I've fixed mine, here is the BETTER SOLUTION:

I have been experiencing shuttering with my:

i7 2600
16 gb ram
hd7870
SSD

PC. As a last resort, i've tried:

IOBit Game Booster 3 (Free) > "Gaming Mode" - Boost

And shuttering is now gone forever. After i've fixed it, i saw this thread. So i guess "gaming mode" includes the Windows Drive settings that OP says, and much more. If you have an high end PC, it is absolutely worth a try.
Edited by doen#2372 on 02/07/2012 18:10 BST
I have seen great results (on several computers) by changing certain values in the "D3pref.txt" found in my doc.
Changes:
DisableTri.Filt. = 1 (default = 0)
HardwareClass = 1 (default = [depends on your computer ~ 3 - 4])

I cannot see any visual changes such as decreased quality,
but the game is smoother.
I have done some other changes as well to my setup, but the fix described above, was all i changes for a friend, and that both improved stuttering and performance overall.

Why is it so, that i have to change these values, and my computer setup is way more than capable of running the game?

My computer:
i7 920
24 Gb RAM
MSI 5850
128 Gb SSD
Win7 x64

Thx in advance for all replies.


Stop saying to change hardware class please, if you can't see which difference it makes on the level of gfx and what changes in the graphics you really need new glasses.
Mine was default on 5 (which my pc can easily handle) and I need to set it on 3 to be playable because of stuttering and then it still stutters on 1 it also stutters, it displays more graphical effects and thus needs more loading of stuff when set higher, and therein lies the problem again, asset load stuttering, where the coding of Blizzard went wrong.

Let me add something to this.

I used to play the game in windowed mode (full screen). I also used to play on Windows 8 Consumer Preview and Release Preview.

The thing about the preview releases of windows is that they are debug builds. They don't do near real time stuff really good. But the situation with Windows 7 is radically different. So, get off the Windows 8 preview builds if you're using them.

Secondly, run the game in full screen exclusive mode. Not windowed. Turn on v-sync.

Make sure you're running the latest drivers of course. nVidia recently updated their drivers with a couple of major improvements to all their generation 4xx series cards and later.

I used to have framing issues, although really subtle, but now, no issues at all.


Has nothing to do with the problem at all. The stuttering problem has nothing to do with frame issues, we get good FPS, it's when DATA IS GETTING LOADED FROM HDD!!! Problem is ACKNOWLEDGED BY BLIZZARD!!! Not our PC problem!!!

I've fixed mine, here is the BETTER SOLUTION:

I have been experiencing shuttering with my:

i7 2600
16 gb ram
hd7870
SSD

PC. As a last resort, i've tried:

IOBit Game Booster 3 (Free) > "Gaming Mode" - Boost

And shuttering is now gone forever. After i've fixed it, i saw this thread. So i guess "gaming mode" includes the Windows Drive settings that OP says, and much more. If you have an high end PC, it is absolutely worth a try.


Only handy for people that know absolutely nothing of a PC and never keep their machines tidy and clean and up to date! In other words, useless for most PC gamers. And that doesn't change the fact the coding of the game needs to be rectified, as there is an acknowledged problem with it!

Should some of you contest what I say, check this:
http://us.battle.net/d3/en/forum/topic/5596249920

Confirmed problems with the game by Blizzard. Funny btw that this post is nowhere findable on the EU forums...
Edited by RedruM#2612 on 02/07/2012 19:03 BST
Posts: 72
This doesnt work.
My hard drive already had the option turned on.

Before 1.0.3 it worked ok, after 1.0.3 and subquent "a" the stuttering is always there.
Everytime a sound or something is loaded, the stutter occurs. I believe its something to do with the way the game streams its data, but im no expert.
6 core amd 1090 @ stock
dual 6970's @ stock
12gb corsair ram
Corsair SSD 120gb

cpu is 30c / 86f idle
gpu is 42c / 107f idle

all under water so heat is not an issue. I get stuttering all the time especially in MP and large mobs. I will try vsync and locking the fps to 60 when the servers get back online. Sure hope this gets solved soon as I really believe a single 6970 is pleanty for this game. D3 isn't that graphically intensive.
This thread is locked.

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]