Diablo® III

Solution for stuck at Diablo3 logo on launch

I had Diablo 3 launcher saying Game is up to date but when i click on Play it was getting stuck at Diablo 3 head and Diablo 3 falls into "not responding" at task manager.

I had been trying to make it work for a day now and finally i managed by doing the following:

Navigate to Diablo 3 installation folder (default C:\Program Files (x86)\Diablo III) and remove the following files (backup for later use or just delete)

Diablo III.tfil
Diablo III.mfil

this worked for me on 2 computers.
Edited by Leo#2908 on 23/09/2012 02:47 BST
Reply Quote
It works for me. Ty Leo
Reply Quote
it works , but why ?
Reply Quote
It's not working for me. Just deleted

Diablo III.tfil
Diablo III.mfil

Just made a backup to be sure it's not worked.
So, this is not working for me *SadFace*
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]