Error Code BLZPTS00007 [SOLVED]

Technical Support
1 2 3 16 Next
Every time I launch my game it spams me with an ERROR CODE BLZPTS00007 saying the agent program failed. It offers a link for help, which links back to the main page telling me to buy Diablo 3, which is nice.

Anyone found an around for this issue? Must admit im enjoying not being able to play my single player game due to the online issues...

Solved by Cisza

Right-click on Diablo III.exe and then "Run as administrator"
..and if that won't help:

Go to start menu. Type in "Services" without " ". Click it.

Scroll down to "Secondary Logon" and right click -> properties. Then set it to automatic startup. click apply. then click start. and close. Now try the installer again.


Also the OP is stupid and cant tell time.
Right-click on Diablo III.exe and then "Run as administrator"
...and if that won't help:

Go to start menu. Type in "Services" without " ". Click it.

Scroll down to "Secondary Logon" and right click -> properties. Then set it to automatic startup. click apply. then click start. and close. Now try the installer again.
give this wo/man biscuit, for some reason it wasn't auto running again. #irdumb
I will gladly accept some milk also.
Annnd now it still thinks Battle.net is down.
When you try to log in? That's good actually. You just need to wait another 23 mins, and 44 seconds...
which is due to it not being 11PM GMT, I am a DRASTICALLY stupid person today. I blame the 4 hours of trying to fix a RRoD Xbox 360 (hint: I hit it hard and it worked, let that be a lesson to you, Violence works.)
Do you know how to do this on Windows XP?
Hi there,

well I tried:
1) run as administrator --> did not work
2) automatically start the secondary logon services --> did not work
3) terminate the agent process while it is "checking for updates" --> did not work
4) tried by double clicking the agent.exe file --> did not work
5) all of the above with no firewall or antivirus running --> still does not work
6) restarted the pc three times already --> no change

what else can I possibly do to fix this problem?
well I tried:
1) run as administrator --> did not work
2) automatically start the secondary logon services --> did not work
3) terminate the agent process while it is "checking for updates" --> did not work
4) tried by double clicking the agent.exe file --> did not work
5) all of the above with no firewall or antivirus running --> still does not work
6) restarted the pc three times already --> no change

Me too!
well I tried:
1) run as administrator --> did not work
2) automatically start the secondary logon services --> did not work
3) terminate the agent process while it is "checking for updates" --> did not work
4) tried by double clicking the agent.exe file --> did not work
5) all of the above with no firewall or antivirus running --> still does not work
6) restarted the pc three times already --> no change

Same for me. Still nothing
^
So far it's working when i run as administrator, if i get to play before work i'll be very happy. also Cisza has been more helpful than any blue post i've seen.
Glad to hear that's working here.
Same here. No workie.
Excuse me, but how can you say it's working when at least four posts above you, every post says that they are having a problem and it is NOT working?
Anyways 5 hours later and still the same problem. :-(
whats going on, i tried all the solutions posted, its not working, i cant even install it
I have the same problem. Tried everything here and about a thousand other things. Had a ticket open for infinity hours aswell -__-
Wonder if it matters, the digital signature for the installer is for ‎Saturday, ‎May ‎12, ‎2012 6:06:40 AM but for the Diablo 3 setup its all the way back to ‎Tuesday, ‎November ‎29, ‎2011 4:53:20 AM

[don't know if I'm trying to be helpful to the devs or I'm just desperate]

Join the Conversation

Return to Forum