Another "Stuck at 1%/Updating Setup File" Issue

Technical Support
I know there's quite a few posts around already (Sorry for yet another one >.<) but I figure that another one can't hurt, especially as it shows there's at least 1 more with a problem:

Having trawled around for a few hours trying to install since 10:00pm (Now being 6:40am >.<) I thought I'd chip in saying I've got the problem too. Here's a list of things I've done thus far:

I originally had the Beta installed which I removed all traces of before starting the retail installer.
All the Agents, Setups and Launchers are set to run as admin.
The Secondary Login service is set to Automatic.
I've deleted the folder more times than I can count.
I've started up in Safe Mode with Networking to find that the Secondary Login service won't enable in that mode.
I am running it using the patcher that we had emailed to us on the 12th May.
I've uninstalled AVG and allowed the Setup, Launcher and Agent files access through the Windows Firewall.
I've checked "Never Dial a Connection" in Internet Properties.
I've tried 3 fresh downloads onto different machines, along with all the above fixes, still with no joy.
I've tried Compatibility Mode to Windows XP SP3 (I know that there's a sticky recommending we don't, but if I turn that off, I get stuck in an Updating Setup File loop)
I've tried running all the variants of Agent.exe that are found in the folder.
I've also occasionally done a full computer sweep/registry sweep for all mentions of "Diablo" and tried doing a fresh installation from there.

A few times, I've had the Updating Setup Files finish, and been able to reach the installer, but then it will freeze at 1% for up to an hour. Deleting the folder to fix this, 9 times out of 10, resulted in the Updating Setup Files freezing at around 60%

All of which, unfortunately, still leave me hanging at 1%, and after deleting the folder, stuck on Updating Setup Files
once u download the 7.60gb from diablo-III-8370-enus-installer-downloader 7,165kb get the new client installer the new one is diablo-III-setup-enus 30.7mb login into your download game client again(30.7m then open new one not old installer when trying to actually install the game then, you will have to install the rest 8.1gb in another installer, using the 30.7mb one. 7.60gb+8.1gb for digital purchased copies. im currently downloading the 8.1gb lol O.o the game is 15.1gb and u have to download all of it Ninjagt~
I did download the new patcher from the site and ran it to download to the same location as the old files, which gave me the 55-60mb new information which it says in the email:

"If you chose the correct directory only approximately 65MB will need to be downloaded to fix your install, otherwise you'll re-download the entire ~7.6GB"

Having already downloaded the 7.6GB before the 12th of May, and running that patch for the extra 65mb, surely running 2 separate patchers into 2 separate locations wouldn't be any help...Unless I'm seriously missing something XD Which wouldn't surprise me right now, I am pretty shattered
well i downloaded it two weeks ago and ended up having to download the 7.60gb again but i didnt use a 55-60mb file froma email get the new one fromm 30.7mb then try
Righto, I'll try downloading that one from scratch. I'd downloaded multiple copies of the one we got in the email thinking it would be identical to the one they'd now provide on the site. Will have to try it later today when it finishes :)

If you don't hear from me, thanks loads, and I love you :) Otherwise, I'll be back waving my pitchfork later on XD

You've tried this on separate computers and all of them are getting this error?

Are they all sharing a connection?

If so, can you try going into the router configuration page, and in there disable the uPnP option, then try again?
Hi Lurdlespor,

Now that you mention it, uPnP was turned on in the router settings. It's now turned off and I have run the patcher provided via email again. Currently, it's on Updating Setup Files at around 50% and the latest line in the logs is:

2012/05/15 07:06:49.111 - Downloading patch for agent update.

...Though it has been like that for about 8 minutes now. Not sure how long it's supposed to take, but I'll wait a little longer :)

EDIT: Typo

EDIT 2: Not 10 seconds after submitting this post, it jumps to 60% (The dreaded freeze spot) and:

2012/05/15 07:14:53.615 - Downloading patch for client update.

*Crosses all appendages*
Finally made it back to the Installer, still freezing at 1%. Sorry Lurdle :(

Just to check, it downloaded Blizzard Launcher.1575 and Agent.954. Not sure if it would make any difference knowing, but you never know :)
Also, just tried to run it in Safe Mode With Networking as well, to no avail. At this rate, with shops opening in 40 minutes, I may just have to go and buy a physical copy of the game. Not too happy about paying for it twice, but at the rate things are looking, and nearly 11 hours of attempting to fix it, I don't have much of a choice
Don't buy a physical copy, it seems unrelated. I have a post about it as well and quite a few replies, you may find comfort in that, or not...

So you're confirming disabling uPnP doesn't help this?
In this case, changing uPnP made no difference :(

I would love to take comfort in it, but with all the fixes that have been suggested and having tried pretty much every single one, I've all but given up on getting this digital copy to work. Oddly enough, when installing the Beta client during the stress test, I had none of these problems, so that makes it all the more annoying >.<
Well it seems to have nothing to do with physical/digital copies.
If you can get those installation files from a friend (c:/program files(x86)/Diablo III) as a whole you can copy them to your PC and that should make the game work, but I can't find anyone who can do that to confirm right now.
I know that 2 friends I have that live quite far away copied the files to each other, and have 0 problems overall >.< And I don't know anyone in my local area that has a working installed copy of the game
Didn't work with the disc either .__.

One theory I did have is that recently we've been having a lot of problems with Virgin Media, such as random programs not working recently, and Xbox Live not being able to connect. I'm wondering if there's a connection between people not being able to connect the Agent properly and having Virgin...Though that could just be a long shot >.<
Scratch that. I ran the Diablo III Setup in Compatibility Mode XP SP3 again, and the Updating Setup Files stopped looping. Now it gets stuck on 1%. Turning off Compatibility starts the Updating Setup Files looping again.

Also, when it gets stuck on 1% while installing from the CD, all noise from the CD drive stops, so it's not processing any of the data from the disc anymore from the sounds of things
Got the same issue. Nothing helps so far.
Got the same issue. Nothing helps so far.
I got the same problem, it stuck to 1%, I've the CD version.

If anyone find out, please let us know.

I'm running on W7 btw.
Some fresh news, I canceled the installation and runned it with admin rights, it seems to be working now but it's quite slow, I'll let you know if it goes to the end.

EDIT : I do have the 100% now :)

Join the Conversation

Return to Forum