Micro stutter. AMD Card

Technical Support
Hi guys,

Got Diablo 3 recently. Loving it so far. Amazing game!

Is anyone else getting micro stutter issues with AMD Cards?

My spec is:

i5 2500 3.3GHz
5850 1GB.

I can run the game on full max settings, with Vsync enabled and I never drop below 50FPS. However, when I'm walking across a map, sometimes I'll notice a micro suttering.

I know it's nothing to do with my PC as members of another forum I frequent are reporting the same issue.

Who is here is getting Micro stuttering on AMD Cards?

Yep same problem here....

Also i think the cinematics stutter. They're not smooth.
I have actually got used to it. :D
Try disabling vsync.
If you have vsync on you will either have 60fps or 30fps since it's for removing screen tearing, if the FPS counter shows between 30-60 it's because it counts average FPS, So vsync on a 60Hz monitor means you will get 60 FPS when possible and if it drops under 60 you will get 30 instead, so when you get 50fps its an average and meant you got drops to 30 under that rendering period, try disabling vsync and put an FPS limit on 60 instead and see if the micro stutter will disapere.
Could be a solution, but if i see screen tear i'd rather play with stutter
Have the same issue. Vsync is indeed the culprit. Disable vsync and set framerate to 65-70. You'll get the tiniest amount of tearing during gameplay, but it's infinitely better than having that damn micro stutter every 15 seconds.
I'll try that...when the servers are up
eh? stuttering? you all on the latest drivers 12.4, i got a 5870 and get a nice 150-200 all on high, running a res of 1920x1080 and all is good here. Not screen tearing either
got similiar specs with a 4890, everything working fine
@ PantsDown - Did you read at all? It's caused by vsync and you do not have vsync on. The screen tearing is the monitors fault, different monitors get different results.
Yep got the latest drivers, will also try to disable Max Foreground FPS, see what happens
Just wanted to point out that its a bit better when you turn vsync OFF and instead of that set maximum fps to 60.

Which is strange, as it should have the same effect.
@Hkarta - No it's not, vsync times frames with the monitors refresh rate to avoid screen tearing and if the FPS can't stay at all times at fps matching the refreshrate your monitor has it halves the FPS, so 60Hz monitor gets 60FPS but if it falls udner 60 FPS it caps at 30 fps and if it falls udner 30 fps it caps at 15 etc.

If you set max fps at a fixed rate it will never go higher but can be any number between zero and set max fps so in your case all from 0-60 without jumping between 15,30,60 etc.

So vsync and FPS cap is entirely different.
Radeon 7850 and i5 3450 and still got the same problem .. i think Diablo 3 isnt so optimized for AMD cards .... .You guys found any solution ?

On my pc i should run Diablo 3 on max and never ever experience this since can play BF3 on ultra and never get this problem?
@Reddawn - Read my other posts. Set max fps to 60 without vsync.

Also you can not run BF3 on ultra in multiplayer at constant playable FPS with a 7850, search google to see what ultra requires.

I got a 7970 and I can run 32 player maps decent enough on preset ultra and my card is alot faster then yours. But the bigger maps tend to lower the FPS drops a bit and more then 32 player maps I have to lower some settings.

You might be able to play single player in ultra but not multiplayer.

EDIT: A quick search on trusted benchmark sites the average FPS in BF3 single player with a 7850 in Ultra 1920x1080 is 43 FPS. So no shot to play in near playable when playing multi player.
So don't write here and lie.
Having this issue as well. I have two 6970's in crossfire. Early in the Beta it never was an issue. After one of the last updates I suddenly had micro stutter. I thought I heard Blizzard promising it would be fixed by release... well go figure I still have it.

It comes and goes, it seems if i just tap my right mouse and set off one of my attacks it stops stuttering for a few moments, only to come right back randomly.

I also tried disabling crossfire and trying with one card, and while it seemed slightly better, it still happens. Blizzard please work with AMD on getting this fixed ASAP.. it's driving me bonkers.
I have 6630M and it's fine for me. I'm playing on max with vsync turned off. No stuttering.
I'm also having microstuttering and it appears randomly, not at any specific points.

My specs are:
i7 920 @ 3.3ghz
6gb 1600mhz ram
5870 1gb @ 925/1275 (I've also tried with stock clocks)
WD Black 650gb harddrive

When typing this, I'm using the 12.4 driver.

Now the thing is, it's not caused by vsync.
Vsync + Fps limit 150 = overall very smooth but microstutter every now and then.
Vsync + Fps limit any lower number = Not smooth.
No vsync + Fps limit 150 = microstutter almost all the time.
No vsync + No fps limit = same as above.
No vsync + Fps limit 60 = same as above.

While it's not a huge problem, it can be a bit annoying sometimes.
I'm hoping for a fix soon.

Oh, and it was the same when I tried the beta over the free weekend. Back then using the 11.11c driver.

EDIT: Now I've also tried setting only the physical cores 3, 5 and 7 to be used for the game like some people suggested. Also set every single Blizzard exe to run as admin, and tried setting Diablo 3 to run at higher priority. Nothing worked, and setting higher priority even caused the audio to start stuttering!
5870 same problem =)

Join the Conversation

Return to Forum