Huge amount of large, mostly triangle, pixelation

Technical Support
This develops within the first 20 seconds of opening the game. Tabbing removes it for the fist 5 seconds, but it comes right back. Essentially unplayable. I couldn't even see Leah when I was talking to her - Covered in an enormous half-screen black triangle. I'm running windows 7 64bit with ATI Radeon 4300 with recent drivers downloaded. Anyone else having this issue?
Could you possibly post a screenshot?
That is another problem. If I try to take a screenshot, it takes a pic of whatever is on the layer beneath D3, not a picture of D3. Its basically a !@#$load of polygons and black triangles/lines everywhere. When I start the game up it is perfect for about 5 seconds. Then a few polygons show up. Wait 10 seconds, the background behind the crows get some polygons, 10 more seconds, the charater looks ridiculous and filled with polygons.
k id like to post a screenshot to see if it looks like what i think it is... does any1 know how i can?.
You'll have to use an image hosting website.
Sounds like some-kind of artifacts anyway, possible that you have a corrupt card. Have you overclocked this card and have you checked the Temps?

Have you tested it on a few other games too? Do you get the same problems. Its interesting how it gradually get worse as the seconds go by, kind of points to some Temp issues or corruption usually.

Thats what i think he described it to look like.
there is a hotfix for amd graphics issues on the amd site somewhere apparently for the newest catalyst.

during beta though, I had a similar issue, I fixed it (on win 7) by completely removing catalyst and my display drivers, then letting windows install its own graphics drivers automatically

doing this also made a few other games run smoother, and my card a little more stable
I made a post on a similar thread, as I had the same problem & managed to solve it (same graphics card ATI Radeon M HD 4300)

I downloaded the drivers from the laptop manufacturers site (Dell in my case). They worked perfectly. Just remember to remove the others, then reboot then install the dell-supplied ones.

I was having exactly this problem! Large triangles all over the place, just like the image in this thread. Made the game unplayable.

I also just recently installed the newest cataclyst drivers. Removed them, let Windows 7 install its own driver et voila, no problems at all!

Thank you all!

Join the Conversation

Return to Forum