Patch 1.0.2.9749 problems logging in to the game

Technical Support
Prev 1 2 3 9 Next
Same problem here. I'm starting to get disappointed by Blizzard...
Just read some of the other threads here seems it's to do with maintenance. It's due today and will be finished (expected time) at about 19:00 GMT.

I hope it is, otherwise I'm getting disappointed too.
same here!!!
I got the same problem. Not Cool.
Same here, from europe, mac version
Same problem here (Mac, EU)...

Blizzard should not treat its customers like this...
The problem is simple (and I got it also).

we downloaded the english(US) version, so we are patching sooner than expected.

We need to download the english(EU) version, and it will works fine.

We need to do that or we'll have the same problem each time they'll be a new patch...
same same.
Afaik 1100PDT is 1800GMT.
Anyway, launcher is still going in this loop despite having already successfully patched.. :(
The problem is simple (and I got it also).

we downloaded the english(US) version, so we are patching sooner than expected.

We need to download the english(EU) version, and it will works fine.

We need to do that or we'll have the same problem each time they'll be a new patch...


say what?
Same here. Just cycle ception
Same Same
xxxxfixxxx
Same loop problem here >:(
And server is up..
same problem with mac
WTF!!!
same here... it says game is already running!!!
y there is no !@#$ing blue post about this.....
Just paid 45 POUNDS for a game I can't play straight away. Same like everybody else
Same all the same!!
same :((

Join the Conversation

Return to Forum