Diablo III launcher - stuck at Updating Setup Files

Technical Support
I got this since a few hours now and ive tried almost everything on previous forum posts of few weeks ago and yet it doesn't work.

Really appreciate it if somebody can give me a help over here.

Somebody knows?
Same !@#$ here.
Pff can't find anything that might fix it :'(

just hoping for some1 to come with solution
Just received my first error:

An error occurred while writing to your hard drive. Please make sure your hard is not full and try again.

Please click the link below for more information or contact Customer Support if the problem persists.

Error code: BLZPTS00009
im getting the same except at the start it was error blzpt00007 then i reset some of my computer settings and now im getting stuck about 3/4 of the way on updating files and it wont go further.
I just let it run for 1 hour, and it got stuck at 2/3 again and now i restarted it and it was stuck at 1/3 for some time and now its back to 2/3...
Please blizzard help us out :)
ive fixed it for me. not sure exactly what i did because ive been messing around for hours now but think i can help if its still needed
Yes would rly appreciate it man !
well for me i uninstalled but i dont know if it was necessary. so ill post a link to a file i downloaded which i replace for the one i currently had ( i think it was the file just called battle.net you will see when you download.) anyway replace it with the old one and then run diablo as administrator. (right click the icon and you'll see it) im terrible with computers so if i can you can! mine is currently installing with hopefully no issues. hope this helps
sorry if my last post is hard to understand, its a little messy
Uninstall diablo completely? That takes like ages for me :X might try and download it on my laptop.

And put it on my main pc with a extern hard drive. will try that later cuz it takes like 5-6 hours to instal diablo again :P

But can u give me the battle.net file then it would be really appreciated !
oh and i had to try running it twice so try a few times if it dosnt work the first time
i dont think you need to uninstall but i did and its working. try without uninstalling, good luck
This is the second time that the patch doesn't download and I can't play. Blizzard you suck what's the point of all this crap ? I just play single player ! Why can't I download the patch separately ? This is stupid.
"Failed to read a required file..."
This is ridiculous
Gonna give it a try later on, thx.

Might even buy the disk tomorrow :P ah well, gonna raid now :'(
i got 'failed to read a required file...' once or twice some time while ive been trying to fix it.
I just did a full re-install and same thing... also same thing happen'd last patch... patch before that...
^did it work?
19/06/2012 19:47Posted by KunyuShan
^did it work?
... no

Join the Conversation

Return to Forum