Stuck at initializing

Technical Support
Hello, i am experiencing an error every time i try to log into the game. Instead of logging in to the game it gets stuck at the initializing screen and doesnt seem to move no matter how much time i give it. I already tried selective startup and running sc2 as an administrator which didnt seem to affect the loading at all. Sometimes it reaches about 10% and can climb as high as 80% when it stops moving and will not continue no matter what i do. As i only recently bought Starcraft 2 im more into the campaign than actual play against other players. Thats why i started playing the campaign as a guest and did not bother to try to get online. However now i feel that i need to get online to play against a friend of mine.

So im wondering if there is something i could do to get past the initializing screen other than the things stated above. Also i dont know if my progress in the campaign would get saved if i i were to reinstall the game(tried that once already), and if the progress is deleted when you reinstall the game is there anything i can do to save it.
Hey Xauros!
Can you please try and delete Variables.txt from your StarCraft II folder located in you Documents and see if that will help? Bare in mind after deleting Variables.txt you will need to adjust your game settings again.
Hi there! I was stuck at %100 for about half an hour, then I alt+f4 and re-loaded the game, and the Initializing was over. I hope It'll help people who suffer the same thing.

I'm also stuck at initializing.

These do nothing for me:

Alt+F4 + restart game
Deleting variables.txt
Deleting Battle.Net folder from ProgramData
Disabling all but Microsoft services thru Msconfig (selective startup).

Please help / fix.

Thank you!
Same problem here...still support seems to work great.. 2,5 months and no help from Starcraft II.
I found something that worked for me. Now I'm not really tech savvy at all, but clearly neither is support. I opened task manager while the launcher was running and just ended the updater. I had to do it twice, but then the launcher just passed the initializing phase and now I can get in again. Hope this helps.
Open "Internet Explorer'
Click 'Tools' (Alt+X)

Click "Internet Options"
Go to the "Connections" tab
Click the "LAN Settings" button
Uncheck "Automatically Detect Settings"
Uncheck "Use automatic configuration script"
Uncheck "Use a proxy server for your LAN"
Click "OK"
Try the game again

if u still have this problem try this....
Please don't bump in threads which are over half a year old.

Thanks. :)

Join the Conversation

Return to Forum