Failed to find a suitable display device...

Technical Support
Yesetday I re-booted my PC to get rid of a spyware that my antivirus program couldn't remove.
I've spent the whole day re-installing/downloading WoW and I am at 'playable' on the wow launcher, however when I press play I get the error message "Failed to find a suitable display device. Exiting program"

I have tried updating my drivers and running WoW repair without luck.
My computer is a Dell XPS420 and my operating system is Windos Vista 32-bit
Did you install all available windows updates including the latest service pack? Also check in your hardware and devices to confirm the model number of your display adapter.
"Failed to find a suitable display device. Exiting program"


Installing the latest drivers for your graphics card should solve this problem.
Doesn't work, in fact I wrote in my post "I have tried updating my drivers"
this is on winxp

click start > programs > systom tools > system information > click tools from menu click directX diaganostic tool, select the display tab, and make sure none of the "directX features are disabled, if so enable them.

all the best
I have Windows vista 32/bit
Open the Start Menu, then type dxdiag in the search box and press Enter.
I saw that trick when i was googling around, but the menu I get looks nothing like it's described by others :S
Doesn't work, in fact I wrote in my post "I have tried updating my drivers"


Did you uninstall your former drivers before attempting to install the latest drivers?

Also, could you post a DxDiag report?

Select "Start" > "Run" (Windows XP) / "Search" (Windows Vista/Windows 7) > "DxDiag"

We're interested in the following:

System
Operating system:
Processor:
Memory:
System manufacturer:
System model:
DirectX version:

Display
Card name:
Manufacturer:
Driver version:
Driver date:
Video Display? You havent it I quess
Hi there,

If you could please post the information requested by Jindai about the video drivers, that'll help immensely.

Thanks!
System

Operating system: Windows vista TM Home premium (6.0. build 6001)
Processor: Intel(R) core(TM)2 Quad CPU Q6600 @ 2.40Ghz (4 Cpus),
Memory: 3070MB RAM
System manufacturer: Dell inc.
System model: Dell XPS-420
DirectX version: Directx 10

(Not sure if this is the right "Display information" having some troubles with translation since there's not many norwegian words for the 'PC-language' )
Display Devices
---------------
Card name:
Manufacturer:
Chip type:
DAC type:
Device Key: Enum\
Display Memory: n/a
Dedicated Memory: n/a
Shared Memory: n/a
Current Mode: 1024 x 768 (32 bit) (1Hz)
Monitor:
Driver Name:
Driver Version: ()
DDI Version: unknown
Driver Attributes: Final Retail
Driver Date/Size: , 0 bytes
WHQL Logo'd: n/a
WHQL Date Stamp: n/a
Device Identifier: {D7B70EE0-4340-11CF-E025-7137AFC2CB35}
Vendor ID: 0x0000
Device ID: 0x0000
SubSys ID: 0x00000000
Revision ID: 0x0000
Revision ID: 0x0000
Video Accel:
Deinterlace Caps: n/a
DDraw Status: Not Available
D3D Status: Not Available
AGP Status: Not Available
I have a similar problem, or at least, half. After a constant plaguing of black screens stating 'No signal', then BSODs, I logged back onto my computer and it was at a very zoomed in resolution, and upon attempting to play WoW, I was greeted with 'Failed to find a suitable display device. Exiting program.'

Card name:
Manufacturer:
Chip type:
DAC type:
Device Key: Enum\
Display Memory: n/a
Dedicated Memory: n/a
Shared Memory: n/a
Current Mode: 1024 x 768 (32 bit) (1Hz)
Monitor:
Driver Name:
Driver Version: ()
DDI Version: unknown
Driver Attributes: Final Retail
Driver Date/Size: , 0 bytes
WHQL Logo'd: n/a
WHQL Date Stamp: n/a
Device Identifier: {D7B70EE0-4340-11CF-E025-7137AFC2CB35}
Vendor ID: 0x0000
Device ID: 0x0000
SubSys ID: 0x00000000
Revision ID: 0x0000
Revision ID: 0x0000
Video Accel:
Deinterlace Caps: n/a
DDraw Status: Not Available
D3D Status: Not Available
AGP Status: Not Available


It appears that there are no drivers installed for your graphics card.

A Dell XPS 420 may have an NVIDIA GeForce 8600 GTS, 8800 GT, or an 8800 GTX graphics card. If you're still using the same graphics card that came with the machine, you can use the following drivers:

http://www.nvidia.com/object/win7-winvista-32bit-266.58-whql-driver.html
t appears that there are no drivers installed for your graphics card.

A Dell XPS 420 may have an NVIDIA GeForce 8600 GTS, 8800 GT, or an 8800 GTX graphics card. If you're still using the same graphics card that came with the machine, you can use the following drivers:

http://www.nvidia.com/object/win7-winvista-32bit-266.58-whql-driver.html


I tried this and i got error message "This graphics driver can't find compatible graphics hardware"
does your graphics card appear in the 'Hardware and Devices' window, and if so does it have an exclamation mark next to it?
I tried this and i got error message "This graphics driver can't find compatible graphics hardware"


Upon further investigation, it appears that the Dell XPS 420 may also have an ATI graphics card; either an ATI Radeon HD 2600 XT or an HD 2400 PRO.

Here are the latest drivers for the graphics cards mentioned above:

http://sites.amd.com/us/game/downloads/Pages/radeon_vista-32.aspx
Guys, I found something interesting.
You know that CD that comes with your computer that has *Drivers and Utitlities', I was running that CD to fix my audio-driver and I saw the list on video drivers availebel.

I updated/installed all the drivers on the list, but there were 3 drivers that just gave me an error message, the drivers I got error on was :
nVidia Geforce8300 GS (128MB DDR2 PCI-Express x16 (DVI/VGA)
nVidia Geforce8800 GT
nVidia Geforce8800 GTX 768MB

The error message was the same on all (translated by me) :
The instaltionprogram for nVidia couldn't find any drivers capable (?) with your current hardware (I think). Exiting instalationprogram.
Go to "Apparaatbeheer", check which video card you have. I have "Nvidia Geforce 9300GS".

Right-click on "YOURVIDEOCARD", go to "Eigenschappen", "Uninstall".

Go to http://www.nvidia.com/Download/index.aspx?lang=en-us and download + install a new driver.

Restart your computer.

By the way, Translate the Dutch words between " " to English. I don't know the English word for these.

Join the Conversation

Return to Forum