Blizzard Updater crashes during optimization

Technical Support
"Updating Tools" works fine, the Launcher restarts after that. Then the optimization process begins, a bit of data is downloaded and then the updater crashes.

Blizzard Updater has stopped working

Problem signature:
Problem Event Name: APPCRASH
Application Name: Blizzard Updater.exe
Application Version:
Application Timestamp: 4f19e111
Fault Module Name: Blizzard Updater.exe
Fault Module Version:
Fault Module Timestamp: 4f19e111
Exception Code: c0000005
Exception Offset: 000b05c4
OS Version: 6.1.7601.
Locale ID: 1031
Additional Information 1: 0a9e
Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
Additional Information 3: 0a9e
Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

Windows 7 Prof. 64bit. 8 GB memory (no swap). ~30 GB free disk space on the SSD wow is installed on. I run the Launcher as administrator.
I tried running in "Safe mode with Networking". Same result.

Launcher log file:
# System started at 2012-02-01 18:54:07.5681
# system: XXX
18:54:07.6301 Launcher version
18:54:07.7483 World of Warcraft version
18:54:09.0246 Starting PatchOnDemand system...
18:54:09.0246 Retrieving torrent information from the server.
18:54:09.0904 Download Tags: EXP3,EXP2,EXP1,Win,enGB
18:54:24.9763 Success writing rebase mopaq file C:\Games\World of Warcraft\Temp\wow-15050-15050-Win-rebase.MPQ.
18:54:28.0184 Required data downloaded. Running update 'Temp\wow-15050-15050-Win-rebase.MPQ'

Updater log file:
World of Warcraft Tools (

This patch upgrades Launcher from version to version
Installing World of Warcraft at "C:\Games\World of Warcraft\" on Wed Feb 01 19:48:01 2012.
Created file "C:\Games\World of Warcraft\BackgroundDownloader.exe".
Created file "C:\Games\World of Warcraft\Blizzard Updater.exe".
Created file "C:\Games\World of Warcraft\Launcher.exe".
Created file "C:\Games\World of Warcraft\Logs\Blizzard Updater Log.html".
Created file "C:\Games\World of Warcraft\Repair.exe".
Created file "C:\Program Files (x86)\Common Files\Blizzard Entertainment\World of Warcraft\Uninstall.xml".
The update was successful.

Any suggestions what I could try to patch?
same problem bro.. :-/
One of the suggested solutions for this problem was to rename the "temp" folder (inside your WoW folder) to "temp2" and then start the launcher again. This may not fix the problem for you, but there is no downside to giving this a try. You may want to reboot your computer before (hard reboot; turn it off, wait a few moments, turn it back on).
18 months out and comeback to this thanks Blizzard

Anyway seemed to have got it working, i think, well as the message doesn't come up and im currently downloading with the (red,yellow,green) taskbar running. I'm still on red but have downloaded 2.75gb of 14.9gb at 1.08MB/s

Basically what i did, was to close everything, go into world of warcraft folder, found in program files, ran the background downloader until i had 2.10gb downloaded...for some reason 1.90gb was already downloaded. After that i closed it and ran the wow.exe and it updated the tools and started downloading like normal...anyway hope ive been of some use. Will update if this fails or works.

If you click on Info and connection info, it'll show you how much you have downloaded and at what speed ect.
Hi there,

Could you please go to your World of Warcraft folder and delete or rename the Temp folder?

Also, could you try running the Repair program found in the main World of Warcraft directory?
Hi there,

Could you please go to your World of Warcraft folder and delete or rename the Temp folder?

Also, could you try running the Repair program found in the main World of Warcraft directory?

I have tried renaming Temp to Temp2 already, with the same result.
I ran the Repair.exe a few times after failed attempts, which essentially restores the launcher to the pre-patch state (and tools are downloaded again upon starting the launcher).
However, none of this solved the problem that the updater tool crashes directly at the start of the optimization.

I'll try to copy the whole thing to my old XP machine next. Maybe the process will work there.
I'm having the exact same problem as mentioned above, although i'm running it on Windows Vista... The process gets stuck at the optimization stage and an error message appears saying that Blizzard Updater has stopped working. Both renaming the temp folder and using repair tool did no good. I also made sure that WoW had firewall permission and anti-virus was turned off. Even so, nothing fixed it...

Join the Conversation

Return to Forum