Stuck on "Updating Blizzard Update Agent..."

Technical Support
Just started doing it this morning.

I click the desktop icon, it starts normally doing the little update thing before the launcher starts but gets stuck halfway through preventing the launcher from showing up.

I'm able to go into the game directory and start the game via the direct wow.exe however any attempts via world of Warcraft launcher.exe just results on being stuck at the updating blizzard update agent stage.

Any ways to resolve this?

http://i.imgur.com/R5jqs.png

Thanks very much
Hi,

The first step would be to delete Agent and see if that helps;
  • PC guide: https://eu.battle.net/support/en/article/6141
  • Mac guide: https://eu.battle.net/support/en/article/6016

  • Could you please try that, then let us know if the problem persists?

    Thanks. :)
    Still getting stuck :(
    Can I please ask what anti-virus software and operating system are installed?

    I ask because certain products (AVG) are notorious for causing issues with such updates, while alternatives (MSE) normally leave well enough alone. Knowing your operating system just makes it a little easier for me to tailor responses to you as sometimes different steps are taken to achieve the same thing.

    Thanks.
    Microsoft security essentials and win7 64bit
    Any ideas? >.<
    same issue here. last night all was fine, today got this problem. i doubt its from my computer since was working just fine 24h ago.
    i use win7, and avast as antiviru
    ps. to all who got this problem: use the second executable from game files to enter game, it works for me. just dont use launcher exe.
    Hi,

    The first step would be to delete Agent and see if that helps;
  • PC guide: https://eu.battle.net/support/en/article/6141
  • Mac guide: https://eu.battle.net/support/en/article/6016

  • Could you please try that, then let us know if the problem persists?

    Thanks. :)

    just did that and still problem persist
    bump? also where i can find repair tool that used to be in game files?
    Got the same problem.
    Using wow.exe to start the game. Blizzard launcher hangs after about 60 % loading.
    Using G-data a-virus and never had probs updating or playing before. It started this morning.
    Can't find repair file (removed after an update?).
    keep this thread alive guys, maybe someone will notice it. wow has a bug....again....
    not only wow. diablo 3 and starcraft also hang at updating.
    Sometimes it says cannot connect to Agent. But most of the time it just hangs.
    The prob wasn't there yesterday and other games have no issues, internet conn. no probs
    like it was said before: use second exe for wow. that works until blizz fix this
    another bump
    Sorry for not posting in the thread for a few days, I've had less time for the forum than normal.

    Please do the following;

    Set the Secondary Logon Service to Automatic;
    https://eu.battle.net/support/en/article/6514

    Update Adobe Flash to the latest version;
    https://eu.battle.net/support/en/article/100513

    Boot into a Selective Startup, then try again;
    https://eu.battle.net/support/en/article/200483

    Ensure your internet settings are configured correctly;
  • Go to the Windows Control Panel.
  • Select Internet Options.
  • Choose the Connections tab.
  • Open LAN settings.
  • Deselect all of the options.
  • Confirm the change(s).

  • And, as always, right-click on World of Warcraft Launcher.exe and select Run as Administrator.
    all i did was to set secondary log on to automatic(it was disabled for some reason) and selected to run as admin. and it worked :)) thank you very much
    I'm having this issue as of today on my Mac. I've followed the instructions above and deleted the battle.net folder etc but it is just hanging on "Updating blizzard update agent"

    Maybe it's just being really slow — I'll let it run for a few more hours.
    Nah, it shouldn't take hours - there's something wrong there.

    Do you have any software updates available?

    If so, please install all of them.

    Otherwise, try booting into Safe Mode;
    http://support.apple.com/kb/HT1455

    Then try again without opening any other programs.
    Uggghhh... Obviously not everyone's PCs decide to mess up all at once. Blizzard just needs to man up and admit the error is on their end and release a hotfix for this... Been a month since I ran into this problem and I still cant get it to work. Tried it all...

    Deleted the Battle.net folder.

    Made sure the Secondary logon was set to automatic.

    Completely uninstalled and reinstalled the game several times.

    Booted up with selective startup.

    Started shortcut as administrator.

    No firewalls up..

    Even tried http://eu.battle.net/wow/en/forum/topic/5208782559?page=1

    Nothing is working. Cant even log into Diablo 3 cause of the same downloader issue. Been killing time on GW2 til hopefully this issue gets worked out but its been over a month.
    Seeing all these bluepost telling us to manually do this and that... Which we shouldnt have to in the first place. Game working 1 day fine.. logout and back in and its suddenly broken..
    Would like to continue playing. But not gonna keep my sub going for something I cant even log into.

    (Note to Blizzard. Fix your crap... We're not paying your company just to have you tell us to fix stuff ourselves.)
    If the steps above don't work do this: Control Panel>Internet Options>Advanced and disable the following: - Check for publisher's certificate revocation
    - Check for server certificate revocation
    - Check for signatures on downloaded programs
    It worked for me.

    Join the Conversation

    Return to Forum