Can't add BattleTag friends

Customer Support
As the title says, I can't add any BattleTag friends. When I try to, they don't get the friend request (and I don't get the "Your friend request has been sent" message). And if someone else tries to add me, I don't get the request either... I've tryed to disable all my addons but it didn't help. It happens with all the players I try to add. And no, I havent reached the 100 friends limit.
Teamobrasil,

Could you please link me to the armory page of a character one of your friends has?

I'd just like to check something, but I need a little more information to be able to do so.

Thanks.
Hey Teamobrasil,
Are you getting any error at all when you try add your friends or simply nothing, also does this happen no matter who you try add?
20/04/2013 08:38Posted by Tiogaradh
Are you getting any error at all

No, I'm not getting any errors.

also does this happen no matter who you try add?

Yes, it happened with all the people I tried to add yesterday.

Could you please link me to the armory page of a character one of your friends has?

http://eu.battle.net/wow/en/character/outland/Equinoxian/simple for example. What you want to check btw?
Do you have the friends/pending/ignore tabs in your friends list? Or do you just have friends/ignore?
I'm pretty sure I have the pending tab too... but I'm not 100% sure.
I can't log in to the game atm but will check it as soon as I can.
Do you have anyone added at all already? If not (silly question, but) you created a Battletag on the site first? Try to have them add you too if you have a Btag etc, I had some people not appear unless they also added me.
20/04/2013 12:12Posted by Nyshae
Do you have anyone added at all already?

Yeah I have at least 60 people added already.

20/04/2013 12:12Posted by Nyshae
Try to have them add you too if you have a Btag

What do you actually mean?
When you send the invite ask them to send you a Battletag invite too, at the same time, it worked for me with some people I couldn't add but it might have been a glitch I guess.
Oh ye... I've tried that too. It didn't work.
Hey again Teamobrasil,
Can you please follow the steps here to fully reset your UI and see if that allows you to receive/send the invites.
Hello,

I tried to delete the cache, interface and WTF folders, but it still does not work to adda battletag or email-adress, both directions.

I also have two other battletag friends added from before, but I ahve experienced 2 persons that I cannot add. The message "Player not found." pops up.

Both Ignore and Pending tab is empty.
One of the person I try to add is http://eu.battle.net/wow/en/character/arathor/Hawkon/simple

Edit: I had to go to battle.net > Settings > Communication Preferences and select on Real ID. Hopethis helps.
Edit: I had to go to battle.net > Settings > Communication Preferences and select on Real ID. Hopethis helps.


You also have to restart the game (though maybe only relog) after having added the battle id

Join the Conversation

Return to Forum