5.4 no more 32-Bit executable.

Technical Support
As Lunyra has found, in 99.9% of cases the 64 bit client actually runs better than the 32 bit client. There is rarely a valid reason to run the 32 bit one. Just run 64 bit and enjoy the game :)


People state they have problems with 64 bit client, and would like to run the 32 bit one, and this is your helpful reply? Heh.
I renamed "Wow-64.exe" to "Wow-64BAK.exe" it now launches 32-Bit just fine.
People state they have problems with 64 bit client, and would like to run the 32 bit one, and this is your helpful reply? Heh.


Please read my response again :) I never said people can never have issues, it's just not the usual reason why people choose to run 32 bit.
Amarielle: Idc if 64 is better or in 99.9% of the cases it runs better.. Im ALSO one of the 0.1% ppl that has issues with the 64 bit version. and your not helping resolve this issue... basically ur telling this is a stupid issue that ppl have and completely ignoring the issues reported (crashing etc, wich I have aswell)... so either stop with ur posts about "how good it must be in 64 bit" or start helping us ;)

Blue post fix please?
You have completely misread and misunderstood. But not to worry :)

Unfortunately for you, it looks like there is no official workaround that we can give you. It would seem it is intended for you to be forced to run 64 bit. Other players have posted possible solutions in this thread, but I would recommend against those, but of course it's your choice.
I wasnt meaning to be rude btw :)

But why on earth would blizzard wanna force ppl to play in 64 bit? ><
Having the same problem, wow always freeze in 64-bit for me -.-
Does not work. One thing that does work though is to simply rename the WoW-64.exe into something else like WoW-64bit.exe or something, then it seems like the client believes you are not running a 64-bit capable system so it lets you start the game in 32-bit mode using the WoW.exe.

Unfortunately the Battle.NET launcher will not be able to start the game any more as it will just toss you an error since it can't locate the WoW-64.exe any longer. But at least those of us who are used to simply start of a shortcut of the WoW.exe will still be able to do so without it forcing you over to the WoW-64.exe


Your my hero. Enb+Sweetfx users can now get their fix.
Just rename the exe

wow-64.exe - rename it to something else - then launch wow.exe - whollah
NO 32 BIT ENNYMORE! AAAAAAAAA!!!!!!! WE WILL ALL DIE! PLEASE FIX THIS RIGHT NOW! :D
I get severe fps drop when trying to record in 64 bit, so i need the 32 bit... I cant make video until the issue is fixed.
FIX

Go to your WoW installation location, ie mine is; C:/Program x86/World of WarCraft.
Rename WoW-64 to WoW-64.bak (to do this just first left click the application to ensure its selected, then right click and hit rename. You can even copy+paste this over it if you feel unsure about naming it. WoW-64.bak)
Then left click anywhere else to allow it it to rename.
Open WoW.exe
Sorry about this everyone - we're working to get an update out that should allow you to use the 32 bit client on 64 bit systems again, without workarounds.

In the meantime, removing or renaming the WoW-64.exe program to something else, should allow the game to launch the 32 bit client.

If players are expeirencing performance issues currently as a result of having to use the 64 bit client, try entering the System settings in-game, and move the View Distance slider back a notch, and see if that helps.

Sorry for the inconvenience this causes.
You have completely misread and misunderstood. But not to worry :)

Unfortunately for you, it looks like there is no official workaround that we can give you. It would seem it is intended for you to be forced to run 64 bit. Other players have posted possible solutions in this thread, but I would recommend against those, but of course it's your choice.

Running wow.exe with the -noautolaunch64bit switch is the official workaround the devs added ;)

Hopefully they will soon fix the constant crashes the x64 version is having for some of us, but until then I'm stuck on 32 bit :(
Basically, all the people who wants to use 32bits client are botters. lol
Simply rename or delete wow-64.exe and it's fixed.
You can launch wow.exe with this console parameter -noautolaunch64bit
Mine just puts a new wow-64 in the folder when i try to open the game with the 32 bit .exe
I renamed "Wow-64.exe" to "Wow-64BAK.exe" it now launches 32-Bit just fine.


Easiest would be to just delete the 64 bit exe. I had issue with sweet fx related to this, and this simple solution worked well. U could also just make a batchfile to delete the file and lauch wow via command line. Open notepad, paste in code, save as wow.bat. Place anywhere, make shortcut to desktop and launch as u would with the normal shortcut for wow. :) Also make sure to use a fancy icon for the shortcut. :D

CODE BELOW:

del "D:\World of Warcraft\Wow-64.exe"
D:
cd World of Warcraft
"World of Warcraft Launcher.exe"
exit

Note that you still should have 32 bit enabled in laucher options. Good luck. :)
If you want wow to go in 32bit just take all the setings on low, when you open wow it says x84 but it works, atleast for me.
hope it works for u guys too

Join the Conversation

Return to Forum