Latest patch not downloading

Technical Support
Hello, I've returned to WoW recently haven't played in almost a year, I don't know which patch number I'm on.

Anyway I started the launcher and it started downloading a 4.5gb update, from version 3.x to 4, the update finished in the traditional sense and I had a setup like installer updating my game, once that was done, I started the launcher again and now I'm on a Cataclysm like window "Cataclysm Launcher" and it says at top of my window "World of Warcraft v4.0.0.12911", there are 3 steps the downloader is supposed to go through but nothing is happening, it says at bottom "Total download remaining: 4.0 GB (0.0 KB/s)" and I can't click on the Play button.

The first time I starter the launcher the download remaining was 2.xGB and it looked as if there was traffic but for 2 hours the download remaining remained the same so I restarted the launcher and now nothing is happening.

Edit: After restarting the launcher several times it gave me an error and told me to try the repair tool, trying that now...

Edit 2: Ok after repairing it is downloading once again, I can't seem to delete threads on this new forum so you might hate me if you read the wall of text and then find out I solved the problem
I'm having a very similar problem. I restored my PC to factory settings so had to re-install WoW. After installing to patch 4.0 my WoW client updated to the cataclysm theme, and then started to download some 8gb patch. Very unsual but im letting it download and its stuck on 0.0KB/s, it destroys my whole internet, i cant open any webpages when this happens etc. My WoW client says it's version

I've never had this problem before so it can't be from my side.

My ISP is virgin media. Any other download from the internet is working at optimum speed. It's jus WoW thats messing up everything.

Here's a screenshot of my launcher showing the download + version:

Help please :)

Make sure your ports are correctly forwarded. World of Warcraft uses the TCP protocol on ports 3724, 1119, 4000, 6112, 6113 and 6114. The World of Warcraft Voice Chat feature uses UDP port 3724.

The peer-to-peer system used to download patches will benefit from having ports 6881 through 6999 forwarded.

Configuring your router for use with World of Warcraft and the Blizzard Downloader:

Port forwarding instructions for many routers can also be found on the following third party website:

Configuring your firewall for use with World of Warcraft and the Blizzard Downloader:
I've configured all the correct port's however it did not help. I have no firewall active at the moment, disabled my Anti - fire wall programme and my windows firewall. I am running windows vista and i have also tried running as admin. still no help.

I have decided to re-install WoW and then use the "xxxx. updater exe file" to update my WoW to that version. And then i shud only have to download worth of files to play WoW right? i'll report back if it helps.
Since i couldnt get any answer on why i couldnt log into the game with my chars after latest patch i decided to delete wow from the computer and try to reinstall.

However i seem to get stuck on I download with full capacity until i get to just that point and then i go down to 0.0kb/sec. Sometimes tho it stands 4.4gb/sec. which would make the game downloaded in 3 secs but well not everything is perfect right?

I have no problems with isp firewalls or anything else since i can download everything else just fine, and i doubt that anything will change after i get to download the first 6 gigs of wow or?
Ports are forwarded, now it's downloading, when I check connection info it says I'm downloading at 60 - 80KB/s and downloaded is 700mb, but on the progress bar on the bottom it shows I'm still downloading the "Setup" and it have been stuck at 164.1/164.4MB since hours.

The Play button is still disabled.

Join the Conversation

Return to Forum