StarCraft® II

Game closes instantly at login screen.

Every time i start up StarCraft the game closes as soon as it gets to the login screen.
Reply Quote
I had something similar, although mine doesn't even get as far as the patcher. I had something incredibly detailed; then I swallowed a bug. I'm not even sure if this will post but I'm hopeful.

I get the Raynor splash screen if I run SC2Switcher in the support folder but that results in the same problem as Leeum. The game closes instantly without so much as an error message.

Running the game normally, The Launcher "connecting to patch server" but as soon as the patcher opens it closes again. No patch notes, no download in progress.

Windows XP
ATI Radeon x1300 Mobility (lololol yes I know)
I've checked my Firewall
I've checked my Anti-virus
I've checked my "Lan settings" in the "internet options > Connections" workaround that was mentioned in the US forum.

The game has worked perfectly since release until today
Reply Quote
Yeah i have had no problems until logging in today, as soon as they Raynor splash screen is over the game closes.
Reply Quote
Blizzard Employee
ATI Radeon x1300 Mobility (lololol yes I know)


:-)

It shouldn't prevent you from patching.

I have seen this issue affecting users with either limited or incorrect permissions. Could you please create an administrator account in Windows, once logged in with it simply try running the launcher.
Reply Quote
I have same problem, had it once before also but after a while without doing anything eveything came to normal. I have only 1 windows account and i've played on it since the begin so i dont think this would be the problem.
Reply Quote
I have administrator rights, with full permissions.

As stated, the patcher and game worked just great until today.
After some mutilation, I deleted the Battle.net-patch.mpq file from the Battle.net folder in the SC2 folder.

The patcher actually ran~ It started downloading.

As soon as it finished downloading (obviously redownloading the file I just deleted), it closed again. And now it is the same problem as before. As soon as I double click the SC2 icon, the patcher opens for a second, and then closes again.

"This patch upgrades StarCraft II from version 1.0.1.16195 to version 1.0.2.16223.
Installing Blizzard Updater at "D:\Program Files\StarCraft II\" on Fri Aug 06 13:41:50 2010.
Created file "D:\Program Files\StarCraft II\Battle.net\Battle.net-patch.MPQ".
Created file "C:\Program Files\Common Files\Blizzard Entertainment\StarCraft II\Uninstall.xml".
Created file "D:\Program Files\StarCraft II\Logs\Blizzard Updater Log.html".
Created file "D:\Program Files\StarCraft II\Mods\Core.SC2Mod\Backup.MPQ".
Created file "D:\Program Files\StarCraft II\StarCraft II Editor.exe".
Created file "D:\Program Files\StarCraft II\Support\Battle.net.dll".
Created file "D:\Program Files\StarCraft II\Support\SC2Editor.exe".
Created file "D:\Program Files\StarCraft II\Support\SC2Switcher.exe".
Created file "D:\Program Files\StarCraft II\Versions\Base15405\patch-enGB.SC2Archive".
Created file "D:\Program Files\StarCraft II\Versions\Base15405\patch.SC2Archive".
Created file "D:\Program Files\StarCraft II\Versions\Base15405\SC2.exe".
The update was successful."

But the game will still not run.
Reply Quote
Leeum, out of interest, have you actually managed to patch your game? are you using v1.02?
Reply Quote
I have had no prompt for a patch whenever i start the game up and i have clicked the downloader in the Starcraft files but says there is nothing to download.
Reply Quote
Blizzard Employee
The Updater Log confirms you have successfully updated to version 1.0.2.16223. Did you run the Windows System Restore recently?
Reply Quote
Huzzah~ I got it to work. Here's how I did it:

D:\Program Files\StarCraft II\Battle.net
Delete Battle.net-patch.mpq
Run SC2 normally, It will probably redownload the patch - and then promptly close - wont be able to open again (Thats how it was for me)
Then go to:
D:\Program Files\StarCraft II\Support
Run SC2Switcher.exe

I'm not exactly sure what it is, lol. It seems to ignore the normal launcher, and thus avoids the sudden "close"

I'm now sitting on the bridge eyeing up achievements. Let me know if this works for you too Leeum.
Reply Quote
The Updater Log confirms you have successfully updated to version 1.0.2.16223. Did you run the Windows System Restore recently?


No, I've never run a system restore in my life. It seems there is a problem with the launcher, not with actual patching. After deleting the patch mpq, it patched successfully. I've posted my workaround above.
Reply Quote
After deleting Battle.net-patch.mpq and starting up Starcraft im stuck on the login screen but without the actual login boxes. It's just the backround screen and i have to alt f4.
Reply Quote
Doesn't start downloading the patch here as well.. I get a box Launcher Connecting To Patch Server for a second and then the game pops up, in the left corner it says version 1.0.1.etc (so not the new one), I try to login and a box pops up about awaiting response..
Reply Quote
Try running the fixer now. It never once worked for me, but it might for you. I'm just posting my experiences, I've seen some people stating that they had to reinstall SC2 entirely.

I'd like to try avoid that if I can. 12 GB is a monster install wait.
Reply Quote
In your case worked, in mine dosent... i did all u said (deleted Battle.net-patch and stuff) but it seems i have the same problem Leeum have.. when I get into the game i m stuck on the loging screen and i dont see any boxes not even that one where u have to put the log in account)
Reply Quote
Yes indeed if reinstall ScII it will work, but i want to avoid this too.
Reply Quote
Nothings working so im reinstalling.
Reply Quote
Well at least thats a step in the right direction sort of. At least it doesn't instantly close lol~

I haven't experienced that, so any suggestions I offer are just guesswork~ There is a blue somewhere in the forum today ~ Maybe they can shed more light on the situation.

There are some other tools in the Support folder, The Updater and the Downloader, they might be able to repair it at this point, but again, this is just guesswork.
Reply Quote
Hi there just wanted to say i have the exact same problem as Leeum and ZulThan. I am now also cursed with the empty menu after deleting Battle.net-patch.mpq.
Reply Quote
Blizzard Employee
Thank you for your replies. I need to know what security software you're running, operating system and whether Proxy connections are disabled in Internet Explorer -> Internet Options -> Connections -> LAN settings.

On Windows Vista / Windows 7, please try right-clicking the game icon on your Desktop and choose Run as administrator.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]