StarCraft® II

Stuck at Initializing Data

Posts: 14
I got patch 1.5 installed quick and easy but I cant manage to log on. When I launch SC2 it first gets stuck on "Launcher Connecting to Patch Server..." for few minutes or not launching the game at all. If the game launches, I get stuck on "Initializing Data" during login. The progress bar starts slightly but then nothing happens. The game doesen't exactly crash but I cant alt tab out and the only way out of it is alt+f4'ing. Im on a PC. Help please!
Reply Quote
Posts: 14
Bump, still not working..
Reply Quote
Posts: 5
Same problem i get about 40% done then it gets stuck there, tried 2 times, quitting with alt f4 and then restarting. No cigar. Getting kind of pissed. Its been sitting at 40% for an hour now.
Reply Quote
Posts: 5
Hello anyone? I redownloaded the whole client, now i sometimes get past the initializing data screen, but then it tells me ive "lost connection to battle.net".. never happened before patch 1.5 Just great, still cant play. Sometimes still gets stuck on the initializing data screen but doesnt even show progress bar. Sometimes launcher doesnt work.. i mean seriously blizzard would you please even respond?
Reply Quote
Posts: 14
I still cant login either. I already gave up after trying to solve it forever.
Reply Quote
Posts: 4
I waited patiently and tried a lot of different things and it took like 10 minutes for the data to initialize, but now I'm in.

It seems they have changed the client a lot. Not only the UI, but also how the internal start-up works.
Reply Quote
Posts: 5
nakedman, i have gotten past the initializing data screen by deleting the programdata and letting it download it again, but then it tells me ive lost connection to Battle.net.. and when i try again it gets stuck on initializing data again. now been sitting there for 50 minutes. Ill let it sit overnight, but im pretty sure blizzard has broken something for me. Always worked before.. Its taking 60-80 cpu % and a hella load of memory but not doing anything. pissing me off
Reply Quote
Posts: 436
I have the same problem. It stops when initializing data after 5 % Although i can easely alt-tab out of the game.

Edit: the status bar creeps up , now at 45 % but progressing at unacepteble slow speed unless its only the first time it does so slow.
Edited by Jonzen on 01/08/2012 21:10 BST
Reply Quote
Posts: 5
it is the first time, but for me it doesnt work afterwards on my internet, checking port forwarding now. Hope it helps. mine worked on another internet.
Reply Quote
Posts: 4
I hope this get's fixed soon...
Reply Quote
Posts: 6
Try deleting the Battle.net folder found in:
-Win7: C:\ProgramData\Battle.net
-XP: C:\Documents and Settings\All Users\Application Data\Battle.net
-Mac: Users/Shared/Battle.net

I found this help by a blue on us.battle.net forum
(http://us.battle.net/sc2/en/forum/topic/6232304062)

This helped me, so here's hoping it'll help others in similar situation :)
Reply Quote
Posts: 14
I have tried deleting the battle.net folder as well as reinstalling... Still the same thing. Sometimes the loading bar gets further, almost to halfway but then stops moving forever. Seems pretty hopeless...
Reply Quote
Posts: 2
The initializing data screens loads for much longer than it should have to. I am sitting on a very fast gaming rig and it still takes about 2-7 minutes to load. took about 15-20 the first time i started sc2 after the patch. But it does finish the loading, just takes way to long...

Hope this is something that blizzard will fix soon.
Reply Quote
Posts: 1
I was getting stuck at initializing data. Got it solved by connecting to internet through my mobile USB stick. When it kept getting stuck I used my cable connection and had all the firewalls etc. disabled from the cable modem.
So for me the problem seems to be internet connection related. Now I'll adjust the cable modem settings and try to get it work through there.
Reply Quote
Posts: 3
I have the same problem. Initializing data got stuck to about 5% even I left it open overnight after I had reinstalled the game.

I reinstalled the game again and the initializing bar got to about 60% but then it got stuck again. Force quit SC2 and tried again, got stuck to 5% again.
Reply Quote
Posts: 1
Bump. I have similar problem, haven't found any fix yet.
Reply Quote
Posts: 3
Bump. Please is there anything we can do? I'm experiencing the same problem here. Deleted the folders and still doesn't work. Please blizzard give us something.
Reply Quote
Posts: 2
Bump, does anyone have any other suggestions? Deleting the battle.net directory from my Application Data has made no difference. Application still hangs indefinitely at 'Initializing data...'. No network activity.
Reply Quote
Posts: 6,435
run it in safe mode with networking.
Reply Quote
Posts: 3
Anyone have any luck with this problem? My initializing data goes super slow. (maybe an hour) And then when the game finally starts I still can't play.
Does anyone knows what it does when it initializing data?

I have tried it in safemode.
I have updated the drivers for my graphic card and network card.
I formatted my computer and installed win7 again. (after that it got even worse. Before that it was slow but I could play.)
I have open all the ports on my router for sc2.
I have tried it with no "startup" programs at all.
I have hit my head against the wall.

..But nothing helps!
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]