StarCraft® II

getting fps lag spike whenever cybernetics core finish

Posts: 750
in every game i play since hots release i get a 2 second lag spike when my cyber core finish, its the only point in the game i lag, anyone else experienced this or have solutions?
Reply Quote
Posts: 35
Yes, exactly 1,8 seconds resource stall when cybercore finishes. This is the most "visible" one but there are many other similar lag spikes.

The only PARTIAL solution I found so far is to run the Unit Preloader 2.0 from the arcade section every time I start up Starcraft II and only after that start playing. This will pre-load all the missing assets in the memory so the game does not have to stream them from the hard-drive/SSD during game play. Please note that this will only work if you have the particular choppy performance/mini-lag/ stuttering the first time the game loads a building model/unit/effect etc.

Other threads describing the EXACT same issues :

EU forums :

http://eu.battle.net/sc2/en/forum/topic/6893510321

http://eu.battle.net/sc2/en/forum/topic/6893980790

US forums:

http://us.battle.net/sc2/en/forum/topic/8197911140

http://us.battle.net/sc2/en/forum/topic/8196604731

http://us.battle.net/sc2/en/forum/topic/8197580729?page=2#21

Please Blizzard do something about this !
Edited by Florin on 28/03/2013 22:05 GMT
Reply Quote
Posts: 37
same here :( have SSD
Reply Quote
Posts: 13
same problem here, but iv a hdd
Reply Quote
Posts: 35
Have you tried the Unit Preloader from the arcade section ? It really helps.
Reply Quote
Posts: 37
Aye help , but it should work without it :(
Reply Quote
Posts: 35
I totally agree it should work without it...
Reply Quote
Posts: 6
glad I came to the forums and found 3 threads with the same issues, means blizzard will sort it out and its not on my end =D......found the unit preloaded helps alot btw
Reply Quote
Posts: 52
same problem here
Reply Quote
Posts: 20
this was how my lag and stutters started, it just increased in time and game is running so bad at moment
Reply Quote
Posts: 119
There is a map called "Unit Preloader" in the Arcade section of bnet. It preloads every unit, structure, spell and animation. Start it first after starting SC2. It will solve the problem.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]