How does "Reduce Input Lag" actually work?

90 Human Warrior
3285
I ask simply because with it unchecked I notice very subtle "micro stuttter" on sceneary when i strafe around. For example if I look at a tree in the distance, and strafe left to right the tree will "skip" a few frames every so often. It's quite off putting.

Now, when I enable "Reduce Input Lag" the suttering goes away. I am able to keep 60fps with it on for the most part, but it does slightly impact my FPS in certain areas.

I'm just curious what it actually does from a technical view point and how it actually works. If I could isolate why that fixes the problem perhaps I could change something else (maybe it's keyboard or mouse related for example) to remedythe situation without the loss of FPS.
Edited by Jextwah on 24/05/2011 16:37 BST
Reply Quote
90 Human Warrior
3285
Bump
Reply Quote
85 Goblin Death Knight
9290
I think I have the same micro stutter / hiccup problem,
made a post about it too, with a video too show it:

http://eu.battle.net/wow/en/forum/topic/2151755907

Gonna try turning it on too see if it helps a bit,
Do you have V-Sync on or off? and with Triple Buffering or without?
I had all 3 of those options off gonna fiddle with it now.

Oh and are you running WoW with an ATI card?

Its really annoying, but seems too affect world but not instances/raids/arenas.
Edited by Tsurugi on 26/05/2011 12:00 BST
Reply Quote
85 Goblin Death Knight
9290
Got it fixed now though..

Had too turn down Shadow Quality too Fair,
Enable V-Sync, Disable Triple Buffering and Enable Reduce Input Lag.

Used too have it on Shadow Quality High ( Recommended setting ),
And no V-Sync since no tearing, and no Reduce Input Lag since I didn't have any..

So I suppose Blizzard made some changes with Shaders in 4.1.

Also Liquid Detail on Good gives me a fps drop when I hit large bodies of water,
but acceptable since not below 30fps and it looks way better.
So if you hit below 30fps you could set that on Fair setting aswell.

At least no Stutter/ hiccup anymore and 30-40 fps in cities and 40-60 fps world again.

Hope this helps other people that experienced same problems.

Might be ATI cards only since Blizzard is supporting NVidia's 3D settings,
if this is the case Blizzard please remove the 3D stuff since WoW was never meant as a 3D game and its only a small portion of the community that uses it...
Reply Quote
14 Night Elf Druid
0
Input lag is to do with how long it takes what ever action you make in the game to apear on the screen.

So for example if you have ever played a game where your mouse course seems to be takeing a fraction of seconed to start moveing on your screen affter you have started moveing it with your hand that is due to input lag.

All monitors suffer with input lag most it is hardly noticable but it is allways there to some degree and some games it can be more noticable, you might notices your monitor has an option on it for a gameing mode that is a special programed mode optimised for reduceing input lag. And I am guessing that the reduce input lag option in WoW is a simialer featuer that changes the way it is processed slighty to try and speed up responce times.

Micro stuttering is a problem assosiated with SLi and Crossfire, for example with 2 or cards running one card might have finshed the frame it is rendering a milliseconed or to before the other card has finshed it's next frame so in order to keep the frames in order the first card has to hold off sending it to the screen before the seconed card has finshed this can cuase a slight micro stutter.

You dont get micro stuttering from only haveing one card
Reply Quote
85 Goblin Death Knight
9290
@Allonon

It probably isn't called micro-stuttering but it sure feels like a stutter and thats why I named my post stutter / hiccups in WoW.

I play with one card and if you look at my movie that I posted in my thread you will see what I am actually talking about.

I dont know what I had experienced in WoW is called, but it felt like a stutter / hiccup.

I never had this problem before and it popped up after 4.1, enabling the reduce input lag and setting shadow quality too fair, v-sync on and triple buffering off actually fixed it, so I don't really care what you call it but I would assume it is a shader issue.

Sorry for not knowing that Micro-stuttering is actually a SLi/X-Fire issue,
but hey... a stutter is a stutter so thats what I named it.
Reply Quote
90 Human Warrior
3285
I appreciate your attempt at explaining, but you seem to of missed the point.

I'm aware of what reduce input lag does, I'm not aware of how it does this. That was the question.

I accept that microstuttering is a term that was used for sli/crossfire issues during their infancy, and also that 99% of microstuttering associated with sli/crossfire have for the most part been resolved. If it helps you I will use a different term such as stutter / jitter / choppyness - whatever. Calling it a micro stutter was neither here nor there, it was just to explain the effect of the problem. The point is it happens, exactly as I described.

I don't suffer with input lag, yet the option fixes the problem.

For clarity my spec is:

Phenom II 3.6ghz Quad
4GB DDR3
1GB 460GTX
1TB Samsung Spinpoint F1
Win 7 Ultimate 64
22 Inch Acer monitor (5ms response time - I don't get any ghosting or input lag)

I run on ultra settings, with shadows/liquid on good, sunshafts on low. 4x/4x aa/mssa.
V-Sync / Triple Buffering Enabled - necessary to prevent screen tearing as I run well above 60fps in most zones, also I get more stutters / choppyness with them off.

I maintain 60+ fps in 99% of zones, minus SW around the busy areas (trade etc.)

The issue I describe is not gamebreak, but it's present and has been there through a few different builds and I notice it on friends machines. Strafeing left to right, focus on a piece of sceneary like a tree, i notice it skips/stutters every few steps.

I noticed Reduce Input Lag removed the skipping and I was curious how it works so I can try to understand what the problem actually is. I know what it does (it's self explinatory) but I don't understand why it fixes my problem as I have no input lag so I wanted to find out how it works.
Edited by Jextwah on 26/05/2011 17:42 BST
Reply Quote
14 Night Elf Druid
0
Sorry think it just changes the way the code is handled slightly to try and speed up responce times but I think this has a bigger hit on CPU useage which is why so many people see the FPS drop alot when it is enabled.

And yes I know what you mean now, your running at a constant fps but some of the things in the distance looke like they are skipping slightly when your strafeing, thats just WoW it has allways been like that as far as I can reamber lol :)

Reply Quote
85 Goblin Death Knight
9290
I have my sunshafts back on, thats not an issue, try setting your settings too wich you normally have it and turn shader quality back too fair. ( with 8x AA they still look nice )
That fixed the problem entirely for me along with Reduce input lag and having Vsync on but Triple Buffering off ( if TB is on I get a fps drop when turning camera )
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]