Repair Tool

90 Human Death Knight
10880
Every time i use it, i get the message "wow was successfully repaired" and after i run Launcher "downloading updated tools", 30 mb remaining.
And i can keep it like this on and on and on, it never stops.
Repair log, maybe you can read something from here and fix this.
Also, this is after a fresh install of WoW.
---------------------------------------------------------------------------
13:30:40.3233 Repair version 4.0.0.742
13:30:41.8327 Repair is running as Administrator
13:30:41.8351 The Repair utility could not detect the game backup mopaq in RepairTools::RepairWOW::GetLatestBackupMPQVersion()
13:30:41.9256 Detected game version '14333'
13:30:41.9256 Detected game locale 'enGB'
13:30:41.9256 Detected game expansion 'Cataclysm'
13:31:05.7367 Repair verified permissions for folder 'D:\World of Warcraft\'
13:31:05.7393 Querying LDAP at 'http://enGB.patch.battle.net:1119/patch'...
13:31:07.5356 Initializing repair configuration data at 'http://attdist.blizzard.com:80/repair/wow/repairconfig_eu_99EB212F727B8208D4B374C083611604.xml'...
13:31:07.8153 Server 'http://attdist.blizzard.com:80/repair/', priority '0', weight '1'
13:31:07.8153 Server 'http://blizzard.vo.llnwd.net:80/o16/content/repair/', priority '0', weight '1'
13:31:07.8154 Successfully found version '4.2.0.14333' for product 'WoW' in the repair configuration.
13:31:07.8155 Downloading 'http://blizzard.vo.llnwd.net:80/o16/content/repair/wow/7/B/7B2FC8509F2C06062A8DE83160AE762F'
13:31:08.0634 Downloading 'http://blizzard.vo.llnwd.net:80/o16/content/repair/wow/F/F/FF2F004FA457EEEED15F2660501D1AF3'
13:31:08.1276 Downloading 'http://blizzard.vo.llnwd.net:80/o16/content/repair/wow/7/9/79D1DB15DF1F153EEA99FB0E6C024104'
13:31:09.3788 Repairing Launcher.exe (F8DCF041E25F36C2FB23EB42764038F5) from Backup.mpq
13:31:09.3789 The Repair utility detected a RepairLooseFile extraction error in RepairTools::RepairEngine::ExtractLooseFileFromBackup()
13:31:09.3789 Downloading 'http://attdist.blizzard.com:80/repair/wow/F/8/F8DCF041E25F36C2FB23EB42764038F5'
13:31:29.1137 Repair completed successfully with 1 repairs.
----------------------------------------------------------------------------
Edited by Aleksandru on 06/07/2011 14:34 BST
Reply Quote
90 Human Death Knight
10880
nothing?
Reply Quote
Blizzard Employee
Hello,

06/07/2011 14:33Posted by Aleksandru
And i can keep it like this on and on and on, it never stops.


Does it mean that the 30MB download gets stuck?
Reply Quote
90 Human Death Knight
10880
Nope, after every Repair that download (30 MB) pops up again.
And if i use repair, the same thing again.
And the PLAY button its always on gray for a few seconds, althou i have downloaded everything.
Reply Quote
Customer Service
Are you able to play the game?
Reply Quote
90 Human Death Knight
10880
Yes.
But whats with that glitch?
Or as long as i can play, none cares?
Reply Quote
Customer Service
There are some temporary files that need to be verified and downloaded when you are starting the game, this happens after each repair.

As long as you repair this will happen.
Reply Quote
85 Worgen Priest
1390
yes same here. didn't happened at previous patches. but it does at 4.2k if you repair ,30mb downloads again.
Reply Quote
90 Human Death Knight
10880
You still don't understand what i want to say.
Everytime i run Repair and then Launcher, the 30MB download appears.
Why? I already downloaded it just a few minutes ago.
This is what i mean.
After the download is over, if i run Repair again, run Launcher, the 30 MB download appears again, and so on, got it now?
Reply Quote
Customer Service
Why are you running the repair, if the game is downloaded and you're able to play, why do you need to keep running the repair tool? It's only there if something's going wrong, if you can play the game fine, there's no need to keep running the repair tool.

Like my colleague Kropacius says, there's some temporary files that get re-downloaded after running the repair tool.
Reply Quote
31 Human Paladin
0
I have the same problem too...
when i clik to launch the game, the dowloader start to download the latest pach...but after a while the download freezes and if i close the downloader and start it again, the download begins normaly but when it begin to apply the downloaded files it cant and says to run the repair tool...i run it ....But the same think happened every time, over and over again and again... Download ---> applying dowloaded files ---> stopes ask for run the repair tool----> the game are repaired ----> starting the downloader and all over again.....!?!?!?!?!?!?!?! PLEASE help me.... i cant play the game... Now said Total Downloading Remaining: 107.0 MB and freezes
Reply Quote
Customer Service
I have the same problem too...
when i clik to launch the game, the dowloader start to download the latest pach...but after a while the download freezes and if i close the downloader and start it again, the download begins normaly but when it begin to apply the downloaded files it cant and says to run the repair tool...i run it ....But the same think happened every time, over and over again and again... Download ---> applying dowloaded files ---> stopes ask for run the repair tool----> the game are repaired ----> starting the downloader and all over again.....!?!?!?!?!?!?!?! PLEASE help me.... i cant play the game... Now said Total Downloading Remaining: 107.0 MB and freezes


That sounds more like a permissions problem, in that the game is trying to save or update files that it does not have access too.

- Locate the World of Warcraft icon on the desktop.
- Right-Click on that icon and select from the menu that appears Properties
- Select the Compatibility tab
- Locate the section named Privilege Level
- Check the box named Run this program as administrator
- Click Apply then Ok
- Restart the game again to retest, if the same issues appear.

In addition also check to see what security programs you have running in the background, especially any security programs, that could blocking the launcher and the update process.
Reply Quote
66 Human Death Knight
0
Under the compatibility tab, i cant see any privilege level section... I can see only 3 sections, 1st compatibility mode, 2nd display settings and 3rd Input settings.... No Privilege section !
I have the windows xp version...and after this patch everything was normall....
I have the Panda GP antivirus and XoftSpySE Anti-Spyware by Pareto Logic and Microsoft Security Essentials And btw i have opened all the ports that the game needs to run...port forwarding, router ports, firewall ports...all of them!
Edited by Ulmar on 17/07/2011 12:16 BST
Reply Quote
85 Orc Death Knight
3810
Same here, this seems to be related to the launcher bugs since the last patch.

It places this in the repair.log every time you run a repair:

18:41:06.5591 Repairing Launcher.exe (F8DCF041E25F36C2FB23EB42764038F5) from Backup.mpq
18:41:06.5591 The Repair utility detected a RepairLooseFile extraction error in RepairTools::RepairEngine::ExtractLooseFileFromBackup()
18:41:06.5591 Downloading 'http://attdist.blizzard.com:80/repair/wow/F/8/F8DCF041E25F36C2FB23EB42764038F5'
18:41:28.7788 Repair completed successfully with 1 repairs.

Basically repair is detecting that launcher.exe is a bad file and downloading a new one. The problem is that when you run it, it downloads the latest and broken version again. If you run repair again you get the exact same thing.

Wow's own logs proove it's a problem with the launcher, not the client pc. I can't believe no one there even checked these logs so this anti-virus excuse is a fob off isn't it? :)
Edited by Zayst on 17/07/2011 12:24 BST
Reply Quote
Customer Service
Under the compatibility tab, i cant see any privilege level section... I can see only 3 sections, 1st compatibility mode, 2nd display settings and 3rd Input settings.... No Privilege section !
I have the windows xp version...and after this patch everything was normall....
I have the Panda GP antivirus and XoftSpySE Anti-Spyware by Pareto Logic and Microsoft Security Essentials And btw i have open all the ports that the game needs to run...port forwarding, router ports, firewall ports...all of them!


Your AV software may be blocking the update, try checking to see if the program is configured to block the launcher, you may need to check that programs rules, or try to configure it to allow the launcher to update correctly.

Failing that completely removing the security software then using the dedicated removal tool that many of those programs have available may be the only way to allow the launcher to update what needs updating.
Reply Quote
31 Human Paladin
0
The WoW Launcher is on the exceptions and allowed to download or something and i cant see anything wrong with the AV program or the AS programs all of them have the WOW -all-exceptions i will try to stop the AV and download the pach..but i'm afraid for such actions....but i'll do it and i'll inform you again for the results....Anyway thanks in advance.. and if you think anything else about tis problem...here i am to folloe the instructions..THANKS!!!!!! i'm out now...log off!!! see ya!!!!
Reply Quote
31 Human Paladin
0
the problem with the downloading the patch still exist....and as the friend above said....i'm afraid it's a core problem or downloader getting crazy and redownloading all the time it's broken self...i think Blizzard must see this problem seriously.....i'm waiting for results....Thanks in advance!!!!! BTW i can't play all this time the game and my nerves are broken...
please H e l p !!!!
Reply Quote
85 Troll Rogue
2260
Just being on the exceptions doesn't mean it'll automatically get through.
These are tech support posters, I'm fairly certain they know what they're talking about.
Try running the client on it's own, using the WoW.exe file. This can sometimes automatically download patches - if not, it'll do it through the downloader and not the launcher tool.
Reply Quote
90 Draenei Shaman
7285
right click .exe icon >> run as administrator.

This fixed ever issue I had sofar. ;))
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]