Razer Lycosa Keyboard Question.

85 Night Elf Warrior
6210
Hello everyone. I just got an awesome new keyboard, the Razer Lycosa on my Bday. However after I used it for a while I discovered a touchpad up in the right corner.
This one is very sensitive. For example if I press one button the Keyboard will either light up all buttons, WASD or nothing will light up. and it keeps going on and off sometimes when I game and its anooying.

Does anyone have any idea to make the touchpad less sensitve or mabye making the touchpad not react on anything. Open for more suggestions.

Cheers.
Reply Quote
85 Blood Elf Hunter
3820
Hey
Happy birthday and I hope your enjoying your new keyboard.
As with any button on the Razer Lycosa keyboard I believe there is a way to disable it via the Razer Lycosa keyboard management software.

http://www.razersupport.com/index.php?_m=downloads&_a=view&parentcategoryid=111&pcid=20&nav=0,77,20

Download the driver that matches your keyboard or alternatively install the drivers that came on the disk with the keyboard.
From here you will be able to disable and customise any key.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]