[Bug] The Battle for Gilneas City (worgen)

85 Worgen Warrior
1645
just spent ages doing this quest (i kept getting lost because i suffer from migraines so i have to have brightness and contrast on zero and thats a dark city!! lol, and somehow ended up versing an elite on my own) anyways I get to the final boss, and just as we are all attacking (me and the NPC's) suddenly loading screen pops up and im back at the beginning :S, I notice that another player is at the beginning and guessing by his actions his started the quest, which means when he started it, I got booted from it to start again....I could have joined him but I was so angry over it all that I would have probably just ended up raging and running out ahead and gotten killed so I decided for his sake ill just leave it...but yeah, is this common? or was I just unlucky?
Reply Quote
85 Worgen Warrior
1645
EDIT: ok I got it working for future reference if anyone has this problem: abandon the mission, then reaccept it, stick with the crowd the whole time after the catapult section in the military district, eventually they will all group where the boss was there and just refill their morale, and eventually they will all storm off to final part, follow them.

I then went straight into the building behind the boss and joined in again after I was sure I was not being booted, and it all turned out fine.
Edited by Warstyle on 22/12/2011 11:37 GMT
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]