WoW launcher x64

Hello Support

I've updated my tools, but when the installation is complete the launcher errors and I am unable to run the game from it. I can run direct from the .exe without any issues.

Here's the information from the log about the launcher :

3747 Updater failed due to an internal or XML data problem. Message is 'Blizzard Updater was unable to start up.This update does not need to be applied. It requires a version of "WoW.exe" older than 4.3.4.15595, but you already have version 4.3.4.15595.

Is there away I can get around this?

Cheers
Grim
Reply Quote
90 Human Death Knight
10595
Simply because it's the easiest thing to start with, I'd try deleting the Launcher and then running the Repair tool so that it will download a new one. This will tell us if it's a problem with the launcher itself or if the issue lies elsewhere.

Also, can I ask if you have recently been playing on one or more US realms?
Reply Quote
Thanks for the speedy reply Doomsinger.

Doh, I didn't even think about doing that. I'll delete the launcher now.

No, I haven't played on any US realms. In beta I have, but not on this account.
Reply Quote
90 Human Death Knight
10595
Ah, that's fine since the beta has an entirely separate installation.

I'm not promising anything with that suggestion, but given that it's far and away the quickest and most simple thing to check, it's always frustrating to spend hours helping someone only for that to solve it in the end. :-)
Reply Quote
Ok, new launcher in and I still get the same error message in the logs.
Reply Quote
90 Human Death Knight
10595
I regret nothing!

Do you have a Temp folder in your World of Warcraft directory? If yes, please delete that, and regardless of if you do or don't, please remove the Updates folder.

Once you've done the above, try the Repair utility again.
Reply Quote
Deleted the two folders as you suggested. Ran the repair tool, still getting the same error when running the launcher.
Reply Quote
90 Human Death Knight
10595
Well, I know you won't like this, however I'm aware of one player who solved this problem when deleting the Updates folder for the second time, and a further player who had the issue resolved after going through four Updates folders.

Can I ask if you are running the Launcher by right-clicking on it and selecting Run as Administrator?
Reply Quote
I'll try again with deleting the updates folder a few more times.

No I don't runas admin, I've just tried runas but get the same error. Just running the repair now.
Reply Quote
90 Human Death Knight
10595
The only other thing I can think of is booting your computer into Safe Mode with Networking.

http://eu.blizzard.com/support/article/19393
Reply Quote
Finally got it sorted now Doomsinger.

After numerous attempts of removing the updates and launcher folders / file and running the repair tool, I was still getting the same error.

I download and installed the x64 client again, tools updated and completed the game update successfully.

Thanks for you assistance today.

Cheers
Grim
Reply Quote
Customer Service
Glad to hear it's working now :)
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]