Client issue? Mage casting sound loop

90 Undead Mage
I sent the following ticket in-game:

On my mage, after casting a few spells, I get a permanent casting noise, which is very annoying. I have tried disabling addons etc, but the noise only goes when I zone in or out of somewhere - only to reappear as soon as I start casting again. Is this a bug?

To which I received the following reply:

Nope sadly it is not a bug but a client issue on your side, addons have corrupted game files on your client causing this, disabling addons will only remove the UI feature of the addon, they will still run and spam the server in the background. You will need to reset your in-game User Interface, to do this please fully exit World of Warcraft and follow the following steps carefully.

Firstly locate three folders in your World of Warcraft installation directory called CACHE, WTF and INTERFACE. Delete these three folders. If you wish to keep a back-up of your Interface settings - copy the Interface folder to the desktop before deleting.

It is important that when re-starting the game after performing these steps that no custom UI changes are made / installed again for the purpose of testing.

For Windows Vista and Windows 7 operating systems a few extra steps are required.

If the UAC/Virtual Store is enabled then the system will also be caching these three folders. Near the navigation bar, please click on the link for Compatibility Files. Once Compatibility Files has been clicked, this will take you to the VirtualStore folder. Please check if there is a World of Warcraft folder, and if so please delete the folders WTF, Cache and Interface from this location as well.

The standard location is the following:
C:\Users\sernameAppData\Local\VirtualStore\Program Files\World of Warcraft\
Substitute sername your windows account username.
Example: C:\Users\JDOE\AppData\Local\VirtualStore\Program Files\World of Warcraft\

If the procedure above does not solve your interface problems, we recommend that you proceed to use the program's Repair Tool. This is located in the game's installation folder. Make sure to run it with 'Reset and Check Files' enabled. This will correct any errors in the game's installation for you.

If you should need further assistance or encounter any issues with this procedure please check out our technical help forum here - - It is a great source of information and a great place to get any further support should you encounter difficulties.

I have deleted Interface/Cache/WTF folders, problem still exists.

I have checked the UAC/Virtual Store folders - nothing there. Problem still exists.

I tried to run the repair tool, which doesnt appear to be there. However, after searching this forum I discovered a thread where the advice from the GM was to delete the WoW.mfil, WoW.pfil and WoW.tfil files and then run the launcher, which would apparently check my game files etc and make sure everything was running properly. Deleted the files as instructed, ran the launcher as instructed - there certainly didn't appear to be any kind of check, WoW just launched as normal, logged into the game as normal, cast a few spells and.. guess what... noise still looping as normal.

I have seen various threads from various frustrated mages (and apparently warlocks too) reporting exactly the same problem - and yet I am told this is not a bug, but a client issue. It has, however, only appeared since the MoP game data was downloaded.

Please would someone confirm firstly whether this is a bug that I can expect a fix for, or a client issue. If the latter, then some idea of how to fix it - excluded the above "solutions" - would be appreciated.
Reply Quote
100 Undead Mage
I just want to report the same issue, which has been going on since the launch of 5.0.5. I am forced to reduce the volume of the effects sound and increase the ones for music and ambience, because it's unbearable to listen to that constant casting sound of arcane blast. And I'm not even arcane specced.
Reply Quote
85 Undead Warlock
I am experiencing the same problem, I never had any addons that would corrupt the files. Have it on both mac and windows (mac being a completely fresh install). So I doubt it's as described above.

Fix this! It's incredibly annoying and seriously hammers your playing experience overall having to either turn off sound or have this constant noise over everything else!!

Reply Quote
Customer Service
Hello there,

Can you try disabling the Death Knight Voices option via the sound options menu, then see what happens?

I know it may seem unrelated, but it should fix it while we work on the issue.
Reply Quote
100 Blood Elf Mage
Disabling the Death Knight Voices fixes the issue only for a few minutes. Actually what fixes is not disabling but rather toggling the option. Actually toggling any sound option that resets the ingame sound fixes it, but only for a while.
Reply Quote
87 Human Mage
Go -> System -> Sound and change the number of channels from low to high and the looping sound ends.

Hope for a real fix soon . I have this bug on a mage its annoying as hell.
Reply Quote
100 Goblin Mage
I'm getting this problem too, the sound of arcane blast on loop can drive a man crazy!
I've tried all the above with no joy, i'm having to play with sound effects off atm.
Reply Quote
100 Undead Mage
Bind '/run Sound_GameSystem_RestartSoundSystem()' to a macro and hit it when it happens again.
Reply Quote
90 Orc Mage
I have no addons. This still occurs. Fix.
Reply Quote
100 Undead Rogue
I've had the same problem for days now. Not with a spell sound looping over and over, but a mantid wing flapping sound, which was driving me crazy (though I could block it out of my mind most of the time).

Doing the disable of dk voices in the sound menu has helped for the moment. I hope it keeps silent now... oh the "blizzful" silence...
Reply Quote
same here

02/10/2012 22:26Posted by Gizel
Bind '/run Sound_GameSystem_RestartSoundSystem()' to a macro and hit it when it happens again.

reminds me of spamming stopsound in cs 1.6 ^^
Reply Quote
Customer Service
Just to re-affirm, this is something that will be fixed with a future update to the client. Restarting the sound system/disabling Death Knight Voices will fix the issue temporarily until the issue occurs again.

This is unrelated to AddOns.
Reply Quote
100 Undead Mage
Y u NO FIX ? :'(
Reply Quote
100 Draenei Mage
Add this as a macro

/click AudioOptionsSoundPanelEnableDSPs

worked for me , when it happens
Reply Quote
100 Undead Mage
i have the same problem guys i hope blizz help us as soon as possible couse is a very noise problem
Reply Quote
100 Troll Mage
So no bug fix this last patch?
Reply Quote
100 Gnome Mage
This sound problem is driving me insane. I've sent in multiple tickets and bug reports and all I get told is that they "can't tell me when it will be fixed because each issue is different". Um. Not good enough. I'm considering switching mains because of this. It gives me a headache and I hate playing with muted sound. Will try the above suggestions, but I'm not getting my hopes up. Really, really annoyed at Blizz for not fixing this sooner. It's a game-wrecker for me.
Reply Quote
88 Gnome Mage
this sound is also driving me insane and getting seriously p****d off with blizz for not fixing! SORT IT OUT!!!!
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Explain (256 characters max)