FPS issus on high-end systems.

90 Human Priest
7195
Hello,

Since the last patch ive went from about 100 fps in crowded city places to about 30 fps in the open world with fpses dropping even further / laggning badly when i enter instances and start to attacking a larger pack of mobs, anyone else got similar issues?
Reply Quote
90 Human Rogue
6495
I havent noticed such drastic drops, but in new zones, that I wouldn't assume were to intensive, I am experiencing 30 - 45 fps. Even with nobody around, and I have a pretty good system. I have had to lower settings from ultra to high/good in some cases.
Reply Quote
90 Draenei Shaman
9760
would like to chime in here. currently running an i5 2500k @ 4.2ghz with a 6950 1gb card, and am struggling for 30fps on the 'good' preset in any MoP area.

tried the usual, delete cache, delete addons, delete WTF folder, update GPU drivers (even tried the 12.9 beta, no change) with a full driver sweeper clean...

at this point i'm up for trying voodoo to get it working smoothly again.
Reply Quote
90 Human Priest
7195
atleast good to know that im not the only one experiencing this, since i just dinged 90 it sucks so bad that instances is lagging so horrible with more then 3 mobs at the same time.. looked abit deeper into the forums and seems alot of people have theese issues
Reply Quote
90 Tauren Shaman
6795
i just dont get it why they dont do anything about it. its like we all totally get ignored and all they say is just delete cache and stuff. and install latest drivers of the graphicscard. give me back the good old days with steady fps!
Reply Quote
83 Tauren Shaman
6100
if you have overclocked processor try to set it back to default
Reply Quote
87 Draenei Warrior
11255
I have the same problem, 30fps? You have still playable game. I have at starting zone in Pandaria about 10 - 20fps. Using i7 3930K and 7970 toxic crossfire (more better hardware you have in this game, then more you are punished)
Edited by Siti on 28/09/2012 08:59 BST
Reply Quote
90 Night Elf Druid
5595
I do also have this FPS problem, i was running 64 bit client but lacks extremely much
thats why i now running 32 bit client and has set the graphics settings from high to good

it do still lacks a little bit, but helped

My System /
Windows 7 64 bit
8 GB DDR3
XFX Radeon 6850 (1GB)
Intel Core i7 2600k 3,4 Ghz
Reply Quote
90 Blood Elf Mage
10765
on character select screen go on add ons and untick the "load out of date add ons" option and you ll be fine
Reply Quote
85 Undead Priest
Raw
7965
I'm having these issues and I didn't enable 'Load out of date addons' to begin with. I'm having a fair 40 FPS in major cities on Ultra, with an i7 2600 and HD6950, but instances are basically unplayable. Pulling even one mob will be noticeable; three or more and I'm tanking blind. I've managed my way through a couple of runs on my paladin, and in a fight like Hoptallus, I'm basically going to have my screen frozen while the adds are up.

At one point I updated Catalyst, got the new application profiles, repaired WoW and deleted Cache. Somehow this worked, but after WoW crashed to desktop once I got the problem back.

EDIT: Is anybody having these problems with an NVIDIA card?
Edited by Clavicule on 28/09/2012 12:42 BST
Reply Quote
90 Draenei Shaman
9760
that's a fair point on the NVIDIA cards. most of the low performance posts i've seen so far have been based on AMD gpus.

i would also like to point out that turning OFF xfire got me to a 'playable' 20 - 30 fps. turning it on made it much MUCH worse. if you're desperate to get into the game setting yourself to windowed or windowed (fullscreen) to kill xfire might be a plan temporarily.
Reply Quote
90 Human Paladin
6355
Got the same isseus with fps while my pc can easely run any game @ wow it has problems
Reply Quote
Customer Service
Hello,

We're investigating issues with poor performance post patch, however we've been unable to confirm any particular causes yet, can you please try the following steps and let us know the results?

If anything is overclocked on your system, please do revert them to standard clock speeds.

If you're on an Nvidia card, try using the previous drivers, we've had some reports of issues with the latest ones.

Also, make sure no other applications are interfering:
http://eu.battle.net/support/en/article/shutting-down-background-applications

Then see what happens?
Reply Quote
90 Blood Elf Rogue
3305
I'm playing with a Saphire HD6870, Intel i7 2500K, .... also FPS issue's in the MoP area (low crowded).
35 FPS on ultra. Never seen this before. :) How is a 40 man raid supposed to look like?
Edited by Daegaran on 28/09/2012 16:49 BST
Reply Quote
90 Tauren Shaman
6795
that doesnt make any difference close start up things.
its like it only is with people with AMD videocards. like yesterday i notice i was running wow on single gpu instead of 2 gpu's (AMD 5870) single has better performance then 2. but still the low fps not like before. hope to hear more about the investigating....
Reply Quote
90 Human Death Knight
8550
I have latest generation PC that is overpowered for WoW and on 50% maps runs smooth 50% not , despite GOOD fps on those areas game is scratching (not running smooth as it should), but i repeat fps is GOOD . It is not smooth when I move and look around in the forest or somewhere. Blizz must do something about this bcs it s annoying when you bought expensive pc equipment and expirience this. (in addition I tried all blue advices + internet solutions and didn t help, I am on Radeon HD 7870 latest driver)
Edited by Argeron on 28/09/2012 18:57 BST
Reply Quote
90 Orc Mage
TnT
7280
Exactly same issue. Nothing overclocked, no out-of-date Addons, no Background Apps, latest Drivers. Using AMD 6850. And was fine in Cata.
Reply Quote
90 Tauren Shaman
6795
ill try to mess with the settings in wow and in the catalyst drivers hope to find a solution otherwise the game isnt just optimized for AMD videocards. or in the worst case step to NVIDIA
Reply Quote
90 Undead Rogue
8655
Also getting the same problem. Sometimes I get a consistent 75+ fps when I'm on my own somewhere but as soon as I drag my mouse really fast it spikes and when I pull mobs it spikes again!

I don't think I've updated my nVidia driver since the launch.

Will keep checking this thread for an answer, god's speed!
Reply Quote
90 Troll Mage
10500
Exactly the same problem here, game is almost unplayable.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]