Battle.net Error #2

i was in BG farming honor and got kicked outta game,then when i wanted to log in again i got this error,
screen shot says it all :

http://www.ephotobay.com/image/wowscrnshot-112912-174712.jpg

so what's this?
Reply Quote
MVP
100 Human Death Knight
10840
Please try power cycling your connection;
https://eu.battle.net/support/en/article/7300082

If that doesn't resolve the issue, can I ask what security software is installed?
Reply Quote
90 Orc Death Knight
0
wanted to log in 2 mins ago, got the same message.
Disabled and enabled my wireless adapter and i was back in the game.
Got disconnected after 3 mins of playing, and same message.
Stormscale EU.
Edited by Kangars on 29/11/2012 14:37 GMT
Reply Quote
90 Human Paladin
8180
I'm also getting this issue. I use Norton Internet Security.
Reply Quote
100 Undead Priest
8305
Getting this aswell, all other internet related stuff works fine except wow
Reply Quote
90 Orc Warlock
7445
mee to
Reply Quote
90 Human Paladin
8180
I managed to log in after a while, then I got d/ced. Now when I try to log back into the game, I'm getting "Character Not Found" messages.

Edit: Managed to log in just fine on a different server, but having this issue on Defias Brotherhood.
Edited by Farelin on 29/11/2012 14:59 GMT
Reply Quote
90 Tauren Druid
8185
m2
Reply Quote
i'm using kaspersky,disabled it and i still get same message,
like all have said,i got in-game as well but then again same issue,now when i get in character selection screen and chose one it stucks on 90% and says "character not found" ,all of the characters get same message.
Edited by Rabbît on 29/11/2012 15:05 GMT
Reply Quote
90 Blood Elf Paladin
0
This is no antivir or firewall.
Battelnet serv - crasch - Blizz plis fix it.
Reply Quote
90 Blood Elf Paladin
11915
Same here, was playing just fine. Then disconnected, tried to log in and BOOM Battle.net Error 2. Tried everything in suggested thread. All other internetservices such as games, music,movie streaming etc. works fine. The only thing not working is WoW.
Reply Quote
100 Human Warlock
18115
I have the same problem! Tried other battle.net games like d3 and sc2 and both works fine!
Reply Quote
90 Pandaren Monk
7165
Have the exact same problem. Everything was working fine until approx 1 hour ago then dced and know everytime I succeed in logging in I get disconnected after a couple of minutes and get the battlenet error #2.
I've never had any problems like this with wow before. I've checked firewalls and other things that might obscure the connecting. But I can conclude that it has nothing to do with my computer, something is wrong with battlenet.
Reply Quote
90 Pandaren Shaman
8035
Same issue, can't login.
Reply Quote
any clue from blue posters why is this happening? still can't log in
Reply Quote
90 Troll Druid
9705
Get this message on one of my accounts but on the other account I get in instantly :S
and after logging in and out a few times from the account that works, it finaly lets me to get into the account that originaly got Error #2 :S

Edit : Sometimes it lets me get to "choose realm" but gets stuck there for a couple of minutes before booting me, then I can try again and it useually works... so I realy have no clue what the real problem is :S

Edit #2 : This have happened since the patch yesterday, and when I do finaly get in, every character I try to login to gets the message "Character not found" at the end of loading screen
Edited by Nénn on 29/11/2012 15:46 GMT
Reply Quote
70 Undead Rogue
0
same here tried to make panda warrior got disconnected. error#2 nice... ill try again tomorrow
Reply Quote
Customer Service
Hello,

In addition to restarting your router, can you flush your DNS cache?

Power off your modem/router for 5 minutes, turn it back on and then perform this command.

Windows XP:
- Click Start and then Run
- Type cmd in the run box and click Ok
- In the Command Console window that has appeared type: ipconfig /flushdns
- After typing the above command, press Enter to execute it and then close the window

Windows Vista / 7:
- Click Start, then Programs, then Accessories and then locate 'Command Prompt'
- Right-click on 'Command Prompt' and left-click on 'Run as Administrator'
- In the Command Console window that has appeared type: ipconfig /flushdns
- After typing the above command, press Enter to execute it and then close the window

Mac /OS X:
https://eu.battle.net/support/en/article/ip-release-renew-and-flush-dns-mac

Also if that doesn't work, try a Selective Startup:
http://eu.battle.net/support/en/article/shutting-down-background-applications
Reply Quote
90 Human Priest
7310
got same problem. worked fine yesterday so don't know what happened while i was getting my beauty sleep. anyway, just done that command prompt thing and now can't get passed the blizzard launcher so kinda made it worse. thx blizz
Reply Quote
90 Human Priest
7310
i finally managed to get passed blizzard launcher but still says character not found after trying to get into the game for 5 mins. read in some other post a blizz employee saying its to do with out of date addons so disabled them all but that didn't help either. pls try and do something about this, i've given up for the night now.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]