libcef.dll missing

(Locked)

And now its even worse, i cant play for more than 30 seconds without the game just shutting down. No error, nothing, its just as if i had pressed alt+f4. Tried repairing an additional time, but the repair isnt even installing the utility folder i previously deleted, as well as recieving no error about missing libcef.dll in-game.) :(
90 Human Paladin
16095
And now its even worse, i cant play for more than 30 seconds without the game just shutting down. No error, nothing, its just as if i had pressed alt+f4. Tried repairing an additional time, but the repair isnt even installing the utility folder i previously deleted, as well as recieving no error about missing libcef.dll in-game.) :(

If you remove files like wow.exe, wow-64.exe, the launcher will download them on start together with the Utils folder. Note that the error will occur again so leaving the Utils folder deleted is the only thing you can do at this given moment.

Now my point of view:
The problem is the following: there should be a file called libcef.dll in the Utils folder together with the WowBrowserProxy.exe. I only assume this is the problem since I wasn't able to fix it myself but I have done a test.

I created a blank text document and named it libcef.dll. After starting wow I got an error the application crashed so it did recognize the file but since it wasn't the right one, it crashed.

My brother has a working client on his computer. I'll check his in the morning and see if I can get it fixed.

Beside finding a solution I have other ingame things showing up like a GM reply popup. When I click it I go to the help page but nothings there. When I close the window the popup is there again. I have no open tickets on the battle.net site so it's strange.
Edited by Krowi on 18/06/2013 00:42 BST
90 Human Paladin
16095
K, first of all sorry for the double post but I want to keep this a little clean.

This is what I learned:
On my computer (Windows 8) there is only a file named WowBrowserProxy.exe in my Utils folder. On my brothers computer there is not only WowBrowserProxy.exe in the folder but also libcef.dll, icudt.dll and a folder locales with what I assume are language files.

To verify which solution works for me I'm going to do this step by step.

Step 1: Utils folder with only WowBrowserProxy.exe in it
K, this is what most people will find in C:\Program Files (x86)\World of Warcraft\Utils if they're getting the error stated in the topic title. The error message I get is the following: http://i1054.photobucket.com/albums/s485/KFredje/Error1_zps847fa6c3.png (too bad no images are allowed here or active links) This is mainly what people get with the 5.3 client if there's something wrong.

Step 2: Adding libcef.dll to the Utils folder
Now I don't get the previous error but the following: http://i1054.photobucket.com/albums/s485/KFredje/Error2_zps3b566248.png and after a second or 2 this one http://i1054.photobucket.com/albums/s485/KFredje/Error3_zps7e6b9a3a.png. So libcef.dll appears to fix something but not everything.

Step 3: Adding icudt.dll to the Utils folder
Again another error: http://i1054.photobucket.com/albums/s485/KFredje/Error4_zpsadb85df1.png so it does appear to fix the previous error but another one shows up.

Step 4: Adding locales folder to the Utils folder
Success! No more error messages and the support in-game website is working.

So it appears there are some lost files on some clients who need to be added in a future fix. For now (I'm not sure if I'm allowed to do this but if not, please tell me as fast as possible) I will link to my files to get this bug fixed: <snip>. These files are not altered in any way to try to hack people. They are genuine Blizzard files copied and rarred from my brothers computer, tested on mt computer and shared to help people fix their problems. I hope this does what it did for me.

GM's, feel free to contact me in-game if there's something you need from me.

Rate this post if it helped you so people will find it more easily.
Edited by Tiogaradh on 18/06/2013 11:48 BST
100 Goblin Shaman
Hex
16465
I got this error and the util folder only had the exe in it like described by another user. however, my game doesn't produce a launcher after this error appeared the first time eek. this is a completely fresh install btw, only just finished half an hour ago after dl'ing for 23hours.
90 Human Paladin
16095
It's a problem only the exe is in the Util folder without any other files. Repair tool and removing the Util folder won't solve the problem. Get the rar from <snip> and place the files in the Util folder and it should work
Edited by Tiogaradh on 18/06/2013 11:47 BST
Customer Service
Krowi, I've removed the link to the file from your post, while i don't believe there is anything malicious about it linking to files isn't really allowed. Running the repair tool should download the missing file.
Edited by Tiogaradh on 18/06/2013 11:50 BST
Yes, Tiogaradh, it should no doubt download the missing file. Problem is though, it doesnt. Not after 3 "successful" repairs, with no errors.

Myself, i'm not even sure is the problem is related or not but whenever i change video settings from fullscreen to Windowed (Fullscreen) the game crashes within seconds. It is weird.
97 Pandaren Rogue
9640
I am experiencing the same thing as Shrude,(part from the crashing thing) i get the libcef.dll missing error.
Then running the repairtool, but the same thing keep happening again
Any ideas how to sort this once and for all?
90 Human Warrior
5080
same problem here and repair does not fix it. I can play the game however so not too much of an issue for me.
90 Human Paladin
16095
Krowi, I've removed the link to the file from your post, while i don't believe there is anything malicious about it linking to files isn't really allowed. Running the repair tool should download the missing file.
Well, too bad for the people who have the problem and can't get it fixed cause like other people said, the launcher doesn't download the missing files.

For people who want my files, go to http://www.wowhead.com/forums?board=16 (this link is allowed I guess) and look for a topic called Libcef.dll missing error [Solution I share for people who are looking for a fix for this error]. There you find what you need (guide written by me).

So I think I'm not doing anything wrong referring to wowhead which has a solution?

PS. @Tiogaradh: I'm not questioning the forum rules but where could I find something about linking to files? I looked in the Technical Support and overall forum rules but I haven't found anything concerning this. And is linking to something on wowhead with the same goal also a violation? I just want to be sure what I can and not do in the future if I want to help people out.
Edited by Krowi on 18/06/2013 23:42 BST
95 Blood Elf Paladin
3805
delete wtf cash and interface fixed!
90 Orc Warrior
12915
I have reinstall my Computer , Fress new , and I got the same trouble,
90 Blood Elf Priest
8930
Blizzard... Please hire Krowi for future tech support.
90 Orc Warrior
12915
This error "libcef.dll is missing

-
I've had a look into this for you and it appears this does have an issue due to the client, even after a new install have a corrupted file. What you need to do is just go into your WoW directory and delete the folder callled "Utils" and then just restart the client and you should then finally be able to log in and play without any further issues
-

he do not say ' that your computer can crash or can be go on sleep mode,
and to get back on windows you need to reset your computer.

Becare!
Edited by Moonraiser on 19/06/2013 21:38 BST
90 Worgen Druid
13450
@Krowi

Much <3 and xox, someone that /moons at Blizz and resolves a stupid mistake on their part.
Finally able to get rid of that darn GM notice in the top corner of my screen, its been there for days!

~Mel~
90 Pandaren Monk
3155
So... I deleted the file and did the repair and now I think there is no problem. But I can't seem it find the file I deleted is this a problem or just nothing?
Customer Service
The Utils folder is currently not being downloaded after removal, which fixes the libcef.dll file error, but unfortunately has the side effect of reverting the in-game browser to the older style.

This will be addressed with an update to the game, but we don't have further details on that just yet.
90 Blood Elf Paladin
4295
hey

i have olso the same problem.

i have a laptop new with windows8 there is the problem on.

and i have a pc with windows 7 and that works perfect.

now my question:

I want to try removing the file on my laptop, but when I do, I also remove the file on my PC where everything is going well?

greetzz
25 Human Warrior
90
Delete the folder and it's worked thanks :D
This thread is locked.

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]