D3 konnte D3D nicht Initialisieren

Technischer Kundendienst
Das zurücksetzen der Direct-3D Einstellungen des Nividia Grafiktreibers brachte die Lösung. Nun geht auch der x64 Client wieder. Der 32 Bit Client lief die ganze Zeit. Muss aber sagen, dass ich in diesen Einstellungen nichts verändert hatte. Vielen Dank!
Also ich habe nur einen Onboard Intel Chip (4200) in meinem Tablet.
Bekomme den Fehler auch alle Nase lang.
Ja volle das mit Battle net aktivieren und Einstellungen zurücksetzten is Perfekt bei readom es funkt wieder. Kein Stand Bild mehr : Ich liebe es wieder und keine Probleme jehhhhhhhhhhhhh mfg euer Butcher
Hallo zusammen, hier mal was ganz anderes,
Diablo III läuft super, bis ich Skype benutzen will, dann kommt der bekannte D3D Fehler.
Hab ihr da eine Idee.
Hallo Michael28260.

Es wäre besser gewesen, wenn du einen neuen Beitrag erstellt hättest, statt einen themenfremden Thread zu "übernehmen", aber so ist es nun mal geschehen.

Sehr wahrscheinlich liegt das Problem daran, dass Skype ein Overlay erzeugen will und sich dies mit Diablo III "beißt". Beende entweder Skype oder schau, dass du die entsprechende Einstellung deaktivierst. Es sollte die Option sein, welche dafür sorgt, dass du ein Pop-up von Skype bekommst, falls du einen Anruf oder eine Chatnachricht erhältst.

Bessert es sich dann?

Gruß
–––––––––
Feedback zu meinem Beitrag kann in dieser kurzen Umfrage angebracht werden.
Juten tag folgendes gleiches problem wenn spielstart switch der bildschirm zu nem weissen bildschirm und läd sollange bis ich die win taste drücke um den vorgang zu beenden. habe win10 (d3 läuft über win7 einstellungen) intel hd deaktiviert niviada geforce 840m zurückgesetzt und anderes rum alle einstellung im battle.net zückgesetzt un es auch inner 32er bit version versucht. prozessor ist ein intel i 5-5200u drin 8gb arbeitspeicher und 1tbspeicher. vor dem 2.5 update lief alles ohne probleme
Überprüfe zunächst mal, ob den Grafiktreiber in deinem System und aktuallisiere ihn ggf.:
https://eu.battle.net/support/de/article/200576

Evtl. reicht es auch schon, wenn man die Einstellungen des Grafiktreibers zurücksetzt:
https://eu.battle.net/support/de/article/6672

Darüberhinaus kannst du auch mal einen Blick in diese Supportartikel werfen:
https://eu.battle.net/support/de/article/464
https://eu.battle.net/support/de/article/6300064
Hallo DeBarbar.
28.03.2017 17:19Beitrag von DeBarbar
habe win10 (d3 läuft über win7 einstellungen)
Ich nehme an, dass du damit den Kompatibilitätsmodus meinst. Bitte deaktiviere diesen wieder, falls die von TollCollect vorgeschlagenen Schritte keine Abhilfe bringen.

Gruß
–––––––––
Feedback zu meinem Beitrag kann in dieser kurzen Umfrage angebracht werden.
Hallo,
ich habe ebenfalls dieses Problem. Heute Vormittag lief es noch einwandfrei und heute Abend auf einmal das D3D Problem. Habe alles hier beschriebene ausprobiert und sogar eine Neuinstallation des Spiels vorgenommen.
Nichts hat geholfen. Ich verzweifel hier grad.
Scheinbar ist das ein NVIDIA Geforce Problem. Zufinden in den Voreinstellungen/Optimierungen für Spiele. NVIDIA Geforce Experience öffnen, bei Diablo3 auf Details gehen und Multisampling rausnehmen. 2. Vergleiche die Auflösung der NVIDIA Optimierung mit der eingestellten Auflösung in den Diablo3 Optionen. D3D Problem liegt an der NVIDIA Game Optimierung - Habe das Problem auch gehabt und durch einen GamingFachmann im Fachgeschäft beheben lassen (In China!)

Liebe Grüße aus dem Reich der Mitte
Hallo.

Wir hätten gern etwas mehr Einblick in eure Systeme. Bitte erstellt eine MsInfo.txt deines Computers. Lade die Datei dann bei einem File Hoster hoch (z. B. Dropbox oder Pastebin) und verlinke sie in deiner Antwort. Es ist auch möglich, die Daten über ein OneDrive- oder Google Drive-Konto freizugeben.

Gruß
–––––––––
Feedback zu meinem Beitrag kann in dieser kurzen Umfrage angebracht werden.
Seit dem letzten NVIDIA GeForce Experience Update trat bei mir ebenfalls dieses Problem auf.
Abhilfe konnte ich schaffen, indem ich bei GeForce Experience den Regler für "Spielinternes Overlay" ausgeschaltet habe. Damit funktioniert die 64-Bit Version auch wieder.
Hallo Hade.

Danke für deine Anmerkung! :)

Wir empfehlen generell, dass Overlays (sofern vorhanden) ausgeschaltet werden sollten, wenn es Leistungs- oder Stabilitätsprobleme geben sollte. Aus diesem Grunde haben wir hier auch einen gesonderten Artikel mit einigen Beispielen eingepflegt.

Gruß
–––––––––
Feedback zu meinem Beitrag kann in dieser kurzen Umfrage angebracht werden.
Bei mir trat dieses Problem der nicht möglichen D3D-Initialisierung samt Fehlermeldung ebenfalls und vor allem plötzlich im Zusammenhang mit dem Windows 10 Creators Update auf (Lösung siehe unten).

Ich spiele D3 seit jeher über Nvidia DSR und hatte nie Probleme mit irgendetwas in Bezug auf die Grafik oder Auflösung.

Nach dem Windows 10 Creators Update konnte ich plötzlich D3 (und auch andere Spiele) nicht mehr starten, da nach dem Starten des Clients und damit dem Laden des Spiels diese Fehlermeldung kam und das Laden der grafischen Oberfläche verhinderte.

Dies lag daran, dass das Creators Update augenscheinlich die Einstellungen in der Nvidia Systemsteuerung überschreibt, ohne dies irgendwie kenntlich zu machen oder anzuzeigen.

Dies ging sogar soweit, dass DSR bei mir selbst im Benchmark-Tool Furmark nicht mehr funktionierte, obwohl es auch nach dem Creators Update in der Nvidia Systemsteuerung noch ausdrücklich aktiviert war.

Zur Lösung dieses Problems muss man die entsprechenden Einstellungen in der Nvidia Systemsteuerung verändern (egal in welche Richtung, Hauptsache sie sind anders, damit man ein Speichern erzwingen kann) und diese speichern. Danach stellt man wieder seine ursprünglichen Einstellungen ein, speichert diese und startet den Rechner sicherheitshalber neu, danach funktioniert DSR wieder.
Hallo Demian.

04.08.2017 15:10Beitrag von Demian
Dies lag daran, dass das Creators Update augenscheinlich die Einstellungen in der Nvidia Systemsteuerung überschreibt, ohne dies irgendwie kenntlich zu machen oder anzuzeigen.
Ich habe in der Vergangenheit die Erfahrung gemacht, dass Windows bei Updates manchmal selbstständig Treiberversionen zu ersetzen scheint. Vielleicht ist das auch hier der Fall gewesen. Hast du zufällig darauf geachtet, ob die Treiber dieselben wie vor dem Windows-Update waren?

Gruß
–––––––––
Feedback zu meinem Beitrag kann in dieser kurzen Umfrage angebracht werden.
Hallo Leute ich habe seit heute den selben Fehler 3D3 kann nicht instaliert werden

Habe Treiber neu instaliert sowie das spiel

habe sämtliche hier sämliche vorgeschlagene Lösungen probiert

Zu meim System

Win 10
32 Gb RAM
intel 7700 k 4,2 ghz
2 Gtx 1080
Hallo Flinkerbär.

Starte bitte zunächst deinen Rechner einfach neu. So stellen wir sicher, dass geplante Änderungen am System tatsächlich umgesetzt werden. Grund für diese Maßnahme ist, dass Windows 10 (in der Standardeinstellung) beim normalen Herunterfahren nicht wirklich herunterfährt, sondern die aktuelle Sitzung abspeichert. Dies beschleunigt den nächsten Start des Systems. Das ist praktisch, kann aber in manchen Fällen zu Problemen führen.

Sollte das nicht helfen, starte den Rechner nochmals neu, lösche dann den Inhalt des Battle.net-Cache-Ordners, starte die Blizzard Battle.net Desktop App und setze sie Benutzereinstellungen von Diablo III zurück.

Klappt es auch dann noch nicht, erstelle bitte eine MsInfo.txt deines Computers. Lade die Datei dann bei einem File Hoster hoch (z. B. Dropbox oder Pastebin) und verlinke sie in deiner Antwort. Es ist auch möglich, die Daten über ein OneDrive- oder Google Drive-Konto freizugeben.

Gruß
–––––––––
Feedback zu meinem Beitrag kann in dieser kurzen Umfrage angebracht werden.
Hallo Allerseits!

Ich habe seit dem Neuaufsetzen meines Notebooks vor ca. 1 Monat auch das hier geschilderte Problem:
Kurz nach dem Start der 64bit-Version von Diablo 3 kommt die Fehlermeldung, dass D3D nicht initialisiert werden konnte.

Alle hier vorgeschlagenen Lösungen (Grafikkartentreiber neuinstallieren, Grafikkarteneinstellungen neu- oder zurücksetzen, Battle.net-Client-Cache löschen, Diablo 3-Einstellungen zurücksetzen, Entfernung von Programmen mit Overlay) habe ich schon versucht.

Der Fehler tritt aber immer noch auf!

Ich hoffe mir kann jemand helfen!

Unter dem Link
https://c.gmx.net/@324465223438172352/OXjZxFcUQjWwvYQI6hU4DQ
sind diese Dateien herunterladbar:
- "diablo 3 - 20171203_1131 - Fehler - d3d nicht initialisierbar.png" (Screenshot des Fehlers)
- D3Debug-32bit-ok-20171203_1138.txt (Diablo 3-Debug-Log 32bit ohne d3d-init-Fehler)
- D3Debug-64bit-d3d_init_error-20171203_1135.txt (Diablo 3-Debug-Log 64-bit mit d3d-init-Fehler)
- msinfo-20171203_1127.txt (Systeminformation erstellt mit msinfo32)
- DxDiag-20171203_1126.txt (DirectX-Information erstellt mit dxdiag)

Kleine Randnotiz, die vielleicht helfen kann:
Bei Starcraft II (64bit) habe ich das Problem nicht.

Grüße!
Hallo DawnStealer.

Öffne bitte mal die NVIDIA-Systemsteuerung und darin die 3D-Optionen. Lege dort bitte in den globalen Einstellungen fest, dass die Darstellung ausschließlich über den NVIDIA-Hochleistungsprozessor erfolgen soll. Überprüfe bitte im Reiter rechts daneben, ob ein Profil für Diablo III besteht. Falls ja, lege dort fest, dass es sich in allen Settings (in denen die Option angeboten wird) der globalen Einstellungen orientieren soll.

Gruß
–––––––––
Feedback zu meinem Beitrag kann in dieser kurzen Umfrage angebracht werden.
Hi Scrainzo!

Danke für den Tipp!
Er hat leider nicht zum Erfolg geführt! :-(

Ich versuche jetzt einige Grafikkartentreiberversionen durch.
Vielleicht ist eine dabei, bei der der 64-Bit-Client wieder funktioniert.

Grüße!

Nimm an der Unterhaltung teil!

Zurück zum Forum