[HowTo] World of Warcraft unter Ubuntu / Linux Mint

Technischer Support
Zurück 1 31 32 33 45 Weiter
@Alle wine-staging Nutzer,

mit dem neuen wine-staging-2.19 funktioniert das Rendern der HTML Inhalte des Battle.net Clienten wieder fehlerfrei. Ihr könnt in der winecfg die Windows Version wieder auf Windows 7 setzen.

Gruß
Neralix
Nein mir läuft es unter Linux Mint 18.2 mit Cinnamon. Nach vielen Anläufen funktioniert nur dieser Weg bei mir: playonlinux installieren und den Client von Wow runterladen. In Playonlinux die Wineversion 2.16 stages installieren. Danach auf Programm installieren, auf nicht aufgeführtes Programm installieren klicken.
Dann 32 Bit Version installieren und auswählen das man die Wineversion wechseln möchte und auf Wine konfigurieren. Wenn man dann in den Wine Einstellungen ist unten auf Windows 10 einstellen und die höchste direktx9 Version hinzufügen und nur das, nichts anderes. ( mit Direct x 10 / 11 noch nicht probiert). Danach den Installer von WoW auswählen und installieren. Funktioniert mit Authenticator und genauso gut wie unter normal Windows. Hoffe es klappt bei euch genauso gut.

MfG
Hi an alle.
Bin noch recht neu mit Linux unterwegs, habe es aber nach gefühlt unendlich viel verschiedenen Tipps und Wegen geschafft, genau so ins Spiel gekommen (ich zitiere Bedauerich):

Mit der neuen wine-2.16 (Staging) läuft WoW bei mir wieder ganz normal unter 64 bit. Es lässt sich nun auch wieder ohne den Launcher starten, sonder direkt übers Terminal mit der Wow-64.exe oder wie bei mir per shell-skript,


Nun, nach dem der Battlenet Launcher geupdated wurde, werden mir alle Realms als inkompatibel angezeigt, was bedeutet, dass ich den Client aktualisieren muss.
Da ich aber nur über die oben zitierte Wow-64.exe reinkomme, also quasi den Launcher überspringe, kriege ich den nicht aktualisiert.
Hat da jemand einen Tipp wie das machbar ist?
Irgendwie übersehe ich da etwas...
Hallo allerseits,

heute ist die Version 1.1.1 des Milhaus-AddOn-Updaters erschienen.

Milhaus-AddOn-Updater ist eine grafische Applikation, programmiert mit Lazarus und freepascal, zum komfortablen Installieren, updaten und verwalten der AddOns für World of Warcraft.

Änderungen:
-----------
- Support für www.CurseForge.com
- AddOns können nun vom Systray-Icon aus aktualisiert werden
- AddOn-Liste kann nun nach Namensbestandteilen gefiltert werden
- Fix: Starten des Battle.Net Clienten bei nicht Standard Installationen
- Migration von curse.com auf curseforge.com

Wichtiger Hinweis:
---------------------
Da www.CurseForge.com mittlerweile den Netzwerkverkehr über https erzwingt, müssen unter Linux die Libraries: libopenssl und libcrypto installiert sein.


Bitte installiert über die Paketverwaltung Eurer Linux-Distribution das unten genannte Paket und lasst die "vorgeschlagenen Pakete" ebenfalls mit installieren:

Debian/Ubuntu: libssl-dev
Fedora/CentOS: openssl-devel
openSUSE: libopenssl-devel

Downloads:
Linux64: https://drive.google.com/open?id=1xjxm824X_jDDz1uFgMP2gN3IpKx-ZlXy
Linux32: https://drive.google.com/open?id=1S_dwqKXhX2XxMl_8LoWQd6eT4ZRvlg7q
Win64: https://drive.google.com/open?id=1z5P4lKSzPUJNpXCcIdNWfiYQ5wxruezx
Win32: https://drive.google.com/open?id=19cNRjqAELOlZl0BjBku-FHEL7mvFH31g

MD5-Summen:
552cf1fb0e7d6b4415959bf13d590a25 Milhaus-1.1.1_Win32-Setup.exe
226bc6a26771c90444d3b965bcbb9eac Milhaus-1.1.1_Win64-Setup.exe
dfb081bc065f8f28200d63b10e1f0c57 milhaus-1.1.1_x86_64_installer.run
88a074639b1eb0598dc3f1eaf5aee756 milhaus-1.1.1_x86_installer.run

Ladet euch bitte, den für euer Betriebssystem(32 oder 64 Bit) passenden Installer herunter.

Für die Installation unter Windows sind für das Ausführen der Setup-Datei einmalig Administratorrechte notwendig. Eine eventuelle Deinstallation geschieht wie üblich über die Systemsteuerung.

Linux Benutzer kopieren die *.run-Datei in ihr Heimat- oder Downloadverzeichnis und machen diese mit chmod 755 <Name der run-Datei> ausführbar. Diese muss nun einmalig in einer Konsole gestartet werden. Hier wird eine Deinstalltion durch das erneute Starten der *.run-Datei ausgeführt.

Zum Starten von Milhaus-AddOn-Updater verwendet Ihr bitte das Icon auf eurem Desktop oder den Eintrag im Startmenü.

Das Programm kann keine bereits installierten AddOns erkennen, ihr müsst die URL's aller installieren AddOns in das Programm einfügen, die bereits vorhanden AddOn müsst Ihr nicht extra aus dem Interface Ordner löschen. An den Einstellungen eurer AddOns werden keine Änderungen vorgenommen. Nachdem Ihr alle URL's eingetragen habt, einfach einmal auf den Button "Automatik" drücken. Unter dem Menüpunkt Hilfe gibt es auch eine FAQ, Anleitung und Kurzanleitung.

Momentan wird als Anbieter www.curseforge.com und wowinterface.com unterstützt.

Ich verbürge mich bei den oben gehashten binaries dafür, dass die Programme keine Werbung, Schadsoftware oder sonstigen Dreck installieren. Des weiteren werden auch keinerlei Daten abgegriffen(sofern die Prüfsummen übereinstimmen, es sich also um die Originalinstallationsdateien handelt).

Das Programm steht unter der GNU GENERAL PUBLIC LICENSE Version 3, ein Source-Code ist verfügbar(siehe: readme-sourcecode).

Viele Fragen werden in der FAQ beantwortet!

Bitte hier keine großartigen Supportanfragen o. ä., schreibt mir statt dessen bitte eine E-Mail an: Milhaus@ist-einmalig.de

Gruß
Neralix
@Hyaena

Das ist eigentlich gar kein Problem. Du musst so gesehen nur den Launcher starten, um WoW zu aktuallisieren. Dafür öffne am besten ein Terminal und navigiere mit folgendem Befehl in den WoW-Ordner:

cd ".wine/drive_c/Program Files (x86)/World of Warcraft"

Danach gibst du dann folgenden Befehl ein um den Lauchner zu starten:

wine World\ of\ Warcraft\ Launcher.exe


Viel Spaß!
@ Bedauerich

Erstmal Danke für die Antwort.
Leider funktioniert das genauso wenig, wie den Launcher über die Shell zu öffnen.
Ich habe jetzt über PlayonLinux einen neuen Ordner gemacht und das ganze Spiel neu raufgepackt, mit der Installationsdatei des Launchers wird ja alles gleich aktualisiert.
Aber das bedeutet auch, das Spiel komplett neu runterzuladen.
Mühselig, aber zumindest läuft es wieder.
Bis zum nächsten mal ....

Wenn wer noch einen anderen Tipp hat?
Leider hab ich rausgefunden das nicht so vielle Leute hier uber Lutris wissen und WoW nur direkt durch wine oder PlayOnLinux installieren.
Lutris hat auch ein eintrag fur WoW (https://lutris.net/games/world-of-warcraft/) auch mit einer schoner beschreibung.

@Hyaena: Du must ja nur battle net installieren.. und dann solltest du in battle net dem Ordner wo du WoW installiert hast einstellen (oder neu installieren). Naturlich muss der ortner Read/Write Rechte haben.

(fyi, sorry for all grammar errors - i am not from germany)
@Nusuey:
Der "Battle.net"-Ordner mit der Battle.net-Exe steht bei mir neben dem "World of Warcraft"-Ordner im "Program Files (x86)".
Habe ich dich jetzt richtig verstanden, ich soll den "World of Warcraft"-Ordner in den "Battle.net"-Ordner hineinstellen?

Aktuell habe ich nämlich genau wieder das gleiche Problem.
@Hyaena

Welche Fehlermeldung wird denn ausgegeben, wenn du versucht den Launcher wie oben beschrieben im Terminal zu starten?
@Bedauerich

nach der ersten EIngabe schon erscheint:

bash: cd: .wine/drive_c/Program Files (x86)/World of Warcraft: Datei oder Verzeichnis nicht gefunden


Allerdings, habe ich auch keinerlei Ordner der sich wine nennt.
Der drive_c ist bei mir im /home/******/PlayOnLinux's virtual drives/wowlegion/ .
Sterne stehen für meinen Namen.
Zumindest ist das der Pfad dem ich folge um die Shell zu öffnen.
21.11.2017 18:42Beitrag von Hyaena
@Bedauerich

nach der ersten EIngabe schon erscheint:

[quote]bash: cd: .wine/drive_c/Program Files (x86)/World of Warcraft: Datei oder Verzeichnis nicht gefunden


Also etwas Stimmt bei der aussage nicht und zwar der cd: das gibt es ja nicht als befehl vlt liegt es daran ... und World of Warcraft kann der terminal nicht finden wegen die leer Taste.

ich bin nicht der fan von playonlinux ich mach sowas wen eher mit winetricks ...
aber die frage ist was bei dir auf deinem Dekstop für eine wine wow starter liegt .. die von playonlinux oder eine andere ? denn nach deinem pfad her greift er auf das .wine <- wine und nicht auf das vom .playonlinux (playonlinux).
@Hyaena: Du musst Leerzeichen in Pfaden escapen, also ein \ vor jedes Leerzeichen packen. ~/.wine (~ ersetzt /home/<angemeldeter User>) hast du definitiv, du siehst den Ordner nur nicht, weil ein . davor ist, damit ist er versteckt. Versuche bei der Eingabe von Shell-Befehlen Pfade zu Dateien und Ordnern mit Tab vervollständigen zu lassen. Tippe beispielsweise so: wine ~/.wine/Pro<jetzt die Tabtaste>. Dann sollte er dir "Program Files/" und "Program Files (x86)/" anbieten. Dann drückst du \ um das Leerzeichen vor (x86) zu escapen. Dann macht er automatisch "~/.wine/drive_c/Program\ Files\ \(x86\)/" draus.
So.
Erst einmal ein Megadanke an alle die sich die Mühe gemacht haben, mir bei meiner Problematik zu helfen.
Ich habe auf jeden Fall wieder ein bisschen mehr gelernt.

Nachdem ich es zur Abwechslung mal mit Lutris probiert habe und auch da nicht weit gekommen bin, habe ich alles runtergeschmissen und von ganz von vorne angefangen. (Deshalb konnte ich das mit Aufruf übers Terminal unter Berücksichtigung der Tipps von Puppyflips nicht ausprobieren, aber die Info war für mich als Linux-Neuling sehr kostbar)

Diesesmal habe ich weder PlayonLinux noch Lutris installiert, sondern lediglich die aktuellste Wine-Version.
Die aktuelle Battle.net-exe habe ich dann ganz einfach per Rechtsklick über Wine gestartet. Fertig.
Und es funktionierte, alles hat sich problemlos installieren lassen. Alles ohne gefühlte zig Extraeinstellungen und Auswahlen.
Für etwaige Feineinstellungen habe ich mir noch winetricks dazugepackt, aber noch nichts daran gedreht.
Ich kann jetzt easy per Desktop-Icon den Battle.net-Launcher starten und endlich so ins Spiel kommen. Ohne umständlich eine Shell zu öffnen.

Gestern abend hat es auf den verheerten Inseln noch etwas "gestottert", in Kalimdor lief alles flüssig. Wenn ich das "Stottern" und die Unterbrechungen in der Musik jetzt noch wegkriege, scheint alles einwandfrei zu laufen.
Aber jetzt ist es schon viel besser als bisher.
Danke Euch nochmal !
Da Wine vermutlich bei dir mit pulseaudio läuft: siehe
https://wiki.winehq.org/Sound
Abschnitt "PulseAudio"
Den Grund haben die Wine-Entwickler hier wine schon angeführt, dass es über die Latency Settings zu Problemen kommen kann.
Generell kann mit über die pulse configs seine Sound Einstellungen verbessern/anpassen (oder verschlimmern als Neuling).

Da sich der Vorschlag der Entwickler global auf dein Linux auswirkt würde ich eher den weniger globalen weg gehen und beim starten von wow einfach die env variable
export PULSE_LATENCY_MSEC=60 vorher setzen.
Wobei du dann über trial-and-error ausprobieren musst bei welchem integer Wert hier dein Sound nicht mehr stottert.

Wenn du den Wert gefunden hast kannst du einen alias erstellen für wine.
alias wine='PULSE_LATENCY_MSEC=xx wine'
Wenn man den Pfad beim change directory-Befehl in Anführungszeichen setzt, dann kann man die Leerzeichen im Pfad durchaus setzen - so wie ich das oben auch beschrieben habe:

cd ".wine/drive_c/Program Files (x86)/World of Warcraft"

Diese Methode ist wesentlich praktischer und übersichtlicher als die mit den Backslashes. Probiert es ruhig mal aus.

VG, Bedauerich
Hallo an alle, ich installiere gerade über PlayOnLinux WOW, seid ca 15min versuche ich den Blizzard Agent bzw die Battlenet app zu installieren, bei ca 50% hängt es, komme also nicht weiter, irgendwelche Tipps?
Der PlayOnLinux Assistent hat folgende Meldung: bitte warten bis Battle.Net installiert wird, der Button steht auf Installation fertig gestellt, dazu dann noch das kleine Setup Fenster von Blizzard Battle.Net, was wie gesagt hängt..
Hi Souqui,

hatte ich ganz genauso.
Ich hab sowieso oft Stress gehabt mit PlayOnLinux und meistens war es umständlich.
Hast du mal ausprobiert einfach mit Rechtsklick auf die Battle.net-Exe, das Ganze direkt mit Wine zu starten?
Wurde bei mir von sich aus an erster Stelle angeboten.
Vorraussetzung natürlich die aktuelleste WIne-Version (Winetricks habe ich auch installiert).
Ich war erleichtert wie einfach alles auf einmal war.
Hi Hyaena, das habe ich soeben versucht.. kam ne fehlermeldung :
Im Programm Battle.net-Setup.exe traten schwerwiegende Fehler auf und es muss beendet werden, wir entschuldigen uns für die Unannehmlichkeinten.

ich denk ich werd es nochmal runterwerfen und probieren neu zu ziehen.. vielleicht klappts..
@ Souqi:

Sorry, mein Post war eher ungenau und unvollständig.
Ich poste einfach mal meine Einstellungen, bzw wie ich genau vorgegangen bin.
Mein Betriebssystem ist Ubuntu 16.04 64bit.

Zuerst habe ich (wie oben erwähnt) die aktuellsten und passenden Versionen von Wine und WInetricks installiert.
Dann habe ich Winetricks gestartet und folgende EInstellungen vorgenommen:

Select the default wineprefix ---> Ok

1. Windows-DLL installieren: - alle d3dx9 und - vcrun 2013 aktiviert.
2. Schriftart installieren: corefonts
3. Run winecfg: Anwendung = Windows 10


Mit dieser Einstellung habe ich dann wie oben beschrieben einfach per Rechtsklick die Blizzard-exe gestartet (nicht erlauben eine Desktopverknüpfung anlegen zu lassen, das macht Wine selber).

Ich kann nicht viel zum Wieso und Warum sagen, ich bin noch ziemlicher Linux-Neuling, aber so habe ich WoW zum Laufen gekriegt.
Ich hoffe ich kann dir damit helfen.
*daumendrück*

Nimm an der Unterhaltung teil!

Zurück zum Forum