[HowTo] World of Warcraft unter Ubuntu / Linux Mint

Technischer Support
Zurück 1 43 44 45 Weiter
17.08.2018 11:59Beitrag von Cozzraiz
Gibts davon auch ne Disribution?
Ich habe nur von der Software gesprochen: https://lutris.net/

Nein, ich dachte irrtümlich ihr sprecht von einer Spiele Distro :P aber ja wird gleich installiert.
17.08.2018 14:58Beitrag von Dinxli
Nein, ich dachte irrtümlich ihr sprecht von einer Spiele Distro :P aber ja wird gleich installiert.


Dann mal viel Erfolg dabei ;)
Die bieten da ein Skript fuer Battle.net mit Anpassungen fuer alle Battle.net Spiele an, das hat super funktioniert. Anfangs hatte ich da zwar auch dieses Blizzard-Agent-Problem, doch durch das Loeschen des Battle.net Ordners in Progam Data war das direkt behoben.
Ja danke, hat auch gut funktioniert mit Lutris, übrigens habe ich esync ausprobiert und noch keine nennenswerte Entlastung des CPU gespürt - aber ich vermute das könnte dann relevant für raids werden.
Hi.
Ich hatte bisher immer das (kleine) Problem, dass das Einlog-Fenster vom Blizzard-Launcher nicht wirklich korrekt dargestellt wurde.
Was nicht weiter schlimm war, da es trotzdem funktioniert hat.

Bei mir gab es auch immer Fehlermeldungen beim installieren der mscorefonts über Winetricks. Mittlerweile bin ich im Netz auf Abhilfe gestossen.

Seit Ubuntu 16.04 funktioniert das Herunterladen der Schriftarten durch das Paket ttf-mscorefonts-installer angeblich wegen veränderter Pfade nicht mehr. Einwandfrei funktioniert das Debian-Paket:

wget http://ftp.de.debian.org/debian/pool/contrib/m/msttcorefonts/ttf-mscorefonts-installer_3.6_all.deb
(<-- eine Zeile)

und dann

sudo dpkg -i ttf-mscorefonts-installer_3.6_all.deb


Jetzt erscheint das Fenster genauso wie es auch soll.
Danke Hyaena, genau das Problem hatte ich auch und jetzt zum Glück nicht mehr.

Teil2: Wenn ich nun WoW über Lutris spiele, habe ich ingame nun links oben so eine Art Addon kleben, das mir die Lutris-Version, die von Vulkan, meiner GraKa und so Zeug anzeigt. Wie kann ich das Mordstrumm verschieben, verkleinern bzw. ausblenden?
Ich persönlich finde das Hud nicht störend.
Aber hier war jemand so nett und hat genau diesen Fall beschrieben wie du das in Lutris wegbekommst
https://eu.battle.net/forums/de/wow/topic/17622512889
Danke Dinxli! Mich störte die Hud als Linkshänderin auch nur, weil sich diese Hud genau auf meine Minimap klatschte, da ich die Minimap links oben habe. Hab's jetzt aber über einen anderen Weg als im beschriebenen Beitrag wegbekommen, da ich direkt über WoW gehe und dieses dann den Battle.net-client anschiebt und nicht umgekehrt:

-> Lutris starten
-> links im Fenster auf wine gehen, dann sieht man seine installierten Windowsspiele. Also Rechtsklick auf World of Warcraft, dort auf die 2. Option von oben "Configure" gehen,
-> anschließend das letzte Fenster (System Options) auswählen, runterscrollen und bei "Environment variables" den kompletten Schlüssel für "DXVK Hud" löschen und feddisch.
19.08.2018 13:10Beitrag von Syvara
Danke Dinxli! Mich störte die Hud als Linkshänderin auch nur, weil sich diese Hud genau auf meine Minimap klatschte, da ich die Minimap links oben habe. Hab's jetzt aber über einen anderen Weg als im beschriebenen Beitrag wegbekommen, da ich direkt über WoW gehe und dieses dann den Battle.net-client anschiebt und nicht umgekehrt:

-> Lutris starten
-> links im Fenster auf wine gehen, dann sieht man seine installierten Windowsspiele. Also Rechtsklick auf World of Warcraft, dort auf die 2. Option von oben "Configure" gehen,
-> anschließend das letzte Fenster (System Options) auswählen, runterscrollen und bei "Environment variables" den kompletten Schlüssel für "DXVK Hud" löschen und feddisch.


Es reicht auch den Wert auf '0' zu setzen, falls mans später "einfacher" haben will das wieder anzumachen, aber nen großen Unterschied macht das natürlich auch nich :D
Stimmt, das hat was. Irgendwann wird man das Teil schätzungsweise auch mal kleiner machen und verschieben können, dann würde ich es auch nicht mehr löschen, denn eigentlich mag ichs ja, nur nicht so riesig und mitten in meiner Minimap.
Du kannst ja gerne ein issue erstellen dass man die grösse + position ändern kann:
https://github.com/doitsujin/dxvk
Muss mich entschuldigen - ich hatte DXVK vorher falsch konfiguriert, aber es rennt jetzt wie Schmidts Katze. :-) Es gab einen enormen Performance-Schub und die Lüfter der Graka drehen sich nun auch auf Hochtouren. Ich hoffe sie übersteht das. :-)

Allerdings, bei mir steht ingame oben links eine Anzeige in weißer Schrift mit der Treiber-Version, den Frames und das das Vulcan genutzt wird. Weiß zufällig jemand wie man das ausstellt?

VG,
Bedauerich

edit: Hat sich schon erledigt. Habe Hud=1 zu Hud=0 geändert.
Und wieder ich mit einer (zumindest für mich) guten Nachricht.
Gestern wurde bei mir Wine aktualisiert und seitdem habe ich kein Problem mehr mit den bunten Gräsern und Gewässern. Auch die Lichteffekte wie Flammen und das Leuchten der Irrwische sind jetzt so, wie sie sein sollten.
Soviel also zu meiner zu schwachen Graka ....

Bin gespannt ob es bei den anderen, die das gleiche Problem hatten, jetzt auch korrigiert ist.
: ) : ) : )
mhm vielleicht ein wenig offtopic, aber linux bekommt viel liebe ^^
https://steamcommunity.com/games/221410/announcements/detail/1696055855739350561
@Hyaena
Kann bestätigen das der letzte wine Patch das Psycho Gras behoben hat!
Sehr geil!
@Dinxli
Ja, hab das auf golem gesehen - freut mich sehr.
Fehlt nur noch der Linux Client für WOW - was wollte man mehr? *zu den Blauen rüberschiel*
Moin!

In dem Zusammenhang der beiden Posts über mir überlege ich aktuell mit meinem letzten Win10 Rechner auf Kubuntu zu wechseln...ich bin mir wine etc. durchaus bewusst, hab das schon einmal durch. Ich hatte allerdings bisher mit wine nur mäßig gute Erfahrungen hinsichtlich der Performance gemacht - auf einer älteren Maschine hatte ich einen Performance-Verlust von ~50% mit wine, im Vergleich zu WinXP.
Daher hab ich leider immer noch einen Windows-PC rumstehen, auf dem ich WoW und einige andere Games zocke...daher die Frage...hat sich da seit 2015 etwas getan oder ist die Performance in WoW mit Wine immer noch (viel) schlechter als in Windows?

Hardware:
Intel Xeon E3-1230
8 GB RAM
Nvidia Geforce GTX 1070
>Intel Xeon E3-1230
Ist ein bischen schräg - sowas findet man eher in Server Systemen.

Graphikkarte habe ich die Selbe (ich spiele in 4k Auflösung)

Der Entwickler selbst gibt an dass die Performance zwischen 60% and 80% des nativen Windows ausmacht.
https://github.com/doitsujin/dxvk/wiki

Bei mir selbst komme ich bei wow auf 80% (also ca. 100fps)

Du musst ja nicht gleich linux installieren boot linux einfach mal über einen usb stick und mounte dein NFS drive wo sich wow befindet.
Hm, dann werd ich mir das einmal anschauen. 60-80% sind schon nicht ohne, aber bisher läuft ja alles flüssig. Mal sehen :)

Btw...den Xeon hab ich mit entsprechendem Board gekauft, weil der Preis-Leistungs-Mäßig damals viiiieeel günstiger als ein i5 gewesen wäre und eben keine interne GPU hat, die ich eh nicht nutzen würde. Bisher hatte ich damit noch keine Probleme :D
Hallo, habe seit dem letzten Battlenet-Client und WoW Update ständig streaming -Fehler. Unter Wine-cfg ist win10 eingestellt und unter staging häckchen bei Enable CSMT und Enable... (EAX) ... Benutze Wine-Staging 3.14, Linux Mint mit aktualisierten Treibern
@Tanreta

Welcher Streamingfehler ist es ? Magst du mal die Nummer posten?
30.08.2018 19:27Beitrag von Hyaena
@Tanreta

Welcher Streamingfehler ist es ? Magst du mal die Nummer posten?

ja - moment

Nimm an der Unterhaltung teil!

Zurück zum Forum