[HowTo]WoW Installation auf Ubuntu Linux 18.08.18

Technischer Support
Gliederung

    1. Vorwort
    2. Grafiktreiber
    3. Installation von Wine
    4. Installation von Lutris
    5. Installation von Battle.net und WoW
    6. MACH DAS NERVIGE DXVK FPS COUNTER DING WEG :c
    7. Bugs und Fixes
    8."Nachwort"


1. Vorwort

Ich möchte nur einmal gesagt haben, dass ich KEIN Linux Profi bin (eher der schwache Neuling :), allerdings hatte ich viele Probleme mit der Installation von Battle.net und WoW, die ich jedem anderen abnehmen will! Es war wirklich die Hölle ;)
Als Vorlage nutze ich diesen Post!

https://eu.battle.net/forums/de/wow/topic/15890259154

2. Grafiktreiber

Zu allererst brauchst du deinen Grafiktreiber auf Linux :) Dazu musst du deinen eigenen auf ergoogeln das kann ich dir leider nicht abnehmen. Es gibt leider zu viele Grafikkarten :( Meistens sind die Treiber für alle Grafikkarten gleich (zumindestens bei Nvidia) allerdings treten manchmal Probleme auf, weswegen man am besten einen älteren Treiber nutzt (eben der zu Release der Karte und aufwärts ^^).

Diese Seite ist momentan aktuell:

https://www.nvidia.de/Download/index.aspx?lang=de
AMD: https://www.amd.com/de/support

Google dazu: "Driver "Grafikkarte (natürlich der Name ^^)

Ich nutze eine Nvidia 10er Grafikkarte, also brauche ich den nvidia-384 Treiber. Da viele eine 10** Grafikkarte nutzen werde ich die Befehle dazu auflisten :)

sudo apt purge nvidia-*** nvidia-settings
sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt-add-repository ppa:xorg-edgers/ppa
sudo apt update
sudo apt dist-upgrade
sudo apt install nvidia-384
sudo reboot


Ich nutze nicht, den Treiber der Seite, da ich Probleme beim installieren hatte. Dieser funktioniert einwandfrei :)

3. Installation von Wine

Wine ist ein Programm das es dir ermöglicht .exe Programme zum laufen zu kriegen :)

Gehe für die Installation einfach folgende Schritte ab:

1. Auf https://www.winehq.org/download gehen
2. Die Distro wählen
3. Den Schritten der Seite folgen
4. Bei der Installation die Stable Version installieren
5. :O Du hast Wine installiert

Jetzt wäre brauchst du noch Winetricks, es ermöglicht dir Schriftarten und Dlls, etc. einzubetten, sodass Wine keine Problem beim Ausführen von Programmen hat.

Dazu gehst du einfach ins Software Center und downloadest Winetricks, gaaanz easy :)

4. Installation von Lutris

Lutris ist ein Programm, dass es dir sehr viel einfacher macht Spiele auf Linux zu installieren :)

Zum Installieren von Lutris solltest du diese Befehle im Terminal eingeben.

ver=$(lsb_release -sr); if [ $ver != "18.04" -a $ver != "17.10" -a $ver != "17.04" -a $ver != "16.04" ]; then ver=18.04; fi

echo "deb http://download.opensuse.org/repositories/home:/strycore/xUbuntu_$ver/ ./" | sudo tee /etc/apt/sources.list.d/lutris.list

wget -q http://download.opensuse.org/repositories/home:/strycore/xUbuntu_$ver/Release.key -O- | sudo apt-key add -

sudo apt-get update

sudo apt-get install lutris


Öffne jetzt einmal Lutris und schließe es. Einach lutris in das Terminal eingeben :)

5. Vorbereitungen treffen

Vor WoW musst du ein paar Vorbereitungen treffen :)

Du musst folgende Dinge installieren. Dazu Googelst du diese Dinge am besten, da ich mir nicht sicher bin ob sie geupdatet werden.

ttf-mscorefonts-installer
libgnutls30:i386
libldap-2.4-2:i386
libgpg-error0:i386
libsqlite3-0:i386


Manche Dinge lassen sich nicht download, da sie schon auf der neusten Ubuntu Version vor installiert ist. Ich kann mich erinnern, dass ich 3 Sachen installieren konnte. Da war Definitiv das letzte dabei :)

5. Installation von Battle.net und WoW

Öffne Lutris :)

Gehe jetzt auf https://lutris.net/games/battlenet/ und wähle die neuste Version der Installation. Bei mir ist es die Gold Version. Gold und Platin sagt wie gut es zu dem Zeitpunkt lief. Klicke dann rechts auf Install und lass das Programm machen. Davor sollte es natürlich geöffnet sein :D

Bei Fehler der Installation einfach nochmal versuchen oder den letzten Punkt des Guides ansehen :)

Es sollte eigentlich alles funktionieren mit Installieren von WoW und alles drum und dran.

6. MACH DAS NERVIGE DXVK FPS COUNTER DING WEG :c

Gehe in Lutris

Mach einen Rechtsklick auf Battle.net

Klicke auf Configure

Auf Advanced Options

Dann oben auf System Options

Dann unten auf Enviroment variables

Bei DXVK_HUD rechts anstatt den Langen mist einfach ne 0 reintippen :)

6. Bugs und Fixes

Bugs und Fixes werden hier gemeldet:

https://github.com/lutris/lutris/wiki/Game:-Blizzard-App


Rechts an der Seite gibts Fixes zu anderen Blizzard Games und den Launcher

https://appdb.winehq.org/objectManager.php?iId=28855&sClass=version


7. "Nachwort"

Ich hoffe ich konnte vielen Leuten viel Arbeit ersparen :)

Bitte sagt nichts zu meiner Rechtschreibung und Kommasetzung :( Mein letztes Zeugniss war Super. 5 1en, doch fast eine 4 in Deutsch :D:D. Scheint als wäre Mathe, Englisch, etc. besser für mich.

Ich versuche Fragen zu beantworten. Allerdings bin ich selbst nich zu auf der Höhe was Linux angeht c:

LG und glhf beim Zocken
05.09.2018 23:14Beitrag von Bedauerich
Das Problem mit dem "Bitte warten" im Launcher hatte ich letztens auch und es passierte stundenlang nichts. Ich habe dann einfach einen neuen Launcher von der Blizzard-Homepage runtergeladen und aus dem Download-Ordner heraus gestartet. Damit funktionierte die Aktualisierung dann sofort auf Anhieb.


Ich denke ehrlich gesagt nicht an den launcher Files liegt, sondern eher an den externen aufrufen. Beim 2ten oder dritten mal hatte es mal funktioniert.
Aber es ging auch schon mal den ganzen Vormittag nicht.
Mit Linux hängt es auch nicht zusammen, dafür gibt es zu viele posts über das selbe Problem von Windows Usern.

So und somit ist der neue Thread in Verwendung ]:)
Btw danke dafür. Das war schon höchste Zeit, du hast es sehr gut gegliedert und den alten Beitrag verlinkt.

Bezüglich der Rechtschreibung (offtopic): Ist doch rel. gut geschrieben, wichtiger sind hier eh die Absätze und kurze prägnante Sätze.
Ich selbst achte auch nicht so sehr darauf in meinem techn. Beruf ist das nebensächlich, aber wenn es darauf ankommt sollte man es schon halbwegs gut beherrschen, daher fleissig lernen ;)
Danke für das Aufschreiben.

Ich habe WoW direkt über https://lutris.net/games/world-of-warcraft/ installiert.
Davor habe ich wie im Link beschrieben die Abhängigkeiten kontrolliert und ggf installiert.
Das ganze deckt sich ziemlich genau mit deiner Beschreibung.
Hallo,

ich kann den Launcher leider nicht mehr starten, um WoW zu aktualisieren. Es kommt die Fehlermeldung "Beim starten des Blizzard-Agents ist ein Fehler aufgetreten. (BLZBNTBTS0000005C).

Hab es auch mit einem frischen Launcher und mit einer Sicherheitskopie des WoW-Ordners probiert, aber leider ohne Erfolg.

Hat vielleicht jemand eine Idee woran das liegen könnte?

VG,
Bedauerich
07.09.2018 12:18Beitrag von Bedauerich
Hallo,

ich kann den Launcher leider nicht mehr starten, um WoW zu aktualisieren. Es kommt die Fehlermeldung "Beim starten des Blizzard-Agents ist ein Fehler aufgetreten. (BLZBNTBTS0000005C).

Hab es auch mit einem frischen Launcher und mit einer Sicherheitskopie des WoW-Ordners probiert, aber leider ohne Erfolg.

Hat vielleicht jemand eine Idee woran das liegen könnte?

VG,
Bedauerich


Hmmm.
Keine Ahnung ob das bei Dir auch funktioniert.
Bei mir hatte sich der Launcher beim Aktualisieren aufgehängt und erst als ich den Cache-Ordner gelöscht hatte, kam ich bis zur Charakterauswahl.
Und nachdem ich da dann rausgekickt wurde, tauchte wieder einmal WOWError 51900322 auf.
Dazu brauchst du einen neuen "Sauberen" Cache-Ordner.
Wie hier beschrieben:

https://eu.battle.net/forums/de/wow/topic/15890259154?page=43#post-854

Probier mal aus.
Danke für den Tip. Ich habe den Cache durch durch die Dateien von Github ersetzt, aber der Fehler besteht leider weiterhin. :(

Vg,
Bedauerich
Hast du schon alle dependencies installiert?
https://github.com/lutris/lutris/wiki/Game:-Blizzard-App

An wine kann es nicht liegen, da ich mit einer frischen instanz den launcher out-of-the box starten kann. daher meine vermutung

für dein ubuntu:
Ubuntu / Debian: ttf-mscorefonts-installerUbuntu: libgnutls30:i386 libldap-2.4-2:i386 libgpg-error0:i386Ubuntu / Debian: libsqlite3-0:i386
Auf der Seite sind übrigens auch die neuesten Issues beschrieben:
https://github.com/lutris/lutris/wiki/Game:-Blizzard-App#a-required-dll-could-not-be-found
https://github.com/lutris/lutris/wiki/Game:-Blizzard-App#spinning-icon-no-login-buttons
https://github.com/lutris/lutris/wiki/Game:-Blizzard-App#black-screen-when-starting-game
https://github.com/lutris/lutris/wiki/Game:-Blizzard-App#issues-with-installing--updating--sleeping-agent
https://github.com/lutris/lutris/wiki/Game:-Blizzard-App#it-simply-wont-start

und folgendes könnte relevant für dich sein:
https://github.com/lutris/lutris/wiki/Game:-Blizzard-App#various-exe-errors
Hm...ich spiele nicht unter Lutris, sondern ganz normal über Wine-Staging. Die von Dir genannten Pakete sind alle bereits installiert. Die WoW.exe zu starten ist auch kein Problem, aber ich bekomme es leider nicht aktualisiert, weil der Launcher nur mit der oben genannten Fehlermeldung startet.

Ich habe den kompletten WoW-Ordner jetzt mal gelöscht, aber wenn ich dann ein WoW-Setup starte kommt leider wieder die oben genannte Fehlermeldung.

Die links schaue ich mir nachher mal an.

VG,
Bedauerich
Falls es immer noch nicht klappen sollte müsstest du sonst mal das debugging aufdrehen bei wine und wow via console starten.

Da sollte man doch sehen was den Fehler verursacht
Ich habs jetzt gelöst indem ich meinen .wine-Ordner gelöscht und WoW in einem frischen .wine-Ordner neu installiert habe. Hatte die Faxen nämlich dicke...

Ich konnte meinen gesicherten WoW-Ordner leider auch nicht wirklich nutzen, denn dann trat immer wieder der Fehler mit dem Agent auf. Egal...jetzt läufts wieder..

Danke noch mal für eure Hilfe.

VG,
Bedauerich
Schön dass es funktioniert hat - vielleicht war einfach schon zu viel verstellt worden :)

Man muss den .wine ordner ja nicht gleich löschen - bzw. wenn du etwas ausprobieren möchtest lege einfach einen neuen wine-ordner über das wine prefix an.
Ich selbst teste gerade esync+dxvk mit einer selbst kompillierte wine version
WINEESYNC=1 DXVK_HUD=1 WINEPREFIX=~/.wine-esync wine64 /run/media/[USER]/Games/World\ of\ Warcraft/World\ of\ Warcraft\ Launcher.exemein stabiler haupt-prefix ist aber WINEPREFIX=~/.wine-64d.h. wenn du mal was testen willst solltest du sicherheitshalber ein neues wineprefix verwenden. Nur so als Tip :)

esync gibt es übrigens auch für Lutris:
https://github.com/lutris/lutris/wiki/How-to:-Esync
Esync removes wineserver overhead for synchronization objects. This can help some games, that are CPU bound, run faster
So wie in World of Warcraft ;)
Hm, seit heute lässt sich mein Launcher nicht mehr mit DXVK starten, was natürlich zu ziemlich miserablen FPS und Rucklern führt :(

Genutzt wird Lutris mit esync-3.14, neustem Nvdia-Treiber (390.87) unter Debian-stretch.

Bis gestern lief alles ohne Probleme. Heute streikte der Launcher dann auf einmal direkt beim Starten mit einer Crash-Meldung. Was auch passiert, sobald ich versuche einen neu installierten Launcher zu starten.
Irgendwie dann geschafft, den Launcher wieder zur Mitarbeit zu bewegen, aber nur ohne DXVK.
Versuche ich jetzt den "reparierten" Launcher mit DXVK zu starten kommt direkt als Fehlermeldung dass eine .dll fehlen würde oder er crasht wieder direkt beim Start.
Irgendjemand eine Idee?
*stellt eine Schale Schokokekse hin*
Welche dlls fehlen denn? Ich vermute mal die gepatchten von dxvk - denn dann kommen genau solche dll errors.

edit:
Du kannst dir gerne noch den Rest von mir durchlesen :) aber am einfachsten wird es sein wenn du das hier befolgst:
https://github.com/lutris/lutris/wiki/How-to:-DXVK#manually-updating-dxvk
Aktuellste Version ist gerade: 0.71

----------------------------- optional -----------------------------

Ich verwende Manjaro (Archlinux) bei mir kann ich dxvk_32 und dxvk_64 binaries von meiner Repo einfach runterladen und mit
setup_dxvk32 && setup_dxvk64
installlieren

Für die anderen Distros weiß ich das nicht aber dort steht beschrieben wie du dir das selber bauen kannst und diese in system32, syswow64 kopiert werden.
https://github.com/doitsujin/dxvk

Du musst aber sowohl 32bit UND 64bit installieren

Im Zweifelsfall würde ich die Schritte auf
https://github.com/lutris/lutris/wiki/How-to:-DXVK
nocheinmal durchgehen und kontrollieren ob alles vorhanden ist.

Ich hatte den Fall dass die files welche mit den dxvk binaries korrupt waren (so ein glück) auf ~/.local/share/lutris/runtime/dxvk/* (32bit und 64bit) und diese habe ich dann ausgetauscht - dann ging es.
Welche .dll? Wenn das in der Fehlermeldung stehen würde wäre sie schon längst da...
Es kommt nur "Eine dll fehlt, bitte installiere den Battle.net Launcher erneut" (sinngemäß) oder es erscheint direkt die Crash-Meldung.
Wobei die dll fehlt Meldung wohl auch unter Windows erscheint und direkt zum Launcher selbst gehört... Aber auch die aktuellste Variante hilft da nichts. Und sobald ich DXVK ausmache schnurrt das Teil wieder wie ein Kätzchen?

Ich hab gestern Vulkan neu installiert, nvidia neu, wine neu, einzig Lutris bleibt noch. Aber wie gesagt, vorgestern lief es einwandfrei und gestern ging dann gar nichts mehr, ich hab daran nur nichts geändert. Was ich gemacht hatte, war eine neue Festplatte einzubauen und darauf Windows für nen Dualboot zu installieren weil paar Sachen ja leider nicht laufen.

Muss ich also doch mal den Pinguindompteur mit Kaffee und Keksen bestechen gehen *seufzt*
So, mal ein kurzes Update, nachdem die WaKü auch noch den Geist aufgegeben hatte und ich nun endlich Ersatz habe:
Ich habs wieder zum Laufen bekommen.
Scheinbar hab ich es irgendwie geschafft in der fstab Datei den 'default' Eintrag bei den Mount-Optionen zu verlieren...
Naja, default rein, umount, mount, tadaa es läuft wieder. Ich komme mir irgendwie verarscht vor :D
In Ubuntu gibt's schon länger Probleme mit den Schriften (ttf-mscorefonts, die sich nicht komplett installieren), gestern war z. B. mein Chat hin und wieder komplett unsichtbar. Äußerst suboptimal sozusagen, also googelte ich mal so ins Blaue hinein, bügelte ein Debian-Paket drüber und tadaaa, es ging endlich wieder.

Wer mag, hier ist ein Download-Link zum Debian-Paket: http://ftp.de.debian.org/debian/pool/contrib/m/msttcorefonts/ttf-mscorefonts-installer_3.7_all.deb
Hallo und vielen Dank für diese tolle Anleitung .
Ich habe schon öfters versucht Wow unter Linux zum laufen zu bekommen und mit dieser Anleitung schaffte ich es bis zum laufenden Launcher.
Wenn ich das Spiel allerdings starten will, schließt der Launcher und im Terminal kommt die Meldung "to many open Files".

Nachdem die Installationsroutine die Installation von Wow verweigerte (ich konnte den Button "installieren" klicken ohne das sich was tat).
Habe ich meine Windows Installation kopiert diese nun ihre Arbeit verweigert wie oben geschildert.

Könnte dies an meiner Grafikkarte liegen, R9 280?
Ich habe irgendwo gelesen das die Grafikkarten der GCN 1 Generation seitens AMD nicht mehr supportet werden beim Linux Treiber.
Meine getesteten Distros waren Ubuntu 18.04. und Mint 19.
die too many open files meldung kommt oft wenn der wert für files limit zu niedrig ist.
siehe https://github.com/lutris/lutris/wiki/How-to:-Esync

edit:
das war mal zu der Fehler Meldung.

04.10.2018 10:46Beitrag von Serpta
Könnte dies an meiner Grafikkarte liegen, R9 280?

Überprüfe mal, ob deine installierten Treiber die Ansprüche für dxvk abdecken für AMD RADV:
https://github.com/doitsujin/dxvk/wiki/Driver-support
Du brauchst dann schon eine relativ neue Treiber Version >= 18.1.3

Laut https://support.amd.com/en-us/kb-articles/Pages/Radeon-Software-for-Linux-Release-Notes.aspx
gibt es aber 18.20 Linux Treiber
Das meinte ich damit, ich benutze den Radeon Mesa Treiber der Installation.

Der AMDgpu läuft nicht durch/ bricht ab.
Allerdings stehen die R9 270 / 280
als einzige nicht mehr mit drin.
R7 240-260 und R9 285-290 schon.

https://support.amd.com/en-us/kb-articles/Pages/Radeon-Software-for-Linux-18.20-Early-Preview-Release-Notes.aspx

Nimm an der Unterhaltung teil!

Zurück zum Forum