Welcome to the Technical Support Forum!

Technical Support
Welcome to the Technical Support forum! This forum provides players with a place to discuss technical issues with each other and official Blizzard representatives.

While this forum is NOT intended to replace our support contact channels, players are encouraged to ask questions, share advice, and participate in on-going discussions here. Accordingly, it is of utmost importance that all players treat each other with courtesy and respect. For more information, please review the Forum Code of Conduct.

Our MVPs are also here to help you:

Writing an Effective Post

Before creating a new thread, be sure to search the Blizzard Support Site and read our Common Issues & Fixes sticky post. Additionally, performing a quick forum search before posting may yield helpful results.

If you’re still unable to resolve your issue, feel free to open a new thread with a descriptive title and a list of the troubleshooting steps you have already tried.

Providing relevant information will also expedite the diagnosis process greatly:

  • Installation and patching issues should include any error messages you are seeing.
  • Connection and latency issues should include your country, ISP as well as a Traceroute and Pathping.
  • Performance and stability issues should include when the issues began and a DXDiag report.

NOTE: If you have an issue with payments or your Blizzard account, we’re unable to assist on public forums for privacy reasons. Please contact our support team directly and they will be more than happy to help.
Social Media

Please follow @BlizzardCSEU_EN on Twitter for regular service updates. This feed is also available in German, French, Russian, Spanish, Italian, Polish and Portuguese.

We also have a dedicated Customer Support YouTube channel to help you guide you through certain features and fixes for common issues.

Join the Conversation

Return to Forum