Game stuck at loading screen

Technical Support
Hello,
it's since this morning i'm having difficulties in starting new games or joining them with my Diablo 3 account. i tried to create or join with some of my charachters (both hardcore and softcore, and even created a new one to try a fresh start but when i start the game or join them i'm stuck in the loading screen while my friends claim that they see my character in game.

i have run the repair and restarted my computer a couple of times but the problem still persist.

i have already checked for my evga gtx 670 drivers and they are all up to date.

My system run a win 7 64 bit with:
i7 930 @ 2.8 Ghz
12 gb ram ddr 3

ç_ç°
a little update:

deleted the cache following the steps in battle.net-

My little bro is able to start and join games with my account from another town.

i'm still stuck in loading screen.
+ 1 exactly the same issue.

Works fine on solo

On group it gets stack on loading screens sound plays rest sees me online etc.
UPDATE

As it has been posted in another thread problem is caused by the amd beta drivers. Roll back to 15,7 and everything should be ok. Did that and my game works again.
as you can see from my specifics i don't have any AMD software installed on my PC.

also the game run with lag problems in story mode
And another update.

Drivers are partially at fault when it comes to amd. With 15.7 i still get some freezes but way rarer (still something that wasnt happening though).
28/08/2015 18:55Posted by Baboon
UPDATE

As it has been posted in another thread problem is caused by the amd beta drivers. Roll back to 15,7 and everything should be ok. Did that and my game works again.


No, it is not OK. Same happens both with 15.7 and with 15.7.1.

Blizzard messed up once again, don't blame AMD.
i didn't made this topic to talk about AMD issues.
this is clearly another kind of problem since i don't have any AMD software or driver.
For anyone if it can help, I was in same situation: no AMD (I got geforce), tried emptying BNet cache, no success. But then, I checked my software firewall (Look'n'Stop) and I saw it was kinda blocking some packets from battlenet. So I added a rule allowing that port/packet/address and voila, magically, I could enter game. Though, this morning it was doing the same, I checked again and saw a new battle net port block, allowed also that one, and worked again. So I guess, it's a bit annoying but it's something related to fussy software firewalls...
i was able to play all night untill 10 a.m. then i logged off to sleep... now i'm back online and i have the same problem... can't understand what is happening.
please i need help from a blue....
another update:

i have made a new installation of diablo 3 on my portable PC, and even changed my router with a new one but it is not running both on my portable and on the desktop.
tried the solution found here:

http://eu.battle.net/d3/en/forum/topic/15161822968

it doesn't work for me and i'm still in loading screen...

all other blizzard games are running without problems (hearthstone, SC2, WoW and HOTS)
here is my tracert to the diablo 3 server:

Traccia instradamento verso 213-155-155-233.customer.teliacarrier.com [213.155.155.233]
su un massimo di 30 punti di passaggio:

1 1 ms 1 ms 1 ms 192.168.1.1
2 39 ms 39 ms 38 ms 192.168.12.1
3 * * * Richiesta scaduta.
4 * * * Richiesta scaduta.
5 * * * Richiesta scaduta.
6 * * * Richiesta scaduta.
7 327 ms 268 ms 224 ms 83.224.40.122
8 41 ms 40 ms 41 ms ae4-100-xcr1.mlk.cw.net [195.59.1.25]
9 68 ms 40 ms 41 ms ae12-xcr1.mlu.cw.net [195.2.25.5]
10 41 ms 40 ms 41 ms mno-b2-link.telia.net [213.248.92.125]
11 59 ms 82 ms 61 ms prs-bb3-link.telia.net [62.115.135.76]
12 63 ms 62 ms 63 ms adm-bb3-link.telia.net [213.155.137.146]
13 63 ms 63 ms 63 ms adm-b2-link.telia.net [62.115.141.3]
14 * * * Richiesta scaduta.
15 * * * Richiesta scaduta.
16 * * * Richiesta scaduta.
17 * * * Richiesta scaduta.
18 * * * Richiesta scaduta.
19 * * * Richiesta scaduta.
20 * * * Richiesta scaduta.
21 * * * Richiesta scaduta.
22 * * * Richiesta scaduta.
23 * * * Richiesta scaduta.
24 * * * Richiesta scaduta.
25 * * * Richiesta scaduta.
26 * * * Richiesta scaduta.
27 * * * Richiesta scaduta.
28 * * * Richiesta scaduta.
29 * * * Richiesta scaduta.
30 * * * Richiesta scaduta.

Traccia completata.

i'm not able to interpret it... is it a connection problem? what should i do about it?
every other game i run works fine...
hi deply, same problem... i have a question for you and other user with the same problem. What is your telephone company? teletu?
My problem seem gone after 24:00. It remember me a problem of lag that i had with diablo3 a long time ago. Teletu was filtering peer to peer trafic between 12:00 and 24:00.
Then I resolved the problem using battle ping. This time the problem is different and battle ping doesn't work for me. But the hours of the problem is suspicios...
If it was a connection issue, it'd just throw you off and say you've been DC'ed..
I'm having the same problem though, with getting stuck in loading screens and it's happening in almost every loading screen - I can get into town, but as soon as I try going to a bounty or a rift, it freezes in the loading.. Been happening since around 11pm server time now, but been working fine literally all day before that
confirm my suspects. the problem began yesterday. It start exactly at 12:00 and finish at 24:00 ... Hours used by my telephone company to filter some kind of traffic... teletu di m***a
yeah Loki, my ISP is "teletu"... it seems like they have some kind of problem.
i will try to contact the customer service and will update the topic if anything change
Hello deply,

There appears to be a huge issue here:

29/08/2015 22:58Posted by deply
6 * * * Richiesta scaduta.
7 327 ms 268 ms 224 ms 83.224.40.122


Something around hop 7 is adding huge amounts of latency to the connection, unfortunately this hop is outside of our control, so we have no means to influence the connection at this point.

All we can recommend in this case is that you show this trace route to your ISP, as they should be able to advise from there.
___________________________________

Let me know how I'm doing!
https://www.surveymonkey.com/s/Lurdlespor
deply
Posts: 15
View profile
a little update:

deleted the cache following the steps in battle.net-

M


28/08/2015 18:55Posted by Baboon
k to 15,7 and everything should be ok. Di

Join the Conversation

Return to Forum