Can't start diablo 3

Technical Support
Just a moment ago I updated my Battle.net launcher and after the update I have been unable to play diablo 3. When I press the Play button it changes into "Launching...." and then nothing happens.

I tried looking for a fix for this issue and came up with renaming the agent folder or deleting the folder entirely. Neither of these methods worked and I've rebooted my PC several times between every method I've tried.

That was a nice update.
Same thing happened for me.

Just installed Diablo 3 again and now it won't start.
I am also having this problem. Worked fine last week, but when I uninstalled it and just today reinstalled it, it will show the D3 logo in the middle of the screen but game never loads.. eventually the launcher lights up the "Play" button again.
Anyone from tech gonna help?
Turns out Blade and Soul doesn't like Blizzard.. had to uninstall the game before Diablo would actually work again.

Thank you Blizzard Tech Support for that swift help.....
Hello all,

Delete the Battle.net Cache folder:
battle.net/support/article/6141

Delete the Battle.net Tools folder:
battle.net/support/article/6504

Repair the game:
battle.net/support/article/6572

Try closing background applications to make sure no other programas are interfering:
battle.net/support/article/200483

Please, keep in mind the forum was created mainly for letting players help each other. While we blues try to help as much as possible, it's not always possible to answer every thread. Keep also in mind there isn't 24h support on the forums.

______________________________________________________
Got feedback about the support I'm providing? Leave your comments here!
I've done everything listed above by @Delmoryth. Three times. Still the same issue. Whats the deal? Everyone seems to have had or has this issue. Tech can you please provide more helpplease. You have no telephone numbers either so I am guessing I am going to need to wait days for a response even though you take my cash for the game within 1 minute.
... more like months... your post is from 3 months ago, still no new blue posts... I'm in the same situation as you, same problem exactly as original poster described, tried all of the steps blue posted, still stuck with a non-working game... Blizzard folks, any help on this?
Thx but this steps not working. Please provide solution
Having the same problem, what gives ?!
Works fine for me
I cant start Diablo anymore , When i push play i get a Error screen and wont let me in.
I have deleted Diablo completly, Then when that didnt work i deleted Battlenet all off it, then both. After that i checked all the thing on forums but i cant get it too work again.
A other problem is that i cant get too the support , because it doesnt allow me too upload DXDIAG and MS INFO, Im running on windows 10 and didnt had problems in seison six, but all started in seison 7 when grapics started too fall out some times getting worse. I have 2 980TI in SLI, win 10 and running on a M2 mainboard drive ssd. So in these notification erros i get i send them too blizz back what i was doing but well i cant reach the support or get any reaction back.
Zdravím mam original game DVD Diablo3 reaper of souls a nechce se my spustit update,pomuže my nekdo?
This issue just popped up for me, too. Closed game, went out to have lunch, came back, and nothing. Computer hadn't even been restarted.

No help from anywhere.
28/08/16 19:57:23,830 com.apple.xpc.launchd[1]: (com.blizzard.switcher.252832.0342CDE6-F25D-407E-B41B-0AF4C3149A09[679]) Service exited with abnormal code: 1
28/08/16 20:17:37,837 authd[108]: copy_rights: _server_authorize failed
28/08/16 20:17:39,903 Agent[1134]: WARNING: The Gestalt selector gestaltSystemVersion is returning 10.9.6 instead of 10.11.6. This is not a bug in Gestalt -- it is a documented limitation. Use NSProcessInfo's operatingSystemVersion property to get correct system version number.
Call location:
28/08/16 20:17:39,904 Agent[1134]: 0 CarbonCore 0x991c2e3d ___Gestalt_SystemVersion_block_invoke + 135
28/08/16 20:17:39,904 Agent[1134]: 1 libdispatch.dylib 0x92cd883f _dispatch_client_callout + 50
28/08/16 20:17:39,904 Agent[1134]: 2 libdispatch.dylib 0x92cd871b dispatch_once_f + 78
28/08/16 20:17:39,904 Agent[1134]: 3 libdispatch.dylib 0x92cd9fa5 dispatch_once + 31
28/08/16 20:17:39,904 Agent[1134]: 4 CarbonCore 0x9913e8e1 _Gestalt_SystemVersion + 1047
28/08/16 20:17:39,904 Agent[1134]: 5 CarbonCore 0x9913e08a Gestalt + 154
28/08/16 20:17:39,904 Agent[1134]: 6 Agent 0x005bb8ac Agent + 5191852
28/08/16 20:17:41,284 com.apple.xpc.launchd[1]: (com.blizzard.switcher.252832.BB4FF802-8A90-405C-AA97-F5F481496E45[1137]) Service exited with abnormal code: 1
Having the same problem - I've looked for answers, but can't find any. It'll open to the RoS logo and then cease. The Battle.net app will say 'playing now' and won't stop saying so, even though the game is absolutely not running?
I think it's time to lawyer up. They took our money and delivered NOTHING.
I installed Diablo3and when came to playable,i preesed play,but amessage poped up,that my graphic card is not ok.I have NVDIA Ge Force 830M and Intel(R)HDGraphics 5500,how comes not to beok and I can"t continue installation to optimal? please tell me what to do

Join the Conversation

Return to Forum