Zultan kulle freeze

Technical Support
I have a problem were the game "freezes" either then zultan spawns or right after he finished talking, my character would only jump back and forth only osme milimeters and i can't do anything except Ctrl + alt+ del and turn it off there. i want to progress throu this quest but can't because it always happens then i am on the quest line zultans kulle bloob and goin into the ancient paths /desoltaed sands.
Hi there MrCupCake!

Are you using an AMD graphics device? If so, please try updating your hardware drivers like this.
-------------------------------------------------------------
Please click here to give me your feedback on this post!
Can i send dxdiag because i looked up i read i had the latest but i maybe missed it?
I should had mentioned it only happens in desolate sands either take gateway or run throu ancient path (i have the latest update drivers) http://i.imgur.com/cn7Fnp9.jpg
Hello guys, have been having the exact same problem in desolate sands while running through the ancient path, i have the latest AMD drivers aswell.... still no useful solutions please answer back as soon as possible.
If the latest drivers don't solve the issue, I would recommend giving a try to the beta version, which sometimes solve issues like this.

______________________________________________________
Got feedback about the support I'm providing? Leave your comments here!
Sadly the beta version didn't work either so what should i do now?
Try to use older 14.12 AMD Catalyst Omega Software .
Still getting the same issue regardless of driver version, this happens on all my characters.

any ideas anyone else this game goes into storage as I cannot progress past this point on any character
Hello Soumy,

Apart from the drivers, have you tried the steps in this article? I would recommend trying all of them, including advanced:
battle.net/support/article/6300064

If the issue persists, please create a DxDiag file and paste the content on the thread:
battle.net/support/article/200581

Please use the Code Blocks function when including the contents of the file:

- Press the button pre on top of the space where you normally write your message.
- Paste the content of your file between the square brackets ][

Example:
[ code]<Contents of the file>[/code ]

______________________________________________________
Got feedback about the support I'm providing? Leave your comments here!
the only thing i haven't tried is uninstalling the whole game i will try it then i have free time to do it i am cought up in searching for jobs so can't tell directly how or if it will be fixed short time
Is this 'still' an issue with anyone else but me? Is there anyway for US to get into the desolate sands that 'doesn't' freeze? Why am I still having this issue?
29/04/2016 04:15Posted by HoTshots
Is this 'still' an issue with anyone else but me? Is there anyway for US to get into the desolate sands that 'doesn't' freeze? Why am I still having this issue?

If you have an AMD card, make sure you update your drivers. More specifically, I've seen that the latest Crimson Edition drivers seem to solve the issue for the vast majority of players. You have a guide on how to update your drivers here:
battle.net/support/article/200576

______________________________________________________
Got feedback about the support I'm providing? Leave your comments here!
Ich kann es nur auf Deutsch also ich habe Diablo 3 gerne gespielt bin über paragon 1000 aber ich werde es jetzt nicht mehr spielen, Ich habe in der letzten season bis Paragon 833 gespielt und war außer stande diese dreckigen Set Portale zu schaffen, diese season das gleiche spiel bin zwar erst Paragon 412 aber bin froh das ich es jetzt nicht mehr spielen werde. Das spiel hat mir mal viel spass gemacht aber mit dieser beutetruhen Geschichte und den unschaffbaren Aufgaben in diesen Setportalen die keiner mag !!! Ich lese immer wieder die sind der letzte rotz ganze Clans haben kein bock mehr auf das Game wegen diesen Mist nennen Sie das SPIELSPASS blizzard ???
HI!
Just had the exact same problem, I have a Ati Radeon HD 5770 and updating from the latest oficial stable version to the Crimson Edition 16.2.1 Beta seems to have done the trick!
Although I still don´t like to use BETA drivers, hope there will be no problems!

Join the Conversation

Return to Forum