Gelatinous Sire - No loot.

General Discussion
I've had it drop no loot multiple times recently. Just happened seconds before I came in here to post.
What happened, why did it start bugging recently?? Soo Annoying since it's the best goblin there is.

-It split out once, to usually two spawns. Then when they die - Nothing happends.. doesn't split, doesn't drop loot.

I'm running the Gargantuan build on WD if that's any help Blizzard.
I would guess it's the old bug returning that if you oneshot it it drops no loot.
11/02/2016 12:35Posted by Kargon
I would guess it's the old bug returning that if you oneshot it it drops no loot.

Seems quite possible.
It did start after i got a lot of damage.
Anyways, didn't know it was an issue before, thanks for telling me. Now we just need to make blizzard aware again i guess
yeah. happened to me also.. T10 bounties.. happened in Act5 in that cemetery place.
Bump for blizz
Happend to me aswell a couple of times. I think it happens when you kill them too fast. I have 2.2 mil damage on my monk and when i drop the bell on them it almost 1 shots them so i was thinking that was the problem...
Hope it gets fixed anyway
12/02/2016 18:25Posted by AreoHotah
Happend to me aswell a couple of times. I think it happens when you kill them too fast. I have 2.2 mil damage on my monk and when i drop the bell on them it almost 1 shots them so i was thinking that was the problem...
Hope it gets fixed anyway


Same problem.. My gargs on my WD crits for like 40-50 bil, so i instakill them as well :/
it happened to me once like 5 days ago. i found it very annoying since i love the blue bastard and he deceived me. they should fix it
I had the same issue while running Torment X rift. All for us were very powerfull, killing everything in one shot, but there was no loot. Next time try to take a little time before you kill it, maybe thats the problem.
13/02/2016 17:01Posted by karpiupl
I had the same issue while running Torment X rift. All for us were very powerfull, killing everything in one shot, but there was no loot. Next time try to take a little time before you kill it, maybe thats the problem.


Just very annoying since i can't control my pets on my WD without dismissing them which takes time :/
Had 3 occurrences of this in Season 12 so far. Partied and solo.
That bug never went away.
You have seen this earlier? Some bugs keeps coming back over and over again?

Patch files seems to be 'updated' from older codes and old bugs comes back...thanks Blizzard's coders... in finnish: "kädettömät apinat!"
As far as I know, the bug has been there since the Gelatinous was introduced. What we always do when we encounter them is not rushing.

I've read somewhere, although this is not an official statement in anyway, that if you wait about 8 seconds before killing the first spawns, they'll all spawn the last ones correctly and you'll get all loot. It's the first spawns that contains the bug, not the smaller ones.
The ones I killed yesterday exploded the screen in loot- Guess I got all the loot that didn't drop for you, sorry ;-)
Sort of happened to me a few days ago. What happened was only 3 of the final 6 gel gobs spawned. Just thought it weird and just said it was a bug. Brother I was playing with saw it too.
28/11/2017 00:11Posted by Alvy
Sort of happened to me a few days ago. What happened was only 3 of the final 6 gel gobs spawned. Just thought it weird and just said it was a bug. Brother I was playing with saw it too.
Maybe they did spawn, but escaped before you could get to them?

Gelatinous Sire is one of the more annoying goblins in the game, but is also the most rewarding. Whenever I find one, and whenever possible to do so, I try to herd the first "big guy" into a corner or enclosure of some kind, so that when he splits, it is easier to manage the smaller ones that are spawned:

https://1drv.ms/i/s!ApNPUvsKitb8ho0YTYWg1B0cvPTWZA
https://1drv.ms/i/s!ApNPUvsKitb8ho0aTqfHnyqbd4LF4Q
Land of the dead - frozen lands stops all the little critters from bolting in all directions :-)
28/11/2017 04:16Posted by Prometheus
28/11/2017 00:11Posted by Alvy
Sort of happened to me a few days ago. What happened was only 3 of the final 6 gel gobs spawned. Just thought it weird and just said it was a bug. Brother I was playing with saw it too.
Maybe they did spawn, but escaped before you could get to them?

[/quote]

Nope. My UE DH one shots gobs on T13. I shot once and killed the Gel Sire. It spawned 2 gel gobs. I shot a second time and killed both gobs. Then only three baby gobs spawned. Third shot killed those. They were near to me in the middle of the screen in a narrow corridor so noway they could have actually spawned and ran away.
I think this happens with other Gobs too, if you kill them to fast they don't drop loot for some reason...

Join the Conversation

Return to Forum