Application encountered an unexpected error

Technical Support
Hi,

for the past couple of hours I've been trying to get Diablo 3 to launch. However, everytime I press 'play' on the Battle.net launcher I get an error screen which reads 'The application encountered an unexpected error'. This is the error code I get:

7F2E747F-1D3C-418D-81B0-9558079A2F0D

Can someone help me out please?
Hello Centurion,

Delete the Battle.net Cache folder:
battle.net/support/article/6141

Delete the Battle.net Tools folder:
battle.net/support/article/6504

If the issue persists, take a look at this article and follow all the steps there, including the advanced:
battle.net/support/article/6300064

If you still have issues after that, please create a MSInfo file and paste the content on the thread:
battle.net/support/article/200581

You can paste the content of the file on a web like Pastebin and provide us with the link. :)

______________________________________________________
Got feedback about the support I'm providing? Leave your comments here!
I've done all this and still doesn't work what next?
If the issue persists, please follow these instructions:

If you still have issues after that, please create a MSInfo file and paste the content on the thread:
battle.net/support/article/200581

You can paste the content of the file on a web like Pastebin and provide us with the link. :)


______________________________________________________
Got feedback about the support I'm providing? Leave your comments here!
Excuse me for my late response, but all of the sudden I could play Diablo again without doing anything... Thanks for the help though! :)
Glad to read that! Hope you can play without any further issues, but if it happens again don't hesitate on coming back so we can look into it. :)

Enjoy Sanctuary!

______________________________________________________
Got feedback about the support I'm providing? Leave your comments here!
Hello,

When I try to go through the Desolate Sands in Act II the game automatically kicked out.

EC697595-A3EB-47E1-A205-93693C36E1B3

Please check this issue.

Thank you.
Hello Dave93,

If you have an AMD graphic card, make sure you update your drivers. Some driver versions are known to cause crashes in that particular area of the game. From what I've heard from other players, the latest Crimson Edition driver should fix the issue.

______________________________________________________
Got feedback about the support I'm providing? Leave your comments here!
Hello Delmoryth,

Thank you for your reply. Yes, I have got AMD graphic card. I installed the latest driver and the problem was resolved.

Best regards,

Dave93
Hi,

Not sure if I should continue this thread or start another one. I'm getting an Application encountered an unexpected error while launching Diablo 3 after the latest patch on Friday.

I tried everything Delmoryth recommended above. I even uninstalled an reinstalled the game but I still get an error.

52402618-2B1C-419D-A3D5-949E86AC89CD

Thank you!

Edit: Fixed. My graphics settings had someone defaulted to something incorrect. By going through nvidia settings and re-optimizing I can get it to launch.
Same issue here. Only not up to date is that windows 10 doesn't have the new anniversary update yet because there are some fragile files that need to be finalised first before attempting any big scary update for windows that can screw a lot over.

Reinstalled all blizzard games.
"repaired" games - say they didn't need any
deleted caches, folders etc.
Ran malware program - nothing
Rebooted pc (multiple times)
Updated drivers
Administrator mode doesn't help.
No mods/overlays installed (never had)
Windows firewall doesn't have any restrictions in it

Also....Diablo III and Overwatch worked perfectly fine two weeks ago.

Anybody else here that is on the non anniversary update of windows 10 with this problem?
23/03/2016 10:24Posted by Delmoryth
Hello Centurion,

Delete the Battle.net Cache folder:
[url="https://battle.net/support/article/6141?utm_source=internal-support_forums&utm_medium=posting&utm_campaign=BlizzardCSEU&utm_content=solution"]battle.net/support/article/6141[/url]

Delete the Battle.net Tools folder:
[url="https://battle.net/support/article/6504?utm_source=internal-support_forums&utm_medium=posting&utm_campaign=BlizzardCSEU&utm_content=solution"]battle.net/support/article/6504[/url]

If the issue persists, take a look at this article and follow all the steps there, including the advanced:
[url="https://battle.net/support/article/6300064?utm_source=internal-support_forums&utm_medium=posting&utm_campaign=BlizzardCSEU&utm_content=solution"]battle.net/support/article/6300064[/url]

If you still have issues after that, please create a MSInfo file and paste the content on the thread:
[url="https://battle.net/support/article/200581?utm_source=internal-support_forums&utm_medium=posting&utm_campaign=BlizzardCSEU&utm_content=solution"]battle.net/support/article/200581[/url]

You can paste the content of the file on a web like [url="http://pastebin.com/"]Pastebin[/url] and provide us with the link. :)

______________________________________________________
Got feedback about the support I'm providing? [url="https://www.surveymonkey.com/s/Delmoryth"]Leave your comments here![/url]


there is one more thing to do i find it and i can shair it with you guys
there is a text file in this directory go to this directory and delete it and then relunch your diablo III
C:\Users\Documents\Diablo III\D3Prefs
have FUN :)
Worked!...

Just deleted the Battle.net Cache folder, thanks...
hi same problem:
066E297E-4D57-4440-ABC0-CC63F0460FE1
Hello NiborNaan,

Have you tried the suggestions that were posted already in this thread?

Kind regards

_______________________________________
What's your opinion?

https://www.surveymonkey.com/r/Kiemmaki
hi same problem:
2C4880A5-E5DF-41E4-9BC8-CA4CB901E2D5
hi

AB9E4BD9-4955-4779-B891-6100A24BB73A

I've tried everything ordered below. Still not working.

Please help thanks

pastebin done
https://pastebin.com/sBeeg2B9
can you help me with this error? i use win 10
16E59F82-263F-40F4-88B4-5A4AEEA9FBDD
Please help.. i dont know why... yesterday worked just fine..
And trying over and over again to play D3 i saw this:
https://gyazo.com/7c9e9f76ac4d80beed444d11d8a2cf8a
Look in the Right where all the games are...
Windows 10 PRO N.
I tryed all the things from clearing cache and deleting Battle net , moving to C.. deleting from appdata, and program data, all, and none worked, my last report:
1D7A2B9A-21C0-4F75-B7A1-EE954AFD774B
Hello, I've seem to have encountered a problem while trying to load Diablo 3.
I've deleted cache folders & battle net etc, and still having the same problem.
Report ID: 0A40AD5E-A34E-4E3D-97BA-158B49C87D8D

Join the Conversation

Return to Forum