No sound.

Technical Support
That fixed the sound for me. Thanks! Can't wait to get the fix for the cinematics!
That fixed the sound for me. Thanks! Can't wait to get the fix for the cinematics!
Thanks for the update XeroRenegade, has this worked for anyone else?

_____________________________________________________
Na na na na na na na na na na na na na na na na Survey!
https://www.surveymonkey.com/s/Tiogaradh
Same problem, the workaround also worked for me! Thank you! Will there ever be a fix, so that the soundquality can be high again?
@Kaeffchen The issue is still being worked on so hopefully we can get you back to normal settings soon.

_____________________________________________________
Na na na na na na na na na na na na na na na na Survey!
https://www.surveymonkey.com/s/Tiogaradh
Unfortunately this does not fix the problem.
03/09/2016 14:47Posted by Tiogaradh
Just to provide a potential workaround to this while the investigation continues.

[quote]1.Go to the Control Panel.
2.Open the Sound settings.
3.Right click on the default device and select Properties.
4.Select the Advanced tab.
5.Set their Sample Rate to the 16 bit, 44100 Hz (CD Quality) option found in the drop down menu.
6.Click on Apply and OK, and test out the game.


This worked for me but you guys need to fix this quick. It's not the best customer support unfortunately.
03/09/2016 14:47Posted by Tiogaradh
Just to provide a potential workaround to this while the investigation continues.

1.Go to the Control Panel.
2.Open the Sound settings.
3.Right click on the default device and select Properties.
4.Select the Advanced tab.
5.Set their Sample Rate to the 16 bit, 44100 Hz (CD Quality) option found in the drop down menu.
6.Click on Apply and OK, and test out the game.


This helped, thank you!

SB24Live!

_____________________________________________________
Na na na na na na na na na na na na na na na na Survey!
https://www.surveymonkey.com/s/Tiogaradh
27/08/2016 09:32Posted by Tiogaradh
Hey guys,
This is a known issue that we are investigating, as soon as we have any new information we will update.


03/09/2016 14:47Posted by Tiogaradh
Just to provide a potential workaround to this while the investigation continues.

1.Go to the Control Panel.
2.Open the Sound settings.
3.Right click on the default device and select Properties.
4.Select the Advanced tab.
5.Set their Sample Rate to the 16 bit, 44100 Hz (CD Quality) option found in the drop down menu.
6.Click on Apply and OK, and test out the game.



This worked for me - I have an old SB Audigy.
Worked for me on one computer but not the other.
I was suffering from no sound at all. I deleted the D3Prefs.txt file in Docs--Diablo3. Fixed it immediately.
Actually, never mind. Just closed out of the game and the Battle.net app and the game again has no sound. Repeated what I did earlier and again no sound. I give up.
I have the same problem, I got a SoundBlaster X-Fi Xtreme Audio and got no sound when in 24bit 48k, but work in 16bit 44.1k.
So a Blizzard tech and I just figured this out, for me anyway. I had to uninstall MSI Nahimic (which is an audio program from my Mobo, of which I don't use anyway). Fixed the audio issue immediately. Tested it several times and is a solid fix. If you have an MSI mobo this might be something that affects you if you're using the onboard audio. Good look muh lads.
03/09/2016 14:47Posted by Tiogaradh
Just to provide a potential workaround to this while the investigation continues.

1.Go to the Control Panel.
2.Open the Sound settings.
3.Right click on the default device and select Properties.
4.Select the Advanced tab.
5.Set their Sample Rate to the 16 bit, 44100 Hz (CD Quality) option found in the drop down menu.
6.Click on Apply and OK, and test out the game.


_____________________________________________________
Na na na na na na na na na na na na na na na na Survey!
https://www.surveymonkey.com/s/Tiogaradh


This workaround did it's job for me.
Thanks!
The problem with that fix is that when I do that, I don't have sound in HearthStone anymore...
I had the same issue with Starcraft II since the Windows 10 anniversary update, but there was a fix (a line to add in variables.txt soundprovider=DSOUND) and I was expecting the same kind of thing for Diablo.
03/09/2016 14:47Posted by Tiogaradh
Just to provide a potential workaround to this while the investigation continues.

1.Go to the Control Panel.
2.Open the Sound settings.
3.Right click on the default device and select Properties.
4.Select the Advanced tab.
5.Set their Sample Rate to the 16 bit, 44100 Hz (CD Quality) option found in the drop down menu.
6.Click on Apply and OK, and test out the game.


_____________________________________________________
Na na na na na na na na na na na na na na na na Survey!
https://www.surveymonkey.com/s/Tiogaradh

Doesn't work in may case. (Funnily enough, I tried it independently of this thread after reviewing Diablo's debug log)

Only disabling Sound Blaster enhancements fixed that.

Any ETA on fix? Is it possible to provide some further information to help with fix?
03/09/2016 14:47Posted by Tiogaradh
Just to provide a potential workaround to this while the investigation continues.

1.Go to the Control Panel.
2.Open the Sound settings.
3.Right click on the default device and select Properties.
4.Select the Advanced tab.
5.Set their Sample Rate to the 16 bit, 44100 Hz (CD Quality) option found in the drop down menu.
6.Click on Apply and OK, and test out the game.


_____________________________________________________
Na na na na na na na na na na na na na na na na Survey!
https://www.surveymonkey.com/s/Tiogaradh


Thx a lot, this work for me!
tried the workarounds and nothing worked for me.sound works fine for other games
My audio is defaulted to 16 bit, 44100 Hz. It doesn't work for me, I'm using a Razor Kraken 7.1 Chroma.

Join the Conversation

Return to Forum