Keep getting error BLZBNTBTS0000005B

Technical Support
Hi there, I'm trying to install D3 with no luck... Every time, the installer starts and then I'm faced with an error screen saying "Something went wrong while trying to install." I've clicked the More Help link and followed all the steps provided but no luck. My specs are:

MacBook Pro (Retina, 13-inch, Early 2015)
Processor: 2.9 GHz Intel Core i5
Memory: 8 GB 1867 MHz DDR3
Graphics: Intel Iris Graphics 6100 1536 MB

I'm running El Capitan 10.11.5 – in which I have upgraded to after trying all of the above on Yosemite.

I've also tried to delete the Battle.Net folder.

Edit: I've tried running the battle.net World of Warcraft installer and that works a treat.

Any help would be appreciated!

G
I'm in the same position as you, just downloaded D3 and tried to install. Same error: BLZBNTBTS0000005B.

I'm also running El Capitain upgraded on a retina macbook.
Ok sweet think we may be in business. I navigated to the folder /Users/Shared/Battle.net/Setup/diablo3. In that folder, at least in mine is Diablo III China Setup.app (not sure why it says china lol, I'm in the US). So I ran it and the setup was able to complete. It also gives you a regional option and mine was already set to "Americas". Once the Battlenet setup was complete, I started the install for Diablo III with no problems. It justed reached the "playable" stage of the download so I'll see if it runs fine and report back. Good luck!
Hey Godal, the method I posted above works for me with no problems. Diablo III installed and runs fine, I was able to create a new character and start playing no problems. Good luck hope this works for you too.

-cat
Thanks for the update cat, do these steps help you Godal?

_____________________________________________________
Na na na na na na na na na na na na na na na na Survey!
https://www.surveymonkey.com/s/Tiogaradh
Hey, I´m from México, same error, the Diablo III China setup works on OS X El capitán 10.11.5 (completely updated).
The china-setup worked fine and I am in Germany. Thank you very much!
I am still playing ptr & it cut off why
Hi,

I have the same problem. I just got a new Macbook Pro with El Capitan 10.11.5.

I tried every solution I could find on the Blizzard forums, but none works. I found the China installer and the problem stays the same.

The Battle.net app just keeps 'bouncing' in the low menu bar. And sometimes I get the yellow (!) error stating something went wrong/error.

Any solutions?

I tried:

- rebooting
- reinstalling every file
- the DNS solution
- removing everything with the agent file
- China installer as described above

Nothing seems to help and I got a fresh instal on a brand new macbook pro.

Would seriously need some help.

Thanks in advance!
i have the same prob and no solution yet
China Setup works also for MacOS Sierra Beta
This worked for me!
MacBook Pro 13-inch El Capitan.
Currently downloading, the China download seems to be working.
Where do i find the China setup? From Danmark here, same problem, why dont blizzard fix it :O
FYI I tried the China install method and it works; new MacBook Pro 2.8 quad-core, 16GB, retina 2GB video RAM, El Capitan. Why Blizzard can't simply figure out what's different between the "regular" plain vanilla installer and this "China" one and simply modify their normal one to incorporate whatever works on the "China" version into it is totally beyond me. It appears to be simple laziness that creates a LOT of extra work on the part of us Mac users simply to get their product (advertised as being Mac compatible) to function. I wonder how many people have simply given up and rubbish-binned the game out of frustration or how many potential sales have been lost due to the word on the street being that Battle.net / D3 doesn't work on El Capitan machines... I'll bet for every one of us who's taken the time to chase this issue down and research it and actually find a workable solution there are probably a hundred people who either give up or don't bother buying in the first place due to the feedback floating around out there about incompatibility w/ El Cap. Blizzard - it's in your interests to address this and shout it from the highest mountain that you have a working El Capitan installer - here it is and come get it!

Anyway, glad to be able to (finally!) run this game again! Sheesh!
That China thing worked. Blizzard Blizzard.... why U no fix this? Wasted 3 hours of my life trying to set this thing up.
I still cannot get this to work on my computer. The 'china app' method does not work for me. This is ridiculous!
I wonder what blizzard is up to. This is no random error, they're obviously trying to access sensitive information and I wonder to what end.
I tried the China setup thing and it does work, however it asks me to login Chinese battlenet account. My account is not Chinese account so I cannot login. and the region seems set on China, there is NO other region option !!!! OMG I now chose to download without login, its downloading now, and i hope i can choose to alter region when the game fully is downloaded. finger crossed.

Join the Conversation

Return to Forum