Error code 1016.....ever since new patch

Technical Support
Been getting this regularly for the past week as well. It looks like the usual case where we're told to do this and that to try and fix it, but nothing works because it's always on Blizzard's end and it will silently get fixed eventually. So when is it getting fixed?
Please make sure you go through the steps I linked previously, as that seems to fix this issue for most.

Another thing you could try, is to swap to Google DNS.
______________________________________________________
Have a few seconds to spare? Let me know how I'm doing!
https://www.surveymonkey.com/r/Nenyasqi
Hi,

this error is getting out of hand. I am getting the error since this morning. Yesterday everything was working fine. I've reset the router and am allready running the google DNS. Nothing helps. I am also getting disconnects from battle.net about every 30 seconds.... I am unable to play HC this way :\

Any other ideas?
Hey boschi,

Please run a WinMTR test whilst experiencing the connection issues. Let that run for about 5 to 10 minutes, and post the results here.
______________________________________________________
Have a few seconds to spare? Let me know how I'm doing!
https://www.surveymonkey.com/r/Nenyasqi
I am having this problem also. I ran the repair tool and my drivers are recently updated. I don't wish to sound like I'm not willing to help myself but having looked at the Google DNS linked page, I am not happy with having to change the setting. I don't know enough about it to know if that would be the cause of other problems that might develop. The page itself says don't do it unless you are competent in that area....I'm not. Also my notepad (6 months old) works fine in every other way.

Is there anything else I can do? I prefer HC and had rebirthed a season character but the dc's add a level of risk I don't want to take.
Same here.
Been having this problem during last season, but I thought the new patch will get rid of it... No luck. 3-4 EC:1016 Disconnects per day can be quite discouraging.
Tried the troubleshooting steps too but didn't help much. Makes me wonder if buying a DLC for an 'unstable' game was a mistake on my part.
I know you guys are trying to help but as far as I can see the troubleshooting only trying to check the client side, while it is clear, that the problem is on the server side. I mean; a few patches ago there were no disconnects of any kind (for me at least). Also no DCs with Starcraft2 or Hots.

I meant no disrespect or offense

Join the Conversation

Return to Forum