Nintendo Switch - Can't connect to friends

Technical Support
Hey support,

I'm trying to connect to a friend on nintendo switch and even after both of us changing out NAT types to type A, we still can't connect with each other.

I can connect with this friend in every other Nintendo Switch game with zero issues. I can even connect to every other Diablo user via "Quick Match" with no errors.

The error message I'm getting is "There was a problem joining the game".
Hello LightUrple,

Most likely, this here matches your issue.

Kind regards

_______________________________________
What's your opinion?

https://www.surveymonkey.com/r/Kiemmaki
Hey @Kiemmaki,

It appears that you didn't even read the problem description here.

"I can connect with this friend in every other Nintendo Switch game with zero issues. I can even connect to every other Diablo user via "Quick Match" with no errors."

This means he HAS a paid sub, otherwise you cannot play online at all, and you sent him a link mentioning you have to have a sub? Did you even read the whole issue description?
I bought an online sub yesterday with my friend, we can't connect to each other either, same error message, and we can pay other Nintendo games online together, so it's a DIABLO 3 SWITCH VERSION issue!

Please fix your game, I've seen many threads in reddit with users having this same error message.

Here's another example too: https://us.battle.net/forums/en/d3/topic/20769748901

We tried all sorts of hoops and loops yesterday to get this working, and failed, when we never have issues at all playing other games.

FIX
YOUR
GAME
Want to bet that they will just ignore us and this problem?
I am having the same issue. I cannot join any of my friends in Diablo. Sometimes, it will randomly work. I am only having this issue in Diablo. I play other online games fine on the Switch.
07/11/2018 16:26Posted by Arthelon
Want to bet that they will just ignore us and this problem?


I hope they don't, because not being able to play with friends online is a huge problem in a game like diablo. I'm being asked by friends how the port is, and I keep telling them, "It's awesome, but don't buy it, online play with friends is not working, and we keep getting ignored by blizzard's support".
Same problem here.
Joining my wife's game does not work.
even when i see her online on the friends list can play other games with her.
local play works but i do not get the progression.
Joining others' games works fine as well.
"Joining friend's game thru internet is the only thing does not work"

I am using Arris SBG6900AC.
None of the solutions here worked.
only solution i found was to switch router to "Bridge mode"
meanwhile i cannot use my internet on the computer or phone
but somehow it fixes the diablo 3.

Fix this problem asap, it is a great port of the great game.
Dont ruin my experience with this game by not fixing this little glitch.
FYI, your friends appear online, even if they haven't got a subscription, and if they don't have a subscription, you can't join them, which can explain why you may be able to join some friends and not others.
It does sound like this isn't the issue for everyone though. I hope Blizzard sort it out for you guys.
I can’t connect with my friend on switch , both have internet and can play every other game together . Is that a problem of your game? Of course we have an internet subscription...
Same issue here... i've forwarded every port I can... tried IP Passthrough... both my Switch and my friend's Switch is updated and Diablo is updated. The only thing either of us can do is Quick Join, then invite each other. We can't play just us two. I can't invite him to my Party and he can't invite me to his. We get the subject error every time. This is pretty ridiculous. I just bought this Switch and Diablo and i can't even play with my friend without some janky BS.
So the date is now 11/15/2018 and my friend and I both have the paid subscription on Nintendo switch. Please blizzard!! Fix this. Otherwise I want my money refunded in full of the switch diablo bundle I purchased. Because your selling a product and I feel gaming companies should be held at the same standard as any other company. I am not satisfied!!
Hello,

Have you tried the suggestion here?

Kind regards

_______________________________________
What's your opinion?

https://www.surveymonkey.com/r/Kiemmaki
15/11/2018 09:34Posted by Kiemmaki
Hello,

Have you tried the suggestion https://us.battle.net/forums/en/d3/topic/20769578851#post-12" class="bml-link-url2">here</a>?

Kind regards

_______________________________________
What's your opinion?

<a href="https://www.surveymonkey.com/r/Kiemmaki


Yes i have, it does not work.
I also open ports that nintendo says to as well. still not working.
15/11/2018 09:34Posted by Kiemmaki
Hello,

Have you tried the suggestion https://us.battle.net/forums/en/d3/topic/20769578851#post-12" class="bml-link-url2">here</a>?

Kind regards

_______________________________________
What's your opinion?

<a href="https://www.surveymonkey.com/r/Kiemmaki


So it’s really irritating for your customer base to be having this problem and there be no response. How about you come up with a. Solution instead of linking me to something others have already posted. Ports open on routers has nothing to do with this. It’s your software that isn’t working. So let’s straigiten the stoke right now.
Ive been experiencing the same issue for the past almost 5 days... ive been booted from games and lost TONS of loot because of this random disconnect. The only solutions that anyone has been linking us to is quite literally ONLY NAT TYPE ISSUES. they dont resolve what most here are talking about.

I have 4 problems all related to server connection.
The first: i try to join a public game and get a message box that says "cannot connect to diablo servers at this time. Please try again later."
Second: i manage to find a match and go to join. If i manage to get past the second box that says that the host has left game amd to try another host. If i manage to get past that then i get greeted with the same message after a very long loading screen.
3rd: if i manage to join a game and not have any problems through the loading screen or main menu then i am disconnected durring imortant portions of the game. Example, wimsydale, the vault, or greater rifts. The only way i am able to make it through these areas are if i do it alone... i cant push GR 45+ ALONE...
4th: if im booted from any of these areas it places me back in new tristram with no way to go and get that loot or ability to level up gems...

I dont know whats wrong with your game but its very clear that its your game and not my network as i have no issues with any other games and their connection to the networks.

Stop giving me router help issues... its not my router. Just fix your damn game. It didnt have any issues before you patched it.
Also i have no issue connecting locally through lan or when were both on the same router. Only when i try to connect to members of the public.
look on the bright side you can do the survye thing and and actualy type back how bad a support that dude is. he has no idea what hes saying, should be banned from responding to people and fired
Hello,

If the above steps didn't work for you, please submit it as a bug report. I am closing here now since it can't be solved by Customer Support.

Kind regards

_______________________________________
What's your opinion?

<a href="https://www.surveymonkey.com/r/Kiemmaki

Join the Conversation

Return to Forum