Grey screen after pressing Play

Technical Support
I found how to do !

You must change in your documents/diablo 3/D3prefs.txt

Open it, you change the line who it say :

"disable trilinear filtering "0" to "1".
"hardware class "0" to "1"

You close your txt and you save it of course!

You run one time the game and when it's say not compatible card you make escape.

If you are a grey screen close your game and go in the d3prefs.txt

You see

"disable trilinear filtering become "0" so change to "1".
"hardware class become "0" so change to "1"

Right click on this txt => properties => read only ! ACcept ok

Launch the game and when you see the message uncompatible make escape ! AND IT'S RUN FOR ME §
I adjusted my video card to what the D3prefs was set to, I didnt have to replace 0 with 1 or anytying and it finally came up fine.
I have been having the same problem. I went into the diablo 3/D3prefs.txt file and changed what you said to change and the game starts up because i can hear the epic main menu music, but my monitor turns blue and says "out of range" i cant figure out how to change the resolution settings to work with my monitor. help with this aswell please? :D
Thank you Ärcane for trying to help; unfortunately your solution doesn't work for me either. I feel sorry to read there are alot of people with the same issue, I hope someone will give us some explanation about it soon.

I have just tried this again myself, you still get a grey screen for about 3secs then login screen appears.

Basically, I load launcher, go options, hit reset game preferences and then confirm, hit play, grey screen then login.

If i then quit game and try load without hitting reset game preferences all I get is grey screen with d3 music in background and nothing else, no errors etc.

Is this the same problem people are having or are you getting errors etc?
My mother just had this happen.

Got disconnected from the game - happens a lot to her, which is strange considering we are connected to the same router and she has a better connection to it than I do - and when she tried to log back in, stuck on grey screen.

She has music off, so it's hard to say if there should be music playing.

Tried resetting prefs, now it's a black screen instead of a grey one, but no other change.

It would REALLY be nice to have a blue reply more eloquent than, "Update your graphics drivers" considering I did that for her earlier today. You want one newer than the latest driver, perhaps?
Who can help me with finding D3Prefs.txt? So I can change 0 to 1. Really please. Email me Explain it to me or do it on remote assistance. Thanks
I have the grey screen too, but only momentarily.. it then proceeds to load. I don't know what caused it, but it's only just started happening for me a few hours ago.
Well, I just tried the Adapa method and it worked like a charm!
Thank you so much

@RamboX you simply find the D3Prefs.txt in your Documents/Diablo III folder
reset game preferences works here,must do it every time ,all heros and levels and stuff is saved and still there so i wonder what things are resetted then,i have not installed latest drivers,that is usually not the problem,if I dont hit reset I also have the grey screen,I have hardware class 4,,didnt help changing it
It was the same for me, tho i thought it must be the GFX but it wasnt, Its the error 3007. When it freezes again, wait the minuits out and you will be back in the word "disconnected"

This morning I started to encounter the same problem. I launch, get a grey screen and background music. I played all day yesterday without the glitch.

Adapa's method didn't work for me.

I'll try updating my drivers now.

edit: Drivers up to date. Does anyone else having the problem use mumble? I noticed it had locked up, force quit it and the game's been fine ever since. Something to do with the overlay?
also having the same issue with the grey screen.
Can we get an update on this from a blue again? Still no fix and there are people here who can't play.

EDIT 1: I have a AMD Radeon HD 6310

it's on neither the poor performance or the unsupported list.
15/05/2012 16:26Posted by Kearia
When i click play i get a black screen and a floating bubble saying "Input not supported" i updated my drivers to ATI Catalyst and installed the Catalyst hotfix but it still does the same thing. Anyone can help?

I had the same issue. All ATI Catalyst drivers are upto date and work perfectly for WoW and a multitude of other games but D3 just goes to a black screen with the "unsupported signal" message.
Open the Catalyst Control Panel (right click desktop and select it from pop-up menu), go into Monitor Properties 0 => Attributes and de-click the EDID option and then change the resolution to a lower resolution (eg.1024x768).
This has now allowed me to play D3 on my Sony Bravia TV which is only recognised as "plug'n'play" by computers.
I get a grey screen but after a few seconds it loads into the game.

Is this grey screen actually normal then? (not counting the freezing)
Same here. Tested with 2x Radeon HD 6850's with the latest (updated like a day ago) Catalyst drivers on a Win7 64 pro system.

I thought that the grey screen was normal, as it only appears for less than a second or so. At least for me it does. =/
Im having the same problem, i click play and my screen goes grey and says drivers are out of date when i updated them and now its just a blank grey screen!
:( I don't even have the file D3pref.txt that you talk about in my download of it..
Have you searched for it on your machine? Like from Windows Explorer if you're using Windows.
Just do like this:
Put in another screen/tv that support widescreen then you just start the game and change the options to regular and not widescreen and then put your old screen back, that worked for me :)

Join the Conversation

Return to Forum