"Failed to read a required file"

Technical Support

Installation halted whilst downloading, so I killed it off and tried to restart it. It didn't progress so I went back to CD setup exe and ran that again which gives me the error:

"Failed to read a required file. Please close all other applications, temporarily deactivate your anti-virus software, and try again."

Any ideas??
In the meanwhile, I managed to un-install (with some errors and some manual deleting.. but got there) - Started install process again and update if it gets there but if anyone has any ideas as how to avoid it happening again I'd appreciate them :)
Same to me -.- please write if your guys find out to fix it:)
Yup im stuck also
Jus to update, a full un-install and re-install of D3 worked
Just delete patch-base-[...].mpq files from Diablo III\Data_D3\PC\MPQs\Cache\base and start diablo launcher again. should help
I have gotten the same message over and over and have done eveything that blizzard said to do to try to get the game installed into my computer. But i keep getting the same message " Failed to run required program (Blizzard Setup) Wait one minute and try again and if that doesnt work please restart your computer and try again." I have the collectors edition and I am on the administors account on my computer. Ive been trying since 1:30 am when we brought the game home. What fixs this? Getting really upset and have been trying to talk to someone in customer service but the wait time is 99 minutes??????? All i want to do is play this game. I paid for it plus my account on battlenet so what fixs this problem????
Change name of Diablo III folder, where you are instaling it, to Diablo IIIa. Lunch Installer again. It will not find previous instalation and will try to start from beggining. Select "Change" directory of install and then (in windows explorer) change folder name of Diablo IIIa (where previous instaled files are) to Diablo III and show this directory to installer. It will proceed from moment that its stoped.
I have the same issue, except that I already downloaded the game and even played once, but since they brought down the servers, I get this error whenever I open the game at the initializing mini-screen. Why would it have worked for a couple hours and now I can't even open the game.
Blues? Any suggestions?

I had hoped that this would be fixed after the servers were brought back up, but nope. still happening
Close D3 launcher

press Ctrl+shift+esc

look for Agent.exe

end process

start launcher
Thanks! Killing Agent.exe worked!
Confirmed. Killing Agent.exe worked for me also.
What seems to happen is the launcher crashes. All you have to do is go into task manager and kill "agent.exe" and it should start back up again. If you're a noob... reboot. Worked for me.
Just felt like saying that killing agent.exe seems to be the fix true fix.

But damn the launcher for crashing when I was hoping it would be done by the time I got home from work.
I had the exact same problem. Someone said close the "Agent.exe" and so i did. Everything seemed like it should but now its stuck on "Launching" and has been so for a while. Any ideas?
This worked for me:

- Stop any process like agent.exe and any other from blizzard.
- Go to "C:\Program Files" and rename your "Diablo III" to "Diablo IIIa" or any other name you want.
- Start the Diablo III installer, let it begin, let it start the download, close the installer after a minute or so from X.
The installer will create a new folder "Diablo III" in your "C:\Program Files".
- Copy all your *.mpq files from your old "Diablo IIIa\Data_D3\PC\MPQs" to the new created "Diablo III\Data_D3\PC\MPQs".
- Start the installer again, it will hat to download only about 70 MB and you can play.

Have fun. ;)
Started the download once I killed Agent.exe! Thanks!
Close D3 launcherpress Ctrl+shift+esc look for Agent.exeend processstart launcher


Join the Conversation

Return to Forum