error 5012

Technical Support
Anyone here know how to fix error 5012 when adding a freind? Iv'e been searching for an answer, but cant seam to find one :(

plz help..
Me too... no solution for me now...
Me too...
same here, can't play with friends.
Really frustrating
all my brothers had no problem adding friends, but they can't add me and I can't add them.. why is it just my game.. frustrating!
Its the same for me
Me too
I saw another thread where a Blizzard worker told this:

"Hello,

Can you check that Parental Controls aren't on your account and that Real ID is enabled?

You should be able to check all these via the account management page:
https://eu.battle.net/account/management/"

It worked nicely for me, could help with you all too :)
I can't use the link. It only write, the page is not found -.-
I can't add my brother. van someone help me ?
Help would be appreciated. Adding a person via Battletag worked after several relogs, real ID attempt returns error 5012.
Sry for german text but my english is terrible^^

Moin alle zusammen.

So ich hatte das Problem selbst und es selbst gelöst.

1tens: ingame: Spieleinstellung > Optionen > Account > Region > muss bei allen gleich sein... wahrscheinlich Europa^^

2tens: battle.net > einloggen > Account > Einstellungen > Freundschaftssystem & Nachrichten > Häkchen bei Freundschaftssystem aktivieren

Hoffe es hilft. Bei mir hat es gefunzt nachdem ich 2 Stunden bei der Servicehotline mal wieder umsonst gewartet habe.^^

Andere Lösung fällt mir selbst ned mehr ein.
Viel Erfolg beim lösen des Problemes.
this was my solution for our all problem
How can I accept my friend? I mean he just added me as friend, but I can't see him as my friend ?
Same problem, only with the curiosity, that i have parental controls, which I nor my parent's have activated. I am in no posession of an email, that can recieve the letter which could remove the parental controls. Im quite desperate actually, no idea what to do. help ?
Spent 2 hours ctrl pasteing my password to log onto the full servers....then I enabled realid on battle.net = me dc... -.- can't get back online
Turning on 'real id' settings in my account settings fixed this problem. Thanks for the tip! Im not sure why it was off TBH, It always worked fine in WOW and SC2
This is also my problem. Does anyone know anything about this parental control glitch?
Problem is solved by logging into battle.net and enabling parental controls for RealID.

This won't be a problem for WoW players that have played since RealID came on, but for those who have not played a Blizzard game before or stopped playing WoW before RealID came in, you need to do this.
Any way to fix this without enabling RealID?
go to battle.net account management and the click parental control and enable real id. this works fine.

Join the Conversation

Return to Forum