After installation i press play nothing happens

Technical Support
I got the dvd diablo 3 when i install the game there are no problems.
when i press play then there isnt anything happening.
when i look in the system manager i can see de diablo3.exe is running.
when i press play again i get an error saying that diablo3.exe is already running.
i reinstalled the game. didt the same thing.
then i downloaded de installer from online, en even whit this one it still doenst work.
accept i see de diablo3.exe running in system manager.

please anyone help i am technical whit computers but cant find out why it doenst works!
Same exact problem I have.

Seen several threads about but none with a solution.
Blue poster adressed networking issue but that didn't fix it.
maybe jou can try this for me??
have to work til 7

The Diablo III Launcher relies on Internet Explorer and the Adobe Flash plug-in.

First, please make sure your Internet Explorer installation is up to date by either running the
Windows Update utility or downloading the latest version from here:

Connection Settings

Please bear in mind that incorrectly configured Internet Explorer settings can prevent the Launcher
from connecting to the internet. Please work through the following steps to ensure that Internet
Explorer is not connecting through a Proxy and that it is not in Offline Mode:

- Launch Internet Explorer and click Tools -> Internet Options -> Connections -> LAN Settings

- Disable any Proxy connection/server

- Disable Automatically Detect Settings and click OK

- Click File and ensure Work Offline is not enabled

Compatibility Mode

Please make sure that the game is not set to run in Compatibility mode:

- Right-click the game icon on the Desktop and choose Properties

- Click the Compatibility tab

- Disable the ‘Run this program in compatibility mode for’ option

and maybe windows 7 needs te turn of the UAC that is if there is a administrator installation or user installation
Downloading and installing the latest AMD driver hotfix fixed this for me.

Thanks for you

Link to driver:
Same problem here. I'm glad I had the good sense to try my friend's guest account before I wasted my money. This game has been in development far too long for stupid problems like this. I'll probably give it a couple more tries in the next week or so. After that, I'm done with Blizzard. You can safely expect a lot more than this from most free games now. Develop something for a decade only to have it completely fail after wasting hours of my time downloading and installing is just ridiculous. I mean shouldn't there at least be some error reported? If Blizzard can't get things right anymore, then they should just give out refunds, file for bankruptcy, and get out of the way so that gaming companies who know how to do proper releases in a timely fashion have a deserved share of the spotlight. It looks more and more like Blizzard peaked with the early days of WoW (if not with Diablo 2). It sure looks like we're now witnessing the long slide to the bottom. Maybe Blizzard could sell the rights and the alpha/beta code they've tried to sell as finished to another gaming company that actually knows how to code for major releases.


P.S. - I have a brand new HP desktop with a fresh installation of Windows 7 Ultimate. Everything is fully up to date, and I have had no other problems with any of the software on it. Basically, it is the target equivalent of the broad side of a barn. If Blizzard can't make it work on this extremely common, current setup, then those of you who have it working should count yourselves extremely lucky. But not too lucky. They'll probably break yours with the next patch.
"AMD Catalyst™ 12.4a Hotfix Driver

Diablo III
The Elder Scrolls V: Skyrim"

I've been having trouble with Skyrim for months and it took Diablo 3 for me to fix it... I am an idiot.
I have an nvidia card but not sure which one. I havent been able to open the game once, it runs in the background but wont actually open, just says "Diablo 3 is already running". errrrr thanks for nothing, i know its running, now tell me how to open it!!
Downloading and installing the latest AMD driver hotfix fixed this for me.

Thanks for you

Link to driver:

didn't worked :/
I struggled for several hours with this. Never had a problem like this with any PC game since the win 98 days. In the end I'm not exactly sure what solved it, seemed almost random:

1. uninstalled the game and deleted the agent/blizzupdater folders before reinstall (did not solve).
2. Ran as administrator installers and launchers (did not solve)
3. updated agent and blizzupdater versions from website outside of blizzard (seemed to make a difference in how the launcher and updating worked, but no go still.)
4. checked Iexplorer settings and reinstalled flash (same)
5. lots of frustated reinstallations of game, ending agent tasks through ctrl alt delete, checking/unchecking"run as administrator" from agent, launcher and updater. In the end it seemed to randomly work by UNchecking run as adminstrator on everything. after having first entered launcher with admin ON and getting an error message "important file cannot be found/accesed" or something like that . I didnt have adminstrator checked in the first place, and did try to uncheck earlier in the process, so I'm really no wiser as to what I actually did... but maybe it could help someone else on their way anyway.

Join the Conversation

Return to Forum